diff --git a/ghostscript-pksmraw.patch b/ghostscript-pksmraw.patch
new file mode 100644
index 0000000..826e000
--- /dev/null
+++ b/ghostscript-pksmraw.patch
@@ -0,0 +1,12 @@
+diff -up ghostscript-8.62/src/gxclrast.c.pksmraw ghostscript-8.62/src/gxclrast.c
+--- ghostscript-8.62/src/gxclrast.c.pksmraw	2008-03-31 17:24:32.000000000 +0100
++++ ghostscript-8.62/src/gxclrast.c	2008-03-31 17:25:33.000000000 +0100
+@@ -2606,8 +2606,6 @@ static int apply_create_compositor(gx_de
+         rc_increment(tdev);
+         *ptarget = tdev;
+     }
+-    if (code < 0)
+-        return code;
+ 
+     /* Perform any updates for the clist device required */
+     code = pcomp->type->procs.clist_compositor_read_update(pcomp,
diff --git a/ghostscript.spec b/ghostscript.spec
index f72095a..637163c 100644
--- a/ghostscript.spec
+++ b/ghostscript.spec
@@ -5,7 +5,7 @@ Summary: A PostScript(TM) interpreter and renderer.
 Name: ghostscript
 Version: %{gs_ver}
 
-Release: 2%{?dist}
+Release: 3%{?dist}
 
 License: GPLv2
 URL: http://www.ghostscript.com/
@@ -20,6 +20,7 @@ Patch3: ghostscript-noopt.patch
 Patch4: ghostscript-fPIC.patch
 Patch5: ghostscript-runlibfileifexists.patch
 Patch6: ghostscript-system-jasper.patch
+Patch7: ghostscript-pksmraw.patch
 
 Requires: urw-fonts >= 1.1, ghostscript-fonts
 BuildRequires: libjpeg-devel, libXt-devel
@@ -92,6 +93,9 @@ rm -rf libpng zlib jpeg jasper
 
 %patch6 -p1 -b .system-jasper
 
+# Fix pksmraw output (bug #308211).
+%patch7 -p1 -b .pksmraw
+
 # Convert manual pages to UTF-8
 from8859_1() {
 	iconv -f iso-8859-1 -t utf-8 < "$1" > "${1}_"
@@ -266,6 +270,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgs.so
 
 %changelog
+* Mon Mar 31 2008 Tim Waugh <twaugh@redhat.com> 8.62-3
+- Fix pksmraw output (bug #308211).
+
 * Tue Mar  4 2008 Tim Waugh <twaugh@redhat.com> 8.62-2
 - No longer need CVE-2008-0411 patch.
 - Don't ship URW fonts; we already have them.