9.07.
Resolves: rhbz#911517
This commit is contained in:
parent
982e6b6614
commit
b4ed15bc8b
@ -1,11 +1,11 @@
|
|||||||
diff -up ghostscript-9.02/cups/gdevcups.c.gdevcups-debug-uninit ghostscript-9.02/cups/gdevcups.c
|
diff -up ghostscript-9.07/cups/gdevcups.c.gdevcups-debug-uninit ghostscript-9.07/cups/gdevcups.c
|
||||||
--- ghostscript-9.02/cups/gdevcups.c.gdevcups-debug-uninit 2011-03-07 15:40:13.000000000 +0000
|
--- ghostscript-9.07/cups/gdevcups.c.gdevcups-debug-uninit 2013-02-14 07:58:16.000000000 +0000
|
||||||
+++ ghostscript-9.02/cups/gdevcups.c 2011-04-04 12:40:48.995443449 +0100
|
+++ ghostscript-9.07/cups/gdevcups.c 2013-02-14 17:16:59.677951232 +0000
|
||||||
@@ -815,6 +815,7 @@ cups_get_matrix(gx_device *pdev, /* I -
|
@@ -830,6 +830,7 @@ cups_get_matrix(gx_device *pdev, /* I -
|
||||||
dprintf4("DEBUG2: PageSize = [ %d %d ], HWResolution = [ %d %d ]\n",
|
dmprintf4(pdev->memory, "DEBUG2: PageSize = [ %d %d ], HWResolution = [ %d %d ]\n",
|
||||||
cups->header.PageSize[0], cups->header.PageSize[1],
|
cups->header.PageSize[0], cups->header.PageSize[1],
|
||||||
cups->header.HWResolution[0], cups->header.HWResolution[1]);
|
cups->header.HWResolution[0], cups->header.HWResolution[1]);
|
||||||
+ if (size_set)
|
+ if (size_set)
|
||||||
dprintf4("DEBUG2: HWMargins = [ %.3f %.3f %.3f %.3f ]\n",
|
dmprintf4(pdev->memory, "DEBUG2: HWMargins = [ %.3f %.3f %.3f %.3f ]\n",
|
||||||
pdev->HWMargins[0], pdev->HWMargins[1], pdev->HWMargins[2],
|
pdev->HWMargins[0], pdev->HWMargins[1], pdev->HWMargins[2],
|
||||||
pdev->HWMargins[3]);
|
pdev->HWMargins[3]);
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up ghostscript-9.05/base/gsicc_manage.c.icc-missing-check ghostscript-9.05/base/gsicc_manage.c
|
diff -up ghostscript-9.07/base/gsicc_manage.c.icc-missing-check ghostscript-9.07/base/gsicc_manage.c
|
||||||
--- ghostscript-9.05/base/gsicc_manage.c.icc-missing-check 2012-02-08 08:48:48.000000000 +0000
|
--- ghostscript-9.07/base/gsicc_manage.c.icc-missing-check 2013-02-14 07:58:13.000000000 +0000
|
||||||
+++ ghostscript-9.05/base/gsicc_manage.c 2012-04-04 12:39:29.151888287 +0100
|
+++ ghostscript-9.07/base/gsicc_manage.c 2013-02-14 17:15:48.974654828 +0000
|
||||||
@@ -140,6 +140,8 @@ gsicc_set_iccsmaskprofile(const char *pn
|
@@ -144,6 +144,8 @@ gsicc_set_iccsmaskprofile(const char *pn
|
||||||
if (str != NULL) {
|
if (str != NULL) {
|
||||||
icc_profile = gsicc_profile_new(str, mem, pname, namelen);
|
icc_profile = gsicc_profile_new(str, mem, pname, namelen);
|
||||||
code = sfclose(str);
|
code = sfclose(str);
|
||||||
@ -10,21 +10,21 @@ diff -up ghostscript-9.05/base/gsicc_manage.c.icc-missing-check ghostscript-9.05
|
|||||||
/* Get the profile handle */
|
/* Get the profile handle */
|
||||||
icc_profile->profile_handle =
|
icc_profile->profile_handle =
|
||||||
gsicc_get_profile_handle_buffer(icc_profile->buffer,
|
gsicc_get_profile_handle_buffer(icc_profile->buffer,
|
||||||
@@ -517,6 +519,8 @@ gsicc_set_srcgtag_struct(gsicc_manager_t
|
@@ -593,6 +595,8 @@ gsicc_set_srcgtag_struct(gsicc_manager_t
|
||||||
icc_profile =
|
icc_profile =
|
||||||
gsicc_profile_new(str, mem, curr_ptr, strlen(curr_ptr));
|
gsicc_profile_new(str, mem, curr_ptr, strlen(curr_ptr));
|
||||||
code = sfclose(str);
|
code = sfclose(str);
|
||||||
+ }
|
+ }
|
||||||
+ if (str != NULL && icc_profile != NULL) {
|
+ if (str != NULL && icc_profile != NULL) {
|
||||||
gsicc_init_profile_info(icc_profile);
|
gsicc_init_profile_info(icc_profile);
|
||||||
break;
|
cmm = gsCMM_DEFAULT;
|
||||||
} else {
|
/* Check if this object is a devicelink profile.
|
||||||
@@ -1127,6 +1131,8 @@ gsicc_set_device_profile(gx_device * pde
|
@@ -1516,6 +1520,8 @@ gsicc_set_device_profile(gx_device * pde
|
||||||
icc_profile =
|
icc_profile =
|
||||||
gsicc_profile_new(str, mem, file_name, strlen(file_name));
|
gsicc_profile_new(str, mem, file_name, strlen(file_name));
|
||||||
code = sfclose(str);
|
code = sfclose(str);
|
||||||
+ }
|
+ }
|
||||||
+ if (str != NULL && icc_profile != NULL) {
|
+ if (str != NULL && icc_profile != NULL) {
|
||||||
if (pro_enum < gsPROOFPROFILE) {
|
if (pro_enum < gsPROOFPROFILE) {
|
||||||
if_debug1(gs_debug_flag_icc, "[icc] Setting device profile %d\n", pro_enum);
|
if_debug1m(gs_debug_flag_icc, mem,
|
||||||
pdev->icc_struct->device_profile[pro_enum] = icc_profile;
|
"[icc] Setting device profile %d\n", pro_enum);
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -urNp ghostscript-9.01.old/ijs/Makefile.am ghostscript-9.01/ijs/Makefile.am
|
|
||||||
--- ghostscript-9.01.old/ijs/Makefile.am 2011-03-08 10:09:33.055722164 +0000
|
|
||||||
+++ ghostscript-9.01/ijs/Makefile.am 2011-03-08 10:09:37.390722163 +0000
|
|
||||||
@@ -24,7 +24,7 @@
|
|
||||||
|
|
||||||
## Process this file with automake to produce Makefile.in.
|
|
||||||
|
|
||||||
-AUTOMAKE_OPTIONS = 1.6 foreign dist-bzip2 no-dependencies
|
|
||||||
+AUTOMAKE_OPTIONS = 1.8 foreign dist-bzip2 no-dependencies
|
|
||||||
|
|
||||||
@SET_MAKE@
|
|
||||||
|
|
@ -1,11 +1,11 @@
|
|||||||
%define gs_ver 9.06
|
%define gs_ver 9.07
|
||||||
%define gs_dot_ver 9.06
|
%define gs_dot_ver 9.07
|
||||||
%{expand: %%define build_with_freetype %{?_with_freetype:1}%{!?_with_freetype:0}}
|
%{expand: %%define build_with_freetype %{?_with_freetype:1}%{!?_with_freetype:0}}
|
||||||
Summary: A PostScript interpreter and renderer
|
Summary: A PostScript interpreter and renderer
|
||||||
Name: ghostscript
|
Name: ghostscript
|
||||||
Version: %{gs_ver}
|
Version: %{gs_ver}
|
||||||
|
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# Included CMap data is Redistributable, no modification permitted,
|
# Included CMap data is Redistributable, no modification permitted,
|
||||||
# see http://bugzilla.redhat.com/487510
|
# see http://bugzilla.redhat.com/487510
|
||||||
@ -19,7 +19,6 @@ Source4: cidfmap
|
|||||||
Patch1: ghostscript-multilib.patch
|
Patch1: ghostscript-multilib.patch
|
||||||
Patch2: ghostscript-scripts.patch
|
Patch2: ghostscript-scripts.patch
|
||||||
Patch3: ghostscript-noopt.patch
|
Patch3: ghostscript-noopt.patch
|
||||||
Patch4: ghostscript-ijs-automake-ver.patch
|
|
||||||
Patch5: ghostscript-runlibfileifexists.patch
|
Patch5: ghostscript-runlibfileifexists.patch
|
||||||
Patch6: ghostscript-icc-missing-check.patch
|
Patch6: ghostscript-icc-missing-check.patch
|
||||||
Patch10: ghostscript-cups-filters.patch
|
Patch10: ghostscript-cups-filters.patch
|
||||||
@ -41,7 +40,7 @@ BuildRequires: libtool
|
|||||||
BuildRequires: jasper-devel
|
BuildRequires: jasper-devel
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: poppler-data
|
BuildRequires: poppler-data
|
||||||
BuildRequires: lcms2-devel
|
BuildRequires: lcms2-devel >= 2.4-5
|
||||||
BuildRequires: openjpeg-devel
|
BuildRequires: openjpeg-devel
|
||||||
%{?_with_freetype:BuildRequires: freetype-devel}
|
%{?_with_freetype:BuildRequires: freetype-devel}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{gs_ver}-root
|
BuildRoot: %{_tmppath}/%{name}-%{gs_ver}-root
|
||||||
@ -114,10 +113,6 @@ rm -rf expat freetype icclib jasper jpeg lcms2 libpng openjpeg zlib cups/libs
|
|||||||
# Build igcref.c with -O0 to work around bug #150771.
|
# Build igcref.c with -O0 to work around bug #150771.
|
||||||
%patch3 -p1 -b .noopt
|
%patch3 -p1 -b .noopt
|
||||||
|
|
||||||
# Fix ./autgen.sh in ijs sub-project
|
|
||||||
# See http://bugs.ghostscript.com/show_bug.cgi?id=692040 for details.
|
|
||||||
%patch4 -p1 -b .ijs-automake-ver
|
|
||||||
|
|
||||||
# Define .runlibfileifexists.
|
# Define .runlibfileifexists.
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
|
|
||||||
@ -333,6 +328,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/libgs.so
|
%{_libdir}/libgs.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 8 2013 Tim Waugh <twaugh@redhat.com> - 9.07-1
|
||||||
|
- 9.07.
|
||||||
|
|
||||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 9.06-7
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 9.06-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
@ -1261,7 +1259,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
* Thu Aug 9 2001 Yukihiro Nakai <ynakai@redhat.com> 6.51-5
|
* Thu Aug 9 2001 Yukihiro Nakai <ynakai@redhat.com> 6.51-5
|
||||||
- Add cjk resources
|
- Add cjk resources
|
||||||
|
|
||||||
* Thu Aug 1 2001 Crutcher Dunnavant <crutcher@redhat.com> 6.51-4
|
* Wed Aug 1 2001 Crutcher Dunnavant <crutcher@redhat.com> 6.51-4
|
||||||
- applied drepper@redhat.com's patch for #50300
|
- applied drepper@redhat.com's patch for #50300
|
||||||
- fixed build deps on zlib-devel and libpng-devel, #49853
|
- fixed build deps on zlib-devel and libpng-devel, #49853
|
||||||
- made gs_init.ps a config file; #25096
|
- made gs_init.ps a config file; #25096
|
||||||
|
Loading…
Reference in New Issue
Block a user