parent
e98726d075
commit
0c733b3f70
1
.gitignore
vendored
1
.gitignore
vendored
@ -46,3 +46,4 @@ ghostscript-8.71.tar.xz
|
||||
/ghostscript-9.14-cleaned-1.tar.bz2
|
||||
/ghostscript-9.15-cleaned.tar.bz2
|
||||
/ghostscript-9.15-cleaned-1.tar.bz2
|
||||
/ghostscript-9.16-cleaned-1.tar.bz2
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -up ghostscript-8.64/psi/int.mak.noopt ghostscript-8.64/psi/int.mak
|
||||
--- ghostscript-8.64/psi/int.mak.noopt 2008-12-26 07:25:31.000000000 +0000
|
||||
+++ ghostscript-8.64/psi/int.mak 2009-02-04 11:33:48.000000000 +0000
|
||||
@@ -111,7 +111,7 @@ $(PSOBJ)igc.$(OBJ) : $(PSSRC)igc.c $(GH)
|
||||
$(PSOBJ)igcref.$(OBJ) : $(PSSRC)igcref.c $(GH) $(memory__h)\
|
||||
diff -up ghostscript-9.16/psi/int.mak.noopt ghostscript-9.16/psi/int.mak
|
||||
--- ghostscript-9.16/psi/int.mak.noopt 2015-03-30 17:03:47.120475345 +0100
|
||||
+++ ghostscript-9.16/psi/int.mak 2015-03-30 17:04:53.004247278 +0100
|
||||
@@ -116,7 +116,7 @@ $(PSOBJ)igcref.$(OBJ) : $(PSSRC)igcref.c
|
||||
$(gsexit_h) $(gsstruct_h)\
|
||||
$(iastate_h) $(idebug_h) $(igc_h) $(iname_h) $(ipacked_h) $(store_h)
|
||||
$(iastate_h) $(idebug_h) $(igc_h) $(iname_h) $(ipacked_h) $(store_h)\
|
||||
$(MAKEDIRS)
|
||||
- $(PSCC) $(PSO_)igcref.$(OBJ) $(C_) $(PSSRC)igcref.c
|
||||
+ $(PSCC) -O0 $(PSO_)igcref.$(OBJ) $(C_) $(PSSRC)igcref.c
|
||||
|
||||
$(PSOBJ)igcstr.$(OBJ) : $(PSSRC)igcstr.c $(GH) $(memory__h)\
|
||||
$(gsmdebug_h) $(gsstruct_h) $(iastate_h) $(igcstr_h)
|
||||
$(gsmdebug_h) $(gsstruct_h) $(iastate_h) $(igcstr_h) $(MAKEDIRS)
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up ghostscript-9.15/base/openjpeg.mak.system-openjpeg2 ghostscript-9.15/base/openjpeg.mak
|
||||
--- ghostscript-9.15/base/openjpeg.mak.system-openjpeg2 2014-10-03 11:20:42.769715997 +0100
|
||||
+++ ghostscript-9.15/base/openjpeg.mak 2014-10-03 11:22:17.823232154 +0100
|
||||
diff -up ghostscript-9.16/base/openjpeg.mak.system-openjpeg2 ghostscript-9.16/base/openjpeg.mak
|
||||
--- ghostscript-9.16/base/openjpeg.mak.system-openjpeg2 2015-03-30 09:21:24.000000000 +0100
|
||||
+++ ghostscript-9.16/base/openjpeg.mak 2015-03-30 17:05:55.160034798 +0100
|
||||
@@ -16,6 +16,7 @@
|
||||
# makefile for Luratech lwf_jp2 library code.
|
||||
# Users of this makefile must define the following:
|
||||
@ -9,19 +9,19 @@ diff -up ghostscript-9.15/base/openjpeg.mak.system-openjpeg2 ghostscript-9.15/ba
|
||||
# JPXSRCDIR - the library source directory
|
||||
#
|
||||
# gs.mak and friends define the following:
|
||||
@@ -103,7 +104,7 @@ $(OPEN_JPEG_GEN)openjpeg.dev : $(TOP_MAK
|
||||
|
||||
@@ -105,7 +106,7 @@ $(OPEN_JPEG_GEN)openjpeg.dev : $(TOP_MAK
|
||||
# external link .dev
|
||||
$(OPEN_JPEG_GEN)openjpeg_1.dev : $(TOP_MAKEFILES) $(OPEN_JPEG_MAK) $(ECHOGS_XE)
|
||||
$(OPEN_JPEG_GEN)openjpeg_1.dev : $(TOP_MAKEFILES) $(OPEN_JPEG_MAK) $(ECHOGS_XE) \
|
||||
$(MAKEDIRS)
|
||||
- $(SETMOD) $(OPEN_JPEG_GEN)openjpeg_1 -lib lib_openjpeg
|
||||
+ $(SETMOD) $(OPEN_JPEG_GEN)openjpeg_1 -lib $(SHARE_JPX_LIB)
|
||||
|
||||
# compile our own .dev
|
||||
$(OPEN_JPEG_GEN)openjpeg_0.dev : $(TOP_MAKEFILES) $(OPEN_JPEG_MAK) $(ECHOGS_XE) $(open_jpeg_OBJS)
|
||||
diff -up ghostscript-9.15/configure.ac.system-openjpeg2 ghostscript-9.15/configure.ac
|
||||
--- ghostscript-9.15/configure.ac.system-openjpeg2 2014-09-22 11:17:33.000000000 +0100
|
||||
+++ ghostscript-9.15/configure.ac 2014-10-03 11:27:55.783067332 +0100
|
||||
@@ -1492,6 +1492,17 @@ if test "x$JPX_DECODER" = "x"; then
|
||||
$(OPEN_JPEG_GEN)openjpeg_0.dev : $(TOP_MAKEFILES) $(OPEN_JPEG_MAK) $(ECHOGS_XE) $(open_jpeg_OBJS) \
|
||||
diff -up ghostscript-9.16/configure.ac.system-openjpeg2 ghostscript-9.16/configure.ac
|
||||
--- ghostscript-9.16/configure.ac.system-openjpeg2 2015-03-30 09:21:24.000000000 +0100
|
||||
+++ ghostscript-9.16/configure.ac 2015-03-30 17:05:08.563193858 +0100
|
||||
@@ -1531,6 +1531,17 @@ if test "x$JPX_DECODER" = "x"; then
|
||||
JPXDEVS='$(PSD)jpx.dev'
|
||||
else
|
||||
AC_MSG_RESULT([no])
|
||||
@ -39,7 +39,7 @@ diff -up ghostscript-9.15/configure.ac.system-openjpeg2 ghostscript-9.15/configu
|
||||
fi
|
||||
fi
|
||||
fi
|
||||
@@ -1500,6 +1511,7 @@ AC_SUBST(JPX_DECODER)
|
||||
@@ -1539,6 +1550,7 @@ AC_SUBST(JPX_DECODER)
|
||||
AC_SUBST(JPX_AUTOCONF_CFLAGS)
|
||||
AC_SUBST(JPXDIR)
|
||||
AC_SUBST(SHARE_JPX)
|
||||
@ -47,9 +47,9 @@ diff -up ghostscript-9.15/configure.ac.system-openjpeg2 ghostscript-9.15/configu
|
||||
AC_SUBST(JPXDEVS)
|
||||
|
||||
dnl check if we can/should build the gtk loader
|
||||
diff -up ghostscript-9.15/Makefile.in.system-openjpeg2 ghostscript-9.15/Makefile.in
|
||||
--- ghostscript-9.15/Makefile.in.system-openjpeg2 2014-10-03 11:29:52.808702801 +0100
|
||||
+++ ghostscript-9.15/Makefile.in 2014-10-03 11:30:02.997757576 +0100
|
||||
diff -up ghostscript-9.16/Makefile.in.system-openjpeg2 ghostscript-9.16/Makefile.in
|
||||
--- ghostscript-9.16/Makefile.in.system-openjpeg2 2015-03-30 17:02:51.000000000 +0100
|
||||
+++ ghostscript-9.16/Makefile.in 2015-03-30 17:05:08.563193858 +0100
|
||||
@@ -248,6 +248,7 @@ JBIG2_CFLAGS=@JBIG2_AUTOCONF_CFLAGS@
|
||||
# and source location and configuration flags for compiling in
|
||||
JPX_LIB=@JPX_DECODER@
|
||||
|
21
ghostscript-system-zlib.patch
Normal file
21
ghostscript-system-zlib.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up ghostscript-9.16/devices/devs.mak.system-zlib ghostscript-9.16/devices/devs.mak
|
||||
--- ghostscript-9.16/devices/devs.mak.system-zlib 2015-03-30 17:47:57.931725800 +0100
|
||||
+++ ghostscript-9.16/devices/devs.mak 2015-03-30 17:48:14.539673024 +0100
|
||||
@@ -1231,7 +1231,7 @@ $(libtiff_dev) $(MAKEDIRS)
|
||||
|
||||
$(DEVOBJ)gdevxps.$(OBJ) : $(DEVVECSRC)gdevxps.c $(gdevvec_h) \
|
||||
$(string__h) $(stdio__h) $(libtiff_dev) $(gx_h) $(gserrors_h) \
|
||||
-$(gxpath_h) $(gzcpath_h) $(stream_h) $(zlib_h) \
|
||||
+$(gxpath_h) $(gzcpath_h) $(stream_h) \
|
||||
$(stdint__h) $(gdevtifs_h) $(gsicc_create_h) $(gsicc_cache_h) \
|
||||
$(gximdecode_h) $(MAKEDIRS)
|
||||
$(XPSDEVCC) $(I_)$(TI_)$(_I) $(GLO_)gdevxps.$(OBJ) $(C_) $(DEVVECSRC)gdevxps.c
|
||||
@@ -1683,7 +1683,7 @@ $(DD)pngalpha.dev : $(DEVS_MAK) $(libpng
|
||||
fpng_=$(DEVOBJ)gdevfpng.$(OBJ) $(DEVOBJ)gdevpccm.$(OBJ)
|
||||
|
||||
$(DEVOBJ)gdevfpng_0.$(OBJ) : $(DEVSRC)gdevfpng.c\
|
||||
- $(gdevprn_h) $(gdevpccm_h) $(gscdefs_h) $(zlib_h) $(MAKEDIRS)
|
||||
+ $(gdevprn_h) $(gdevpccm_h) $(gscdefs_h) $(MAKEDIRS)
|
||||
$(CC_) $(I_)$(DEVI_) $(II)$(PI_)$(_I) $(PCF_) $(GLF_) $(DEVO_)gdevfpng_0.$(OBJ) $(C_) $(DEVSRC)gdevfpng.c
|
||||
|
||||
$(DEVOBJ)gdevfpng_1.$(OBJ) : $(DEVSRC)gdevfpng.c\
|
@ -1,11 +1,11 @@
|
||||
%define gs_ver 9.15
|
||||
%define gs_dot_ver 9.15
|
||||
%define gs_ver 9.16
|
||||
%define gs_dot_ver 9.16
|
||||
%{expand: %%define build_with_freetype %{?_with_freetype:1}%{!?_with_freetype:0}}
|
||||
Summary: A PostScript interpreter and renderer
|
||||
Name: ghostscript
|
||||
Version: %{gs_ver}
|
||||
|
||||
Release: 6%{?dist}
|
||||
Release: 1%{?dist}
|
||||
|
||||
# Included CMap data is Redistributable, no modification permitted,
|
||||
# see http://bugzilla.redhat.com/487510
|
||||
@ -30,6 +30,7 @@ Patch5: ghostscript-icc-missing-check.patch
|
||||
Patch6: ghostscript-Fontmap.local.patch
|
||||
Patch7: ghostscript-wrf-snprintf.patch
|
||||
Patch8: ghostscript-system-openjpeg2.patch
|
||||
Patch9: ghostscript-system-zlib.patch
|
||||
|
||||
Requires: %{name}-core%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-x11%{?_isa} = %{version}-%{release}
|
||||
@ -144,6 +145,9 @@ rm -rf expat freetype icclib jasper jpeg jpegxr lcms lcms2 libpng openjpeg zlib
|
||||
|
||||
%patch8 -p1 -b .system-openjpeg2
|
||||
|
||||
# Fixes for using the system zlib
|
||||
%patch9 -p1 -b .system-zlib
|
||||
|
||||
# Convert manual pages to UTF-8
|
||||
from8859_1() {
|
||||
iconv -f iso-8859-1 -t utf-8 < "$1" > "${1}_"
|
||||
@ -184,7 +188,8 @@ for path in \
|
||||
do
|
||||
FONTPATH="$FONTPATH${FONTPATH:+:}$path"
|
||||
done
|
||||
autoconf --force
|
||||
rm -f ijs/ltmain.sh
|
||||
autoreconf -fiv
|
||||
%configure --with-ijs --enable-dynamic --with-fontpath="$FONTPATH" \
|
||||
--with-drivers=ALL --disable-compile-inits --with-system-libtiff \
|
||||
--with-install-cups \
|
||||
@ -342,6 +347,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libgs.so
|
||||
|
||||
%changelog
|
||||
* Mon Mar 30 2015 Tim Waugh <twaugh@redhat.com> 9.16-1
|
||||
- 9.16.
|
||||
|
||||
* Fri Dec 19 2014 Tim Waugh <twaugh@redhat.com> 9.15-6
|
||||
- Don't ship X11.so in both the main package and the x11 sub-package.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user