Remove upstreamed patch
This is now upstreamed. We are at 3.12.0.0 version. See: https://github.com/haskell/cabal/blob/Cabal-v3.12.0.0/Cabal-syntax/src/Distribution/System.hs Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
parent
7fd591693c
commit
b37f2bedac
@ -1,43 +0,0 @@
|
||||
diff --git a/libraries/Cabal/Cabal-syntax/src/Distribution/System.hs b/libraries/Cabal/Cabal-syntax/src/Distribution/System.hs
|
||||
index 68bda63..6521464 100644
|
||||
--- a/libraries/Cabal/Cabal-syntax/src/Distribution/System.hs
|
||||
+++ b/libraries/Cabal/Cabal-syntax/src/Distribution/System.hs
|
||||
@@ -159,7 +159,7 @@ buildOS = classifyOS Permissive System.Info.os
|
||||
|
||||
-- | These are the known Arches: I386, X86_64, PPC, PPC64, Sparc,
|
||||
-- Arm, AArch64, Mips, SH, IA64, S390, S390X, Alpha, Hppa, Rs6000,
|
||||
--- M68k, Vax, JavaScript and Wasm32.
|
||||
+-- M68k, Vax, RISCV64, JavaScript and Wasm32.
|
||||
--
|
||||
-- The following aliases can also be used:
|
||||
-- * PPC alias: powerpc
|
||||
@@ -173,7 +173,7 @@ data Arch = I386 | X86_64 | PPC | PPC64 | Sparc
|
||||
| Arm | AArch64 | Mips | SH
|
||||
| IA64 | S390 | S390X
|
||||
| Alpha | Hppa | Rs6000
|
||||
- | M68k | Vax
|
||||
+ | M68k | Vax | RISCV64
|
||||
| JavaScript
|
||||
| Wasm32
|
||||
| OtherArch String
|
||||
@@ -188,7 +188,7 @@ knownArches = [I386, X86_64, PPC, PPC64, Sparc
|
||||
,Arm, AArch64, Mips, SH
|
||||
,IA64, S390, S390X
|
||||
,Alpha, Hppa, Rs6000
|
||||
- ,M68k, Vax
|
||||
+ ,M68k, Vax, RISCV64
|
||||
,JavaScript
|
||||
,Wasm32]
|
||||
|
||||
diff --git a/libraries/Cabal/Cabal/src/Distribution/Simple/PreProcess.hs b/libraries/Cabal/Cabal/src/Distribution/Simple/PreProcess.hs
|
||||
index fbe5710..a53b33d 100644
|
||||
--- a/libraries/Cabal/Cabal/src/Distribution/Simple/PreProcess.hs
|
||||
+++ b/libraries/Cabal/Cabal/src/Distribution/Simple/PreProcess.hs
|
||||
@@ -729,6 +729,7 @@ platformDefines lbi =
|
||||
Rs6000 -> ["rs6000"]
|
||||
M68k -> ["m68k"]
|
||||
Vax -> ["vax"]
|
||||
+ RISCV64 -> ["riscv64"]
|
||||
JavaScript -> ["javascript"]
|
||||
Wasm32 -> ["wasm32"]
|
||||
OtherArch _ -> []
|
11
ghc9.10.spec
11
ghc9.10.spec
@ -61,7 +61,7 @@ Version: 9.10.1
|
||||
# - release can only be reset if *all* library versions get bumped simultaneously
|
||||
# (sometimes after a major release)
|
||||
# - minor release numbers for a branch should be incremented monotonically
|
||||
Release: 4%{?dist}
|
||||
Release: 4.0.riscv64%{?dist}
|
||||
Summary: Glasgow Haskell Compiler
|
||||
|
||||
License: BSD-3-Clause AND HaskellReport
|
||||
@ -99,10 +99,6 @@ Patch27: haddock-remove-googleapis-fonts.patch
|
||||
# https://gitlab.haskell.org/ghc/ghc/-/issues/23034
|
||||
Patch35: https://gitlab.haskell.org/ghc/ghc/-/merge_requests/12885.patch
|
||||
|
||||
# RISCV64 added to Cabal
|
||||
# See: https://github.com/haskell/cabal/pull/9062
|
||||
Patch40: cabal-add-riscv64.patch
|
||||
|
||||
# Enable GHCi support on riscv64
|
||||
# Upstream in >= 9.9.
|
||||
Patch41: https://gitlab.haskell.org/ghc/ghc/-/commit/dd38aca95ac25adc9888083669b32ff551151259.patch
|
||||
@ -431,8 +427,6 @@ rm libffi-tarballs/libffi-*.tar.gz
|
||||
%endif
|
||||
|
||||
%ifarch riscv64
|
||||
#RISCV64 cabal support
|
||||
%patch -P40 -p1 -b .orig
|
||||
#GHCi support
|
||||
%patch -P41 -p1 -b .orig
|
||||
%endif
|
||||
@ -866,6 +860,9 @@ make test
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Dec 21 2024 David Abdurachmanov <davidlt@rivosinc.com> - 9.10.1-4.0.riscv64
|
||||
- Remove upstreamed riscv64 patch
|
||||
|
||||
* Sat Sep 7 2024 Jens Petersen <petersen@redhat.com> - 9.10.1-4
|
||||
- rts now depends on libnuma
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user