f50ec379b6
- quick build - use 7.10.3b respin tarballs - no longer need: - ghc-glibc-2.20_BSD_SOURCE.patch - ghc-7.8-arm-use-ld-gold.patch - ghc-7.8-arm7_saner-linker-opt-handling-9873.patch - ghc-config.mk.in-Enable-SMP-and-GHCi-support-for-Aarch64.patch - build_minimum_smp - add Debian packages: - buildpath-abi-stability - no-missing-haddock-file-warning - reproducible-tmp-names - use llvm35 - add libraries-versions.sh script - all library versions updates except xhtml - BR ghc-rpm-macros-extra for all OS versions - support building on EL6 - deprecated libraries: haskell2010, haskell98, old-locale, old-time - symlink for integer-gmp2 - add llvm_major
23 lines
1.2 KiB
Diff
23 lines
1.2 KiB
Diff
Description: Do not emit a warning if the .haddock file is missing
|
|
As it is quite common on Debian installations to install the -dev package
|
|
without the -doc package.
|
|
Author: Joachim Breitner <nomeata@debian.org>
|
|
|
|
Index: ghc-7.10/utils/ghc-pkg/Main.hs
|
|
===================================================================
|
|
--- ghc-7.10.orig/utils/ghc-pkg/Main.hs 2015-07-22 11:17:04.787751658 +0200
|
|
+++ ghc-7.10/utils/ghc-pkg/Main.hs 2015-07-22 11:17:04.787751658 +0200
|
|
@@ -1533,8 +1533,10 @@
|
|
mapM_ (checkDir True "library-dirs") (libraryDirs pkg)
|
|
mapM_ (checkDir True "include-dirs") (includeDirs pkg)
|
|
mapM_ (checkDir True "framework-dirs") (frameworkDirs pkg)
|
|
- mapM_ (checkFile True "haddock-interfaces") (haddockInterfaces pkg)
|
|
- mapM_ (checkDirURL True "haddock-html") (haddockHTMLs pkg)
|
|
+ -- In Debian, it is quite normal that the package is installed without the
|
|
+ -- documentation. Do not print a warning there.
|
|
+ -- mapM_ (checkFile True "haddock-interfaces") (haddockInterfaces pkg)
|
|
+ -- mapM_ (checkDirURL True "haddock-html") (haddockHTMLs pkg)
|
|
checkDuplicateModules pkg
|
|
checkExposedModules db_stack pkg
|
|
checkOtherModules pkg
|