f50ec379b6
- quick build - use 7.10.3b respin tarballs - no longer need: - ghc-glibc-2.20_BSD_SOURCE.patch - ghc-7.8-arm-use-ld-gold.patch - ghc-7.8-arm7_saner-linker-opt-handling-9873.patch - ghc-config.mk.in-Enable-SMP-and-GHCi-support-for-Aarch64.patch - build_minimum_smp - add Debian packages: - buildpath-abi-stability - no-missing-haddock-file-warning - reproducible-tmp-names - use llvm35 - add libraries-versions.sh script - all library versions updates except xhtml - BR ghc-rpm-macros-extra for all OS versions - support building on EL6 - deprecated libraries: haskell2010, haskell98, old-locale, old-time - symlink for integer-gmp2 - add llvm_major
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
Forwarded to https://ghc.haskell.org/trac/ghc/ticket/10424
|
|
|
|
Index: ghc-7.10.1/compiler/iface/MkIface.hs
|
|
===================================================================
|
|
--- ghc-7.10.1.orig/compiler/iface/MkIface.hs 2015-05-17 20:34:02.808643844 +0200
|
|
+++ ghc-7.10.1/compiler/iface/MkIface.hs 2015-05-17 20:34:02.804643799 +0200
|
|
@@ -611,7 +611,7 @@
|
|
iface_hash <- computeFingerprint putNameLiterally
|
|
(mod_hash,
|
|
ann_fn (mkVarOcc "module"), -- See mkIfaceAnnCache
|
|
- mi_usages iface0,
|
|
+ usages,
|
|
sorted_deps,
|
|
mi_hpc iface0)
|
|
|
|
@@ -644,6 +644,9 @@
|
|
(non_orph_fis, orph_fis) = mkOrphMap ifFamInstOrph (mi_fam_insts iface0)
|
|
fix_fn = mi_fix_fn iface0
|
|
ann_fn = mkIfaceAnnCache (mi_anns iface0)
|
|
+ -- Do not allow filenames to affect the interface
|
|
+ usages = [ case u of UsageFile _ fp -> UsageFile "" fp; _ -> u | u <- mi_usages iface0 ]
|
|
+
|
|
|
|
getOrphanHashes :: HscEnv -> [Module] -> IO [Fingerprint]
|
|
getOrphanHashes hsc_env mods = do
|