65eec31b69
- backport quickbuild config from 8.4 module - disable -Wall on s390x like in 8.4 module to silence warning flood and simplify setting of CFLAGS - setup build.mk in setup section, taken from copr and module - enable buildpath-abi-stability.patch (from Debian)
24 lines
1.0 KiB
Diff
24 lines
1.0 KiB
Diff
Forwarded to https://ghc.haskell.org/trac/ghc/ticket/10424
|
|
|
|
--- a/compiler/iface/MkIface.hs
|
|
+++ b/compiler/iface/MkIface.hs
|
|
@@ -681,7 +681,7 @@ addFingerprints hsc_env mb_old_fingerpri
|
|
iface_hash <- computeFingerprint putNameLiterally
|
|
(mod_hash,
|
|
ann_fn (mkVarOcc "module"), -- See mkIfaceAnnCache
|
|
- mi_usages iface0,
|
|
+ usages,
|
|
sorted_deps,
|
|
mi_hpc iface0)
|
|
|
|
@@ -714,6 +714,9 @@ addFingerprints hsc_env mb_old_fingerpri
|
|
(non_orph_fis, orph_fis) = mkOrphMap ifFamInstOrph (mi_fam_insts iface0)
|
|
fix_fn = mi_fix_fn iface0
|
|
ann_fn = mkIfaceAnnCache (mi_anns iface0)
|
|
+ -- Do not allow filenames to affect the interface
|
|
+ usages = [ case u of UsageFile _ fp -> UsageFile "" fp; _ -> u | u <- mi_usages iface0 ]
|
|
+
|
|
|
|
-- | Retrieve the orphan hashes 'mi_orphan_hash' for a list of modules
|
|
-- (in particular, the orphan modules which are transitively imported by the
|