sync ghc9.4: add sphinx7 patch
This commit is contained in:
parent
029e0a3682
commit
afd169846d
17
ghc.spec
17
ghc.spec
@ -1,5 +1,5 @@
|
|||||||
# Start: prod settings
|
# Start: prod settings
|
||||||
# all bcond_without for production builds:
|
# all *bcond_without* for production builds:
|
||||||
# - performance build (disable for quick build)
|
# - performance build (disable for quick build)
|
||||||
%bcond perfbuild 1
|
%bcond perfbuild 1
|
||||||
%bcond build_hadrian 1
|
%bcond build_hadrian 1
|
||||||
@ -9,7 +9,7 @@
|
|||||||
%endif
|
%endif
|
||||||
# End: prod settings
|
# End: prod settings
|
||||||
|
|
||||||
# without for production builds
|
# not for production builds
|
||||||
%if %{without perfbuild}
|
%if %{without perfbuild}
|
||||||
# disable profiling libraries (overriding macros.ghc-srpm)
|
# disable profiling libraries (overriding macros.ghc-srpm)
|
||||||
%undefine with_ghc_prof
|
%undefine with_ghc_prof
|
||||||
@ -138,6 +138,10 @@ Patch24: buildpath-abi-stability.patch
|
|||||||
Patch26: no-missing-haddock-file-warning.patch
|
Patch26: no-missing-haddock-file-warning.patch
|
||||||
Patch27: haddock-remove-googleapis-fonts.patch
|
Patch27: haddock-remove-googleapis-fonts.patch
|
||||||
|
|
||||||
|
Patch30: https://src.opensuse.org/rpm/ghc/raw/branch/factory/sphinx7.patch
|
||||||
|
|
||||||
|
# https://gitlab.haskell.org/ghc/ghc/-/wikis/platforms
|
||||||
|
|
||||||
# fedora ghc has been bootstrapped on
|
# fedora ghc has been bootstrapped on
|
||||||
# %%{ix86} x86_64 s390x ppc64le aarch64
|
# %%{ix86} x86_64 s390x ppc64le aarch64
|
||||||
# and retired arches: alpha sparcv9 armv5tel ppc ppc64 s390 armv7hl
|
# and retired arches: alpha sparcv9 armv5tel ppc ppc64 s390 armv7hl
|
||||||
@ -456,6 +460,11 @@ rm libffi-tarballs/libffi-*.tar.gz
|
|||||||
%patch -P26 -p1 -b .orig
|
%patch -P26 -p1 -b .orig
|
||||||
%patch -P27 -p1 -b .orig
|
%patch -P27 -p1 -b .orig
|
||||||
|
|
||||||
|
#sphinx 7
|
||||||
|
%if 0%{?fedora} >= 40
|
||||||
|
%patch -P30 -p1 -b .orig
|
||||||
|
%endif
|
||||||
|
|
||||||
%if %{with haddock} && %{without hadrian}
|
%if %{with haddock} && %{without hadrian}
|
||||||
%global gen_contents_index gen_contents_index.orig
|
%global gen_contents_index gen_contents_index.orig
|
||||||
if [ ! -f "libraries/%{gen_contents_index}" ]; then
|
if [ ! -f "libraries/%{gen_contents_index}" ]; then
|
||||||
@ -465,7 +474,6 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without hadrian}
|
%if %{without hadrian}
|
||||||
# https://gitlab.haskell.org/ghc/ghc/-/wikis/platforms
|
|
||||||
cat > mk/build.mk << EOF
|
cat > mk/build.mk << EOF
|
||||||
%if %{with perfbuild}
|
%if %{with perfbuild}
|
||||||
%ifarch %{ghc_llvm_archs}
|
%ifarch %{ghc_llvm_archs}
|
||||||
@ -552,6 +560,9 @@ cd hadrian
|
|||||||
%global hadrian_llvm +llvm
|
%global hadrian_llvm +llvm
|
||||||
%endif
|
%endif
|
||||||
%define hadrian_docs %{!?with_haddock:--docs=no-haddocks} --docs=%[%{?with_manual} ? "no-sphinx-pdfs" : "no-sphinx"]
|
%define hadrian_docs %{!?with_haddock:--docs=no-haddocks} --docs=%[%{?with_manual} ? "no-sphinx-pdfs" : "no-sphinx"]
|
||||||
|
# aarch64 with 224 cpus: _build/stage0/bin/ghc: createProcess: pipe: resource exhausted (Too many open files)
|
||||||
|
# https://koji.fedoraproject.org/koji/taskinfo?taskID=105428124
|
||||||
|
%global _smp_ncpus_max 64
|
||||||
# quickest does not build shared libs
|
# quickest does not build shared libs
|
||||||
# try release instead of perf
|
# try release instead of perf
|
||||||
%{hadrian} %{?_smp_mflags} --flavour=%[%{?with_perfbuild} ? "perf" : "quick"]%{!?with_ghc_prof:+no_profiled_libs}%{?hadrian_llvm} %{hadrian_docs} binary-dist-dir
|
%{hadrian} %{?_smp_mflags} --flavour=%[%{?with_perfbuild} ? "perf" : "quick"]%{!?with_ghc_prof:+no_profiled_libs}%{?hadrian_llvm} %{hadrian_docs} binary-dist-dir
|
||||||
|
26
sphinx7.patch
Normal file
26
sphinx7.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 52d701b31dc4427b7e321a04be3f5f13a5fc271e Mon Sep 17 00:00:00 2001
|
||||||
|
From: "mimi.vx" <mimi.vx@gmail.com>
|
||||||
|
Date: Wed, 24 May 2023 12:42:15 +0000
|
||||||
|
Subject: [PATCH] Fix for Sphinx 7 removed style key
|
||||||
|
|
||||||
|
Fixes https://gitlab.haskell.org/ghc/ghc/-/issues/23444
|
||||||
|
---
|
||||||
|
docs/users_guide/rtd-theme/layout.html | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/docs/users_guide/rtd-theme/layout.html b/docs/users_guide/rtd-theme/layout.html
|
||||||
|
index 2a61142514a..7ffeff7befc 100644
|
||||||
|
--- a/docs/users_guide/rtd-theme/layout.html
|
||||||
|
+++ b/docs/users_guide/rtd-theme/layout.html
|
||||||
|
@@ -64,7 +64,7 @@
|
||||||
|
{%- endif %}
|
||||||
|
|
||||||
|
{# CSS #}
|
||||||
|
- <link rel="stylesheet" href="{{ pathto('_static/' + style, 1) }}" type="text/css" />
|
||||||
|
+ <link rel="stylesheet" href="{{ pathto('_static/' + styles[-1], 1) }}" type="text/css" />
|
||||||
|
<link rel="stylesheet" href="{{ pathto('_static/pygments.css', 1) }}" type="text/css" />
|
||||||
|
{%- for css in css_files %}
|
||||||
|
{%- if css|attr("rel") %}
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
Loading…
Reference in New Issue
Block a user