Port F-10 changes to devel
This commit is contained in:
parent
ef6ff25c36
commit
a8b8189107
@ -1,22 +0,0 @@
|
|||||||
--- ghc-6.8.3/libraries/Makefile~ 2008-06-17 23:10:28.000000000 -0700
|
|
||||||
+++ ghc-6.8.3/libraries/Makefile 2008-06-17 23:21:21.000000000 -0700
|
|
||||||
@@ -256,6 +256,8 @@
|
|
||||||
--with-hc-pkg=../../utils/ghc-pkg/ghc-pkg-inplace \
|
|
||||||
--with-hsc2hs=../../utils/hsc2hs/hsc2hs-inplace \
|
|
||||||
--with-ld=$(LD) \
|
|
||||||
+ --with-haddock=$(HADDOCK) \
|
|
||||||
+ --with-happy=$(HAPPY) \
|
|
||||||
--haddock-options="--use-contents=../index.html \
|
|
||||||
--use-index=../doc-index.html" \
|
|
||||||
$(FLAGGED_CONFIGURE_ARGS) \
|
|
||||||
--- ghc-6.8.3/libraries/gen_contents_index~ 2008-06-18 20:40:39.000000000 -0700
|
|
||||||
+++ ghc-6.8.3/libraries/gen_contents_index 2008-06-18 20:40:50.000000000 -0700
|
|
||||||
@@ -22,7 +22,7 @@
|
|
||||||
done
|
|
||||||
|
|
||||||
# Now create the combined contents and index pages
|
|
||||||
-haddock --gen-index --gen-contents -o . \
|
|
||||||
+haddock-0.9 --gen-index --gen-contents -o . \
|
|
||||||
-t "Haskell Hierarchical Libraries" \
|
|
||||||
$HADDOCK_ARGS
|
|
||||||
|
|
33
ghc.spec
33
ghc.spec
@ -15,8 +15,8 @@
|
|||||||
%define package_debugging 0
|
%define package_debugging 0
|
||||||
|
|
||||||
Name: ghc
|
Name: ghc
|
||||||
Version: 6.8.3
|
Version: 6.10.0.20081007
|
||||||
Release: 6%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Glasgow Haskell Compilation system
|
Summary: Glasgow Haskell Compilation system
|
||||||
# See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239713
|
# See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239713
|
||||||
ExcludeArch: alpha ppc64
|
ExcludeArch: alpha ppc64
|
||||||
@ -25,19 +25,14 @@ Group: Development/Languages
|
|||||||
Source0: http://www.haskell.org/ghc/dist/%{version}/ghc-%{version}-src.tar.bz2
|
Source0: http://www.haskell.org/ghc/dist/%{version}/ghc-%{version}-src.tar.bz2
|
||||||
Source1: http://www.haskell.org/ghc/dist/%{version}/ghc-%{version}-src-extralibs.tar.bz2
|
Source1: http://www.haskell.org/ghc/dist/%{version}/ghc-%{version}-src-extralibs.tar.bz2
|
||||||
Source2: ghc-rpm-macros.ghc
|
Source2: ghc-rpm-macros.ghc
|
||||||
Patch0: ghc-6.8.3-libraries-config.patch
|
|
||||||
URL: http://haskell.org/ghc/
|
URL: http://haskell.org/ghc/
|
||||||
Requires: gcc, gmp-devel, readline-devel
|
Requires: gcc, gmp-devel, libedit-devel
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: ghc682, ghc681, ghc661, ghc66
|
Obsoletes: ghc682, ghc681, ghc661, ghc66, haddock <= 2.0.0.0
|
||||||
BuildRequires: ghc, happy, sed
|
BuildRequires: ghc, happy, sed
|
||||||
BuildRequires: gmp-devel, readline-devel
|
BuildRequires: gmp-devel, libedit-devel
|
||||||
# X11 is no longer in ghc extralibs
|
|
||||||
#BuildRequires: libX11-devel, libXt-devel
|
|
||||||
BuildRequires: freeglut-devel, openal-devel
|
|
||||||
%if %{build_doc}
|
%if %{build_doc}
|
||||||
# haddock generates docs in libraries, but haddock 2.0 is not compatible
|
BuildRequires: libxslt, docbook-style-xsl
|
||||||
BuildRequires: libxslt, docbook-style-xsl, haddock09
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -78,7 +73,6 @@ you like to have local access to the documentation in HTML format.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version} -b1
|
%setup -q -n %{name}-%{version} -b1
|
||||||
%patch0 -p1 -b .0-haddock~
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# hack for building a local test package quickly from a prebuilt tree
|
# hack for building a local test package quickly from a prebuilt tree
|
||||||
@ -100,8 +94,6 @@ echo "XMLDocWays = html" >> mk/build.mk
|
|||||||
echo "HADDOCK_DOCS = YES" >> mk/build.mk
|
echo "HADDOCK_DOCS = YES" >> mk/build.mk
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
export HaddockCmd=%{_bindir}/haddock-0.9
|
|
||||||
|
|
||||||
./configure --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \
|
./configure --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} \
|
||||||
--bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
|
--bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
|
||||||
--datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \
|
--datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} \
|
||||||
@ -201,8 +193,17 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Oct 1 2008 Bryan O'Sullivan <bos@serpentine.com> 6.8.3-6.fc10
|
* Sun Oct 12 2008 Bryan O'Sullivan <bos@serpentine.com> - 6.10.0.20081007-2.fc10
|
||||||
* Rename hsc2hs to hsc2hs-ghc so the alternatives symlink to it will work
|
- Use libedit in preference to readline, for BSD license consistency
|
||||||
|
- With haddock bundled now, obsolete standalone versions (but not haddock09)
|
||||||
|
- Drop obsolete freeglut-devel, openal-devel, and haddock09 dependencies
|
||||||
|
|
||||||
|
* Sun Oct 12 2008 Bryan O'Sullivan <bos@serpentine.com> - 6.10.0.20081007-1.fc10
|
||||||
|
- Update to 6.10.1 release candidate 1
|
||||||
|
|
||||||
|
* Wed Oct 1 2008 Bryan O'Sullivan <bos@serpentine.com> - 6.10.0.20080921-1.fc10
|
||||||
|
- Drop unneeded haddock patch
|
||||||
|
- Rename hsc2hs to hsc2hs-ghc so the alternatives symlink to it will work
|
||||||
|
|
||||||
* Wed Sep 24 2008 Jens Petersen <petersen@redhat.com> - 6.8.3-5.fc10
|
* Wed Sep 24 2008 Jens Petersen <petersen@redhat.com> - 6.8.3-5.fc10
|
||||||
- bring back including haddock-generated lib docs, now under docdir/ghc
|
- bring back including haddock-generated lib docs, now under docdir/ghc
|
||||||
|
Loading…
Reference in New Issue
Block a user