turn on SMP and ghci for aarch64
patch by Erik de Castro Lopo from https://ghc.haskell.org/trac/ghc/ticket/9673
This commit is contained in:
parent
682be3ab66
commit
4a07cbb90c
@ -0,0 +1,34 @@
|
|||||||
|
From 44cee4852282f63393d532aad59c5cd865ff3ed6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Erik de Castro Lopo <erikd@mega-nerd.com>
|
||||||
|
Date: Wed, 1 Apr 2015 04:46:01 +0000
|
||||||
|
Subject: [PATCH] mk/config.mk.in : Enable SMP and GHCi support for Aarch64.
|
||||||
|
|
||||||
|
---
|
||||||
|
mk/config.mk.in | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/mk/config.mk.in b/mk/config.mk.in
|
||||||
|
index f4cb52b..d6831c9 100644
|
||||||
|
--- a/mk/config.mk.in
|
||||||
|
+++ b/mk/config.mk.in
|
||||||
|
@@ -172,7 +172,7 @@ HaveLibDL = @HaveLibDL@
|
||||||
|
|
||||||
|
# ArchSupportsSMP should be set iff there is support for that arch in
|
||||||
|
# includes/stg/SMP.h
|
||||||
|
-ArchSupportsSMP=$(strip $(patsubst $(TargetArch_CPP), YES, $(findstring $(TargetArch_CPP), i386 x86_64 sparc powerpc arm)))
|
||||||
|
+ArchSupportsSMP=$(strip $(patsubst $(TargetArch_CPP), YES, $(findstring $(TargetArch_CPP), i386 x86_64 sparc powerpc arm aarch64)))
|
||||||
|
|
||||||
|
GhcWithSMP := $(strip $(if $(filter YESNO, $(ArchSupportsSMP)$(GhcUnregisterised)),YES,NO))
|
||||||
|
|
||||||
|
@@ -180,7 +180,7 @@ GhcWithSMP := $(strip $(if $(filter YESNO, $(ArchSupportsSMP)$(GhcUnregisterised
|
||||||
|
# has support for this OS/ARCH combination.
|
||||||
|
|
||||||
|
OsSupportsGHCi=$(strip $(patsubst $(TargetOS_CPP), YES, $(findstring $(TargetOS_CPP), mingw32 cygwin32 linux solaris2 freebsd dragonfly netbsd openbsd darwin kfreebsdgnu)))
|
||||||
|
-ArchSupportsGHCi=$(strip $(patsubst $(TargetArch_CPP), YES, $(findstring $(TargetArch_CPP), i386 x86_64 powerpc sparc sparc64 arm)))
|
||||||
|
+ArchSupportsGHCi=$(strip $(patsubst $(TargetArch_CPP), YES, $(findstring $(TargetArch_CPP), i386 x86_64 powerpc sparc sparc64 arm aarch64)))
|
||||||
|
|
||||||
|
ifeq "$(OsSupportsGHCi)$(ArchSupportsGHCi)" "YESYES"
|
||||||
|
GhcWithInterpreter=YES
|
||||||
|
--
|
||||||
|
2.1.4
|
||||||
|
|
12
ghc.spec
12
ghc.spec
@ -35,7 +35,7 @@ Version: 7.8.4
|
|||||||
# (sometimes after a major release)
|
# (sometimes after a major release)
|
||||||
# - minor release numbers for a branch should be incremented monotonically
|
# - minor release numbers for a branch should be incremented monotonically
|
||||||
# xhtml moved from haskell-platform to ghc-7.8.3
|
# xhtml moved from haskell-platform to ghc-7.8.3
|
||||||
Release: 43%{?dist}
|
Release: 44%{?dist}
|
||||||
Summary: Glasgow Haskell Compiler
|
Summary: Glasgow Haskell Compiler
|
||||||
|
|
||||||
License: %BSDHaskellReport
|
License: %BSDHaskellReport
|
||||||
@ -58,6 +58,7 @@ Patch22: ghc-armv7-VFPv3D16--NEON.patch
|
|||||||
Patch23: ghc-7.8.3-Cabal-install-PATH-warning.patch
|
Patch23: ghc-7.8.3-Cabal-install-PATH-warning.patch
|
||||||
Patch24: ghc-7.8-arm7-use-ld-gold-8976.patch
|
Patch24: ghc-7.8-arm7-use-ld-gold-8976.patch
|
||||||
Patch25: ghc-7.8-arm7_saner-linker-opt-handling-9873.patch
|
Patch25: ghc-7.8-arm7_saner-linker-opt-handling-9873.patch
|
||||||
|
Patch26: ghc-config.mk.in-Enable-SMP-and-GHCi-support-for-Aarch64.patch
|
||||||
|
|
||||||
%global Cabal_ver 1.18.1.5
|
%global Cabal_ver 1.18.1.5
|
||||||
%global array_ver 0.5.0.0
|
%global array_ver 0.5.0.0
|
||||||
@ -272,6 +273,7 @@ rm -r libffi-tarballs
|
|||||||
|
|
||||||
%ifarch aarch64
|
%ifarch aarch64
|
||||||
%patch21 -p1 -b .orig
|
%patch21 -p1 -b .orig
|
||||||
|
%patch26 -p1 -b .orig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch armv7hl
|
%ifarch armv7hl
|
||||||
@ -315,11 +317,6 @@ HADDOCK_DOCS = NO
|
|||||||
%if %{defined without_manual}
|
%if %{defined without_manual}
|
||||||
BUILD_DOCBOOK_HTML = NO
|
BUILD_DOCBOOK_HTML = NO
|
||||||
%endif
|
%endif
|
||||||
%ifarch aarch64
|
|
||||||
# aarch64 dynlinking causing runtime IO problems
|
|
||||||
# https://ghc.haskell.org/trac/ghc/ticket/9673
|
|
||||||
DYNAMIC_GHC_PROGRAMS=NO
|
|
||||||
%endif
|
|
||||||
## for verbose build output
|
## for verbose build output
|
||||||
#GhcStage1HcOpts=-v4
|
#GhcStage1HcOpts=-v4
|
||||||
## enable RTS debugging:
|
## enable RTS debugging:
|
||||||
@ -578,6 +575,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 10 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-44
|
||||||
|
- turn on SMP and ghci for aarch64 (Erik de Castro Lopo, #1210323)
|
||||||
|
|
||||||
* Mon Mar 30 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-43
|
* Mon Mar 30 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-43
|
||||||
- aarch64 production build
|
- aarch64 production build
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user