update the arm64 patch for 7.8.4
This commit is contained in:
parent
43f536af8e
commit
37dd51b1af
@ -91,13 +91,13 @@ Index: ghc-7.8.3/compiler/nativeGen/RegAlloc/Linear/FreeRegs.hs
|
|||||||
ArchPPC_64 -> panic "maxSpillSlots ArchPPC_64"
|
ArchPPC_64 -> panic "maxSpillSlots ArchPPC_64"
|
||||||
ArchAlpha -> panic "maxSpillSlots ArchAlpha"
|
ArchAlpha -> panic "maxSpillSlots ArchAlpha"
|
||||||
ArchMipseb -> panic "maxSpillSlots ArchMipseb"
|
ArchMipseb -> panic "maxSpillSlots ArchMipseb"
|
||||||
Index: ghc-7.8.3/compiler/nativeGen/RegAlloc/Linear/Main.hs
|
Index: ghc-7.8.4/compiler/nativeGen/RegAlloc/Linear/Main.hs
|
||||||
===================================================================
|
===================================================================
|
||||||
--- ghc-7.8.3.orig/compiler/nativeGen/RegAlloc/Linear/Main.hs 2014-07-10 10:16:42.533187516 +0200
|
--- ghc-7.8.4/compiler/nativeGen/RegAlloc/Linear/Main.hs.orig 2015-02-07 18:19:27.364827776 +0100
|
||||||
+++ ghc-7.8.3/compiler/nativeGen/RegAlloc/Linear/Main.hs 2014-07-10 10:16:42.529187516 +0200
|
+++ ghc-7.8.4/compiler/nativeGen/RegAlloc/Linear/Main.hs 2015-02-07 18:20:46.813771354 +0100
|
||||||
@@ -207,6 +207,7 @@
|
@@ -207,6 +207,7 @@
|
||||||
ArchSPARC -> linearRegAlloc' dflags (frInitFreeRegs platform :: SPARC.FreeRegs) first_id block_live sccs
|
ArchSPARC -> linearRegAlloc' dflags (frInitFreeRegs platform :: SPARC.FreeRegs) entry_ids block_live sccs
|
||||||
ArchPPC -> linearRegAlloc' dflags (frInitFreeRegs platform :: PPC.FreeRegs) first_id block_live sccs
|
ArchPPC -> linearRegAlloc' dflags (frInitFreeRegs platform :: PPC.FreeRegs) entry_ids block_live sccs
|
||||||
ArchARM _ _ _ -> panic "linearRegAlloc ArchARM"
|
ArchARM _ _ _ -> panic "linearRegAlloc ArchARM"
|
||||||
+ ArchARM64 -> panic "linearRegAlloc ArchARM64"
|
+ ArchARM64 -> panic "linearRegAlloc ArchARM64"
|
||||||
ArchPPC_64 -> panic "linearRegAlloc ArchPPC_64"
|
ArchPPC_64 -> panic "linearRegAlloc ArchPPC_64"
|
1
ghc.spec
1
ghc.spec
@ -540,6 +540,7 @@ fi
|
|||||||
* Sat Feb 7 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-39.1
|
* Sat Feb 7 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-39.1
|
||||||
- version doc htmldirs again
|
- version doc htmldirs again
|
||||||
- all archs have bindir/ghci
|
- all archs have bindir/ghci
|
||||||
|
- update the arm64 patch for 7.8.4
|
||||||
|
|
||||||
* Sat Jan 17 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-39
|
* Sat Jan 17 2015 Jens Petersen <petersen@redhat.com> - 7.8.4-39
|
||||||
- update to 7.8.4
|
- update to 7.8.4
|
Loading…
Reference in New Issue
Block a user