upstream patch to enable SMP rts for ppc64le
This commit is contained in:
parent
12e492c7ee
commit
1026d3dcb9
35
5725.patch
Normal file
35
5725.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 7cfa6f3114168797cf1fa7faa4ffe6c06b73f149 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Trommler <ptrommler@acm.org>
|
||||
Date: Tue, 11 May 2021 20:52:01 +0200
|
||||
Subject: [PATCH] Hadrian: Enable SMP on powerpc64{le}
|
||||
|
||||
Fixes #19825
|
||||
---
|
||||
hadrian/src/Oracles/Flag.hs | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/hadrian/src/Oracles/Flag.hs b/hadrian/src/Oracles/Flag.hs
|
||||
index 86521e4aa8a..1b3aff693eb 100644
|
||||
--- a/hadrian/src/Oracles/Flag.hs
|
||||
+++ b/hadrian/src/Oracles/Flag.hs
|
||||
@@ -70,7 +70,16 @@ targetSupportsSMP :: Action Bool
|
||||
targetSupportsSMP = do
|
||||
unreg <- flag GhcUnregisterised
|
||||
armVer <- targetArmVersion
|
||||
- goodArch <- anyTargetArch ["i386", "x86_64", "sparc", "powerpc", "arm", "aarch64", "s390x", "riscv64"]
|
||||
+ goodArch <- anyTargetArch ["i386"
|
||||
+ , "x86_64"
|
||||
+ , "sparc"
|
||||
+ , "powerpc"
|
||||
+ , "powerpc64"
|
||||
+ , "powerpc64le"
|
||||
+ , "arm"
|
||||
+ , "aarch64"
|
||||
+ , "s390x"
|
||||
+ , "riscv64"]
|
||||
if -- The THREADED_RTS requires `BaseReg` to be in a register and the
|
||||
-- Unregisterised mode doesn't allow that.
|
||||
| unreg -> return False
|
||||
--
|
||||
GitLab
|
||||
|
12
ghc.spec
12
ghc.spec
@ -88,7 +88,7 @@ Version: 9.2.6
|
||||
# - release can only be reset if *all* library versions get bumped simultaneously
|
||||
# (sometimes after a major release)
|
||||
# - minor release numbers for a branch should be incremented monotonically
|
||||
Release: 128%{?dist}
|
||||
Release: 129%{?dist}
|
||||
Summary: Glasgow Haskell Compiler
|
||||
|
||||
License: BSD and HaskellReport
|
||||
@ -136,6 +136,10 @@ Patch16: ghc-9.2.1-hadrian-s390x-rts--qg.patch
|
||||
# https://gitlab.haskell.org/ghc/ghc/-/issues/16998
|
||||
Patch18: Disable-unboxed-arrays.patch
|
||||
|
||||
# ppc64le
|
||||
# enable smp with hadrian
|
||||
Patch20: https://gitlab.haskell.org/ghc/ghc/-/merge_requests/5725.patch
|
||||
|
||||
# Debian patches:
|
||||
Patch24: buildpath-abi-stability.patch
|
||||
Patch26: no-missing-haddock-file-warning.patch
|
||||
@ -451,6 +455,9 @@ rm libffi-tarballs/libffi-*.tar.gz
|
||||
%patch18 -p1 -b .orig
|
||||
%endif
|
||||
|
||||
# ppc64le
|
||||
%patch20 -p1 -b .orig
|
||||
|
||||
# debian
|
||||
%patch24 -p1 -b .orig
|
||||
%patch26 -p1 -b .orig
|
||||
@ -985,6 +992,9 @@ env -C %{ghc_html_libraries_dir} ./gen_contents_index
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Feb 17 2023 Jens Petersen <petersen@redhat.com> - 9.2.6-129
|
||||
- upstream patch to enable SMP rts for ppc64le
|
||||
|
||||
* Thu Feb 16 2023 Jens Petersen <petersen@redhat.com> - 9.2.6-128
|
||||
- rebuild to fix prof deps
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user