ghc-wai-extra/ghc-wai-extra.spec

229 lines
5.8 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name wai-extra
%global pkgver %{pkg_name}-%{version}
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 3.1.13.0
Release: %autorelease
Summary: Basic WAI handlers and middleware
License: MIT
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: dos2unix
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-HUnit-devel
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-ansi-terminal-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-base64-bytestring-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-call-stack-devel
BuildRequires: ghc-case-insensitive-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-cookie-devel
BuildRequires: ghc-data-default-class-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-fast-logger-devel
BuildRequires: ghc-http-types-devel
BuildRequires: ghc-iproute-devel
BuildRequires: ghc-network-devel
BuildRequires: ghc-resourcet-devel
BuildRequires: ghc-streaming-commons-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-time-devel
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-unix-devel
BuildRequires: ghc-vault-devel
BuildRequires: ghc-wai-devel
BuildRequires: ghc-wai-logger-devel
BuildRequires: ghc-warp-devel
BuildRequires: ghc-word8-devel
%if %{with ghc_prof}
BuildRequires: ghc-HUnit-prof
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-ansi-terminal-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-base64-bytestring-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-call-stack-prof
BuildRequires: ghc-case-insensitive-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-cookie-prof
BuildRequires: ghc-data-default-class-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-fast-logger-prof
BuildRequires: ghc-http-types-prof
BuildRequires: ghc-iproute-prof
BuildRequires: ghc-network-prof
BuildRequires: ghc-resourcet-prof
BuildRequires: ghc-streaming-commons-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-unix-prof
BuildRequires: ghc-vault-prof
BuildRequires: ghc-wai-prof
BuildRequires: ghc-wai-logger-prof
BuildRequires: ghc-warp-prof
BuildRequires: ghc-word8-prof
%endif
%if %{with tests}
BuildRequires: ghc-hspec-devel
BuildRequires: ghc-hspec-discover-devel
BuildRequires: ghc-temporary-devel
BuildRequires: ghc-zlib-devel
%endif
# End cabal-rpm deps
%description
Provides basic WAI handler and middleware functionality:
* WAI Testing Framework
Hspec testing facilities and helpers for WAI.
* Event Source/Event Stream
Send server events to the client. Compatible with the JavaScript EventSource
API.
* Accept Override
Override the Accept header in a request. Special handling for the _accept query
parameter (which is used throughout WAI override the Accept header).
* Add Headers
WAI Middleware for adding arbitrary headers to an HTTP request.
* Clean Path
Clean a request path to a canonical form.
* Combine Headers
Combine duplicate headers into one.
* GZip Compression
Negotiate HTTP payload gzip compression.
* Health check endpoint
Add an empty health check endpoint.
* HTTP Basic Authentication
WAI Basic Authentication Middleware which uses Authorization header.
* JSONP
"JSON with Padding" middleware. Automatic wrapping of JSON responses to convert
into JSONP.
* Method Override / Post
Allows overriding of the HTTP request method via the _method query string
parameter.
* Request Logging
Request logging middleware for development and production environments
* Request Rewrite
Rewrite request path info based on a custom conversion rules.
* Select
Dynamically choose between Middlewares.
* Stream Files
Convert ResponseFile type responses into ResponseStream type.
* Virtual Host
Redirect incoming requests to a new host based on custom rules.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
dos2unix -k -n %{SOURCE1} %{pkg_name}.cabal
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc ChangeLog.md README.md example
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
%autochangelog