ghc-uuid/ghc-uuid.spec

150 lines
4.3 KiB
RPMSpec

# generated by cabal-rpm-0.11.1
# https://fedoraproject.org/wiki/Packaging:Haskell
%global pkg_name uuid
%global pkgver %{pkg_name}-%{version}
%global cryptohashmd5 cryptohash-md5-0.11.100.1
%global cryptohashsha1 cryptohash-sha1-0.11.100.1
%global networkinfo network-info-0.2.0.8
%global uuidtypes uuid-types-1.0.3
%global subpkgs %{cryptohashmd5} %{cryptohashsha1} %{networkinfo} %{uuidtypes}
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 1.3.13
# can only be reset when all subpkgs bumped
Release: 1%{?dist}
Summary: For creating, comparing, parsing and printing Universally Unique Identifiers
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{cryptohashmd5}/%{cryptohashmd5}.tar.gz
Source2: https://hackage.haskell.org/package/%{cryptohashsha1}/%{cryptohashsha1}.tar.gz
Source3: https://hackage.haskell.org/package/%{networkinfo}/%{networkinfo}.tar.gz
Source4: https://hackage.haskell.org/package/%{uuidtypes}/%{uuidtypes}.tar.gz
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros-extra
# Begin cabal-rpm deps:
BuildRequires: ghc-binary-devel
BuildRequires: ghc-bytestring-devel
#BuildRequires: ghc-cryptohash-md5-devel
#BuildRequires: ghc-cryptohash-sha1-devel
BuildRequires: ghc-entropy-devel
#BuildRequires: ghc-network-info-devel
BuildRequires: ghc-random-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-time-devel
#BuildRequires: ghc-uuid-types-devel
%if %{with tests}
BuildRequires: ghc-HUnit-devel
BuildRequires: ghc-QuickCheck-devel
BuildRequires: ghc-tasty-devel
BuildRequires: ghc-tasty-hunit-devel
BuildRequires: ghc-tasty-quickcheck-devel
%endif
# End cabal-rpm deps
# uuid-types needs
BuildRequires: ghc-hashable-devel
%description
This library is useful for creating, comparing, parsing and printing
Universally Unique Identifiers.
See <http://en.wikipedia.org/wiki/UUID> for the general idea.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Requires: ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%global main_version %{version}
%if %{defined ghclibdir}
%ghc_lib_subpackage %{cryptohashmd5}
%ghc_lib_subpackage %{cryptohashsha1}
%ghc_lib_subpackage %{networkinfo}
%ghc_lib_subpackage %{uuidtypes}
%endif
%global version %{main_version}
%prep
%setup -q -n %{pkgver} -a1 -a2 -a3 -a4
%build
%ghc_libs_build %{subpkgs}
%ghc_lib_build
%install
%ghc_libs_install %{subpkgs}
%ghc_lib_install
%ghc_fix_rpath %{subpkgs}
%check
%cabal_test
%post devel
%ghc_pkg_recache
%postun devel
%ghc_pkg_recache
%files -f %{name}.files
%license LICENSE
%files devel -f %{name}-devel.files
%doc CHANGES.md
%changelog
* Tue Feb 21 2017 Jens Petersen <petersen@redhat.com> - 1.3.13-1
- update to 1.3.13
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Jun 20 2016 Jens Petersen <petersen@redhat.com> - 1.2.14-1
- update to 1.2.14
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.13-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Sep 30 2015 Jens Petersen <petersen@redhat.com> - 1.2.13-6
- allow time 1.5
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.13-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Tue Jan 27 2015 Jens Petersen <petersen@fedoraproject.org> - 1.2.13-4
- cblrpm refresh
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Jun 15 2013 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 1.2.13-1
- spec file generated by cabal-rpm-0.8.1