ghc-statistics/ghc-statistics.spec

147 lines
4.2 KiB
RPMSpec

# generated by cabal-rpm-0.12.5
# https://fedoraproject.org/wiki/Packaging:Haskell
%global pkg_name statistics
%global pkgver %{pkg_name}-%{version}
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 0.14.0.2
Release: 6%{?dist}
Summary: A library of statistical types, data, and functions
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
# Begin cabal-rpm deps:
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-base-orphans-devel
BuildRequires: ghc-binary-devel
BuildRequires: ghc-deepseq-devel
BuildRequires: ghc-erf-devel
BuildRequires: ghc-math-functions-devel
BuildRequires: ghc-monad-par-devel
BuildRequires: ghc-mwc-random-devel
BuildRequires: ghc-primitive-devel
BuildRequires: ghc-vector-algorithms-devel
BuildRequires: ghc-vector-binary-instances-devel
BuildRequires: ghc-vector-devel
BuildRequires: ghc-vector-th-unbox-devel
%if %{with tests}
BuildRequires: ghc-HUnit-devel
BuildRequires: ghc-QuickCheck-devel
BuildRequires: ghc-ieee754-devel
BuildRequires: ghc-test-framework-devel
BuildRequires: ghc-test-framework-hunit-devel
BuildRequires: ghc-test-framework-quickcheck2-devel
%endif
# End cabal-rpm deps
%description
This library provides a number of common functions and types useful in
statistics. We focus on high performance, numerical robustness, and use of good
algorithms. Where possible, we provide references to the statistical
literature.
The library's facilities can be divided into four broad categories:
* Working with widely used discrete and continuous probability distributions.
(There are dozens of exotic distributions in use; we focus on the most common.)
* Computing with sample data: quantile estimation, kernel density estimation,
histograms, bootstrap methods, significance testing, and regression and
autocorrelation analysis.
* Random variate generation under several different distributions.
* Common statistical tests for significant differences between samples.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-doc = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%package devel-doc
Summary: Haskell %{pkg_name} library development documentation
BuildArch: noarch
%description devel-doc
This package provides the Haskell %{pkg_name} library development
documentation.
%prep
%setup -q -n %{pkgver}
cp -p %{SOURCE1} %{pkg_name}.cabal
%build
%ghc_lib_build
%install
%ghc_lib_install
grep -v "%{_docdir}/ghc/html/libraries/%{pkgver}" %{name}-devel.files > %{name}-devel-nodoc.files
grep "%{_docdir}/ghc/html/libraries/%{pkgver}" %{name}-devel.files > %{name}-devel-doc.files
%check
%cabal_test
%post devel
%ghc_pkg_recache
%postun devel
%ghc_pkg_recache
%files -f %{name}.files
%license LICENSE
%files devel -f %{name}-devel-nodoc.files
%doc README.markdown changelog.md
%files devel-doc -f %{name}-devel-doc.files
%doc README.markdown examples
%changelog
* Sat Jul 28 2018 Jens Petersen <petersen@redhat.com> - 0.14.0.2-6
- revise .cabal
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.0.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.0.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Jens Petersen <petersen@redhat.com> - 0.14.0.2-3
- rebuild
* Mon Dec 04 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 0.14.0.2-2
- Split documentation into separate subpackage.
* Sat Nov 18 2017 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.14.0.2-1
- spec file generated by cabal-rpm-0.11.2