ghc-skein/ghc-skein.spec

161 lines
4.5 KiB
RPMSpec

# generated by cabal-rpm-1.0.1
# https://fedoraproject.org/wiki/Packaging:Haskell
%global pkg_name skein
%global pkgver %{pkg_name}-%{version}
%bcond_without tests
Name: ghc-%{pkg_name}
Version: 1.0.9.4
Release: 12%{?dist}
Summary: Skein, a family of cryptographic hash functions. Includes Skein-MAC as well
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-base-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-cereal-prof
BuildRequires: ghc-crypto-api-prof
BuildRequires: ghc-tagged-prof
%if %{with tests}
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-hspec-devel
%endif
# End cabal-rpm deps
%description
Skein (<http://www.skein-hash.info/>) is a family of fast secure cryptographic
hash functions designed by Niels Ferguson, Stefan Lucks, Bruce Schneier, Doug
Whiting, Mihir Bellare, Tadayoshi Kohno, Jon Callas and Jesse Walker.
This package uses bindings to the optimized C implementation of Skein.
We provide a high-level interface (see module "Crypto.Skein") to some of the
Skein use cases. We also provide a low-level interface (see module
"Crypto.Skein.Internal") should you need to use Skein in a different way.
Currently we have support for Skein as cryptographic hash function as Skein as
a message authentication code (Skein-MAC). For examples of how to use this
package, see "Crypto.Skein" module documentation.
This package includes Skein v1.3. Versions of this package before 1.0.0
implemented Skein v1.1.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%check
%cabal_test
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%if %{with haddock}
%files doc -f %{name}-doc.files
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
* Fri Aug 02 2019 Jens Petersen <petersen@redhat.com> - 1.0.9.4-12
- add doc and prof subpackages (cabal-rpm-1.0.0)
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9.4-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 1.0.9.4-10
- refresh to cabal-rpm-0.13
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9.4-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 28 2018 Jens Petersen <petersen@redhat.com> - 1.0.9.4-8
- rebuild
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.9.4-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Jens Petersen <petersen@redhat.com> - 1.0.9.4-5
- rebuild
* Mon Jul 17 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.9.4-4
- Re-add dist tag to release numbers.
* Mon Jul 17 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.9.4-3
- Bump for Fedora 26.
* Thu Dec 15 2016 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.0.9.4-2
- Update release to be newer than previous builds
* Thu Dec 15 2016 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 1.0.9.4-1
- spec file generated by cabal-rpm-0.10.0