ghc-serialise/ghc-serialise.spec

152 lines
4.1 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name serialise
%global pkgver %{pkg_name}-%{version}
# testsuite missing deps: quickcheck-instances
Name: ghc-%{pkg_name}
Version: 0.2.6.0
Release: %autorelease
Summary: A binary serialisation library for Haskell values
License: BSD-3-Clause
Url: https://hackage.haskell.org/package/%{pkg_name}
# https://github.com/well-typed/cborg/issues/309
ExcludeArch: %{ix86}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-array-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-cborg-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-half-devel
BuildRequires: ghc-hashable-devel
BuildRequires: ghc-primitive-devel
BuildRequires: ghc-strict-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-these-devel
BuildRequires: ghc-time-devel
BuildRequires: ghc-unordered-containers-devel
BuildRequires: ghc-vector-devel
%if %{with ghc_prof}
BuildRequires: ghc-array-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-cborg-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-half-prof
BuildRequires: ghc-hashable-prof
BuildRequires: ghc-primitive-prof
BuildRequires: ghc-strict-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-these-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-vector-prof
%endif
# End cabal-rpm deps
%description
This package (formerly 'binary-serialise-cbor') provides pure, efficient
serialization of Haskell values directly into 'ByteString's for storage or
transmission purposes. By providing a set of type class instances, you can also
serialise any custom data type you have as well.
The underlying binary format used is the 'Concise Binary Object
Representation', or CBOR, specified in RFC 7049. As a result, serialised
Haskell values have implicit structure outside of the Haskell program itself,
meaning they can be inspected or analyzed without custom tools.
An implementation of the standard bijection between CBOR and JSON is provided
by the [cborg-json](/package/cborg-json) package. Also see
[cbor-tool](/package/cbor-tool) for a convenient command-line utility for
working with CBOR data.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
cp -bp %{SOURCE1} %{pkg_name}.cabal
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE.txt
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc ChangeLog.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE.txt
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
%autochangelog