ghc-rio/ghc-rio.spec

158 lines
4.0 KiB
RPMSpec

# generated by cabal-rpm-2.0.6
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name rio
%global pkgver %{pkg_name}-%{version}
%bcond_without tests
Name: ghc-%{pkg_name}
Version: 0.1.17.0
Release: 4%{?dist}
Summary: A standard library for Haskell
License: MIT
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-base-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-deepseq-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-exceptions-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-hashable-prof
BuildRequires: ghc-microlens-prof
BuildRequires: ghc-microlens-mtl-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-primitive-prof
BuildRequires: ghc-process-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-typed-process-prof
BuildRequires: ghc-unix-prof
BuildRequires: ghc-unliftio-prof
BuildRequires: ghc-unliftio-core-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-vector-prof
%if %{with tests}
BuildRequires: ghc-QuickCheck-devel
BuildRequires: ghc-hspec-devel
%endif
# End cabal-rpm deps
%description
The goal of the rio library is to make it easier to adopt Haskell for
writing production software. It is intended as a cross between:
- Collection of well designed, trusted libraries
- Useful Prelude replacement
- A set of best practices for writing production quality Haskell code
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%check
%cabal_test
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc ChangeLog.md README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.17.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.17.0-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.17.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jun 19 2020 Jens Petersen <petersen@redhat.com> - 0.1.17.0-1
- update to 0.1.17.0
* Wed Jun 10 2020 Jens Petersen <petersen@redhat.com> - 0.1.16.0-1
- update to 0.1.16.0
* Fri Feb 28 2020 Jens Petersen <petersen@redhat.com> - 0.1.14.0-1
- update to 0.1.14.0 (lts14)
* Wed Feb 19 2020 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.1.8.0-1
- spec file generated by cabal-rpm-2.0.2