ghc-psqueues/ghc-psqueues.spec

106 lines
2.5 KiB
RPMSpec

# generated by cabal-rpm-0.12.1
# https://fedoraproject.org/wiki/Packaging:Haskell
%global pkg_name psqueues
%global pkgver %{pkg_name}-%{version}
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 0.2.4.0
Release: 10%{?dist}
Summary: Pure priority search queues
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
# Begin cabal-rpm deps:
BuildRequires: ghc-deepseq-devel
BuildRequires: ghc-hashable-devel
%if %{with tests}
BuildRequires: ghc-HUnit-devel
BuildRequires: ghc-QuickCheck-devel
BuildRequires: ghc-array-devel
BuildRequires: ghc-tagged-devel
BuildRequires: ghc-test-framework-devel
BuildRequires: ghc-test-framework-hunit-devel
BuildRequires: ghc-test-framework-quickcheck2-devel
%endif
# End cabal-rpm deps
%description
The psqueues package provides Priority Search Queues> in three different
flavors. Each of the three implementations provides the same API, so they can
be used interchangeably. Typical applications of Priority Search Queues
include:
* Caches, and more specifically LRU Caches;
* Schedulers;
* Pathfinding algorithms, such as Dijkstra's and A*.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-doc = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%prep
%setup -q -n %{pkgver}
%build
%ghc_lib_build
%install
%ghc_lib_install
%check
%cabal_test
%post devel
%ghc_pkg_recache
%postun devel
%ghc_pkg_recache
%files -f %{name}.files
%license LICENSE
%files devel -f %{name}-devel.files
%doc CHANGELOG
%changelog
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Jens Petersen <petersen@redhat.com> - 0.2.4.0-9
- rebuild
* Thu Oct 5 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 0.2.4.0-8
- Bump release to be newer than existing bundled version.
* Wed Oct 4 2017 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.2.4.0-1
- spec file generated by cabal-rpm-0.11.2