import #1925891
This commit is contained in:
parent
6ec67570d1
commit
5f8241c3d8
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/pretty-terminal-0.1.0.0.tar.gz
|
114
ghc-pretty-terminal.spec
Normal file
114
ghc-pretty-terminal.spec
Normal file
@ -0,0 +1,114 @@
|
||||
# generated by cabal-rpm-2.0.8
|
||||
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
|
||||
|
||||
%global pkg_name pretty-terminal
|
||||
%global pkgver %{pkg_name}-%{version}
|
||||
|
||||
Name: ghc-%{pkg_name}
|
||||
Version: 0.1.0.0
|
||||
Release: 2%{?dist}
|
||||
Summary: Styling and coloring terminal output with ANSI escape sequences
|
||||
|
||||
License: BSD
|
||||
Url: https://hackage.haskell.org/package/%{pkg_name}
|
||||
# Begin cabal-rpm sources:
|
||||
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
|
||||
Source1: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
|
||||
# End cabal-rpm sources
|
||||
Patch0: pretty-terminal-disable-example.patch
|
||||
|
||||
# Begin cabal-rpm deps:
|
||||
BuildRequires: dos2unix
|
||||
BuildRequires: ghc-Cabal-devel
|
||||
BuildRequires: ghc-rpm-macros
|
||||
BuildRequires: ghc-base-prof
|
||||
BuildRequires: ghc-text-prof
|
||||
# End cabal-rpm deps
|
||||
|
||||
%description
|
||||
Useful helpers to style and color text with ANSI escape sequences.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Haskell %{pkg_name} library development files
|
||||
Provides: %{name}-static = %{version}-%{release}
|
||||
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||
%if %{defined ghc_version}
|
||||
Requires: ghc-compiler = %{ghc_version}
|
||||
%endif
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package provides the Haskell %{pkg_name} library development
|
||||
files.
|
||||
|
||||
|
||||
%if %{with haddock}
|
||||
%package doc
|
||||
Summary: Haskell %{pkg_name} library documentation
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
This package provides the Haskell %{pkg_name} library documentation.
|
||||
%endif
|
||||
|
||||
|
||||
%if %{with ghc_prof}
|
||||
%package prof
|
||||
Summary: Haskell %{pkg_name} profiling library
|
||||
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
Supplements: (%{name}-devel and ghc-prof)
|
||||
|
||||
%description prof
|
||||
This package provides the Haskell %{pkg_name} profiling library.
|
||||
%endif
|
||||
|
||||
|
||||
%prep
|
||||
# Begin cabal-rpm setup:
|
||||
%setup -q -n %{pkgver}
|
||||
dos2unix -k -n %{SOURCE1} %{pkg_name}.cabal
|
||||
# End cabal-rpm setup
|
||||
%patch0 -p1 -b .orig
|
||||
|
||||
|
||||
%build
|
||||
# Begin cabal-rpm build:
|
||||
%ghc_lib_build
|
||||
# End cabal-rpm build
|
||||
|
||||
|
||||
%install
|
||||
# Begin cabal-rpm install
|
||||
%ghc_lib_install
|
||||
# End cabal-rpm install
|
||||
|
||||
|
||||
%files -f %{name}.files
|
||||
# Begin cabal-rpm files:
|
||||
%license LICENSE
|
||||
# End cabal-rpm files
|
||||
|
||||
|
||||
%files devel -f %{name}-devel.files
|
||||
%doc ChangeLog.md README.md examples
|
||||
|
||||
|
||||
%if %{with haddock}
|
||||
%files doc -f %{name}-doc.files
|
||||
%license LICENSE
|
||||
%endif
|
||||
|
||||
|
||||
%if %{with ghc_prof}
|
||||
%files prof -f %{name}-prof.files
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 9 2021 Jens Petersen <petersen@redhat.com> - 0.1.0.0-2
|
||||
- convert revised .cabal file to unix format in setup (#1925891)
|
||||
- remove the example executable
|
||||
|
||||
* Sun Feb 7 2021 Jens Petersen <petersen@redhat.com> - 0.1.0.0-1
|
||||
- spec file generated by cabal-rpm-2.0.7
|
55
pretty-terminal-0.1.0.0.cabal
Normal file
55
pretty-terminal-0.1.0.0.cabal
Normal file
@ -0,0 +1,55 @@
|
||||
-- This file has been generated from package.yaml by hpack version 0.20.0.
|
||||
--
|
||||
-- see: https://github.com/sol/hpack
|
||||
--
|
||||
-- hash: da906ab4d9433b9aa0f41e4f11e0799d878090ed582ff8dd719687946ddcecd5
|
||||
|
||||
name: pretty-terminal
|
||||
version: 0.1.0.0
|
||||
x-revision: 1
|
||||
synopsis: Styling and coloring terminal output with ANSI escape sequences.
|
||||
description: Please see the README on Github at <https://github.com/loganmac/pretty-terminal#readme>
|
||||
category: Terminal
|
||||
homepage: https://github.com/loganmac/pretty-terminal#readme
|
||||
bug-reports: https://github.com/loganmac/pretty-terminal/issues
|
||||
author: Logan McPhail
|
||||
maintainer: logan.airnomad@gmail.com
|
||||
copyright: 2018 Logan McPhail
|
||||
license: BSD3
|
||||
license-file: LICENSE
|
||||
build-type: Simple
|
||||
cabal-version: >= 1.10
|
||||
|
||||
extra-source-files:
|
||||
ChangeLog.md
|
||||
README.md
|
||||
|
||||
source-repository head
|
||||
type: git
|
||||
location: https://github.com/loganmac/pretty-terminal
|
||||
|
||||
library
|
||||
hs-source-dirs:
|
||||
src
|
||||
ghc-options: -Wall -Wincomplete-record-updates -Wincomplete-uni-patterns -Wtabs
|
||||
build-depends:
|
||||
base >=4.9 && <5
|
||||
, text
|
||||
exposed-modules:
|
||||
System.Console.Pretty
|
||||
other-modules:
|
||||
Paths_pretty_terminal
|
||||
default-language: Haskell2010
|
||||
|
||||
executable example
|
||||
main-is: Main.hs
|
||||
hs-source-dirs:
|
||||
examples
|
||||
ghc-options: -Wall -Wincomplete-record-updates -Wincomplete-uni-patterns -Wtabs -threaded -rtsopts -with-rtsopts=-N
|
||||
build-depends:
|
||||
base >=4.7 && <5
|
||||
, pretty-terminal
|
||||
, text
|
||||
other-modules:
|
||||
Paths_pretty_terminal
|
||||
default-language: Haskell2010
|
7
pretty-terminal-disable-example.patch
Normal file
7
pretty-terminal-disable-example.patch
Normal file
@ -0,0 +1,7 @@
|
||||
--- pretty-terminal-0.1.0.0/pretty-terminal.cabal~ 2021-02-09 18:47:54.000000000 +0800
|
||||
+++ pretty-terminal-0.1.0.0/pretty-terminal.cabal 2021-02-09 19:20:52.666302818 +0800
|
||||
@@ -53,3 +53,4 @@
|
||||
other-modules:
|
||||
Paths_pretty_terminal
|
||||
default-language: Haskell2010
|
||||
+ buildable: False
|
Loading…
Reference in New Issue
Block a user