ghc-persistent/ghc-persistent.spec

300 lines
9.7 KiB
RPMSpec

# generated by cabal-rpm-2.1.0 --subpackage
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name persistent
%global pkgver %{pkg_name}-%{version}
%global lifttype lift-type-0.1.0.1
%global subpkgs %{lifttype}
# testsuite missing deps: quickcheck-instances
Name: ghc-%{pkg_name}
Version: 2.14.5.1
# can only be reset when all subpkgs bumped
Release: 9%{?dist}
Summary: Type-safe, multi-backend data serialization
License: MIT
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{lifttype}/%{lifttype}.tar.gz
Source2: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros-extra
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-attoparsec-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-base64-bytestring-devel
BuildRequires: ghc-blaze-html-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-conduit-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-deepseq-devel
BuildRequires: ghc-fast-logger-devel
BuildRequires: ghc-http-api-data-devel
#BuildRequires: ghc-lift-type-devel
BuildRequires: ghc-monad-logger-devel
BuildRequires: ghc-mtl-devel
BuildRequires: ghc-path-pieces-devel
BuildRequires: ghc-resource-pool-devel
BuildRequires: ghc-resourcet-devel
BuildRequires: ghc-scientific-devel
BuildRequires: ghc-silently-devel
BuildRequires: ghc-template-haskell-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-th-lift-instances-devel
BuildRequires: ghc-time-devel
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-unliftio-devel
BuildRequires: ghc-unliftio-core-devel
BuildRequires: ghc-unordered-containers-devel
BuildRequires: ghc-vault-devel
BuildRequires: ghc-vector-devel
%if %{with ghc_prof}
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-attoparsec-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-base64-bytestring-prof
BuildRequires: ghc-blaze-html-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-conduit-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-deepseq-prof
BuildRequires: ghc-fast-logger-prof
BuildRequires: ghc-http-api-data-prof
#BuildRequires: ghc-lift-type-prof
BuildRequires: ghc-monad-logger-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-path-pieces-prof
BuildRequires: ghc-resource-pool-prof
BuildRequires: ghc-resourcet-prof
BuildRequires: ghc-scientific-prof
BuildRequires: ghc-silently-prof
BuildRequires: ghc-template-haskell-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-th-lift-instances-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-unliftio-prof
BuildRequires: ghc-unliftio-core-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-vault-prof
BuildRequires: ghc-vector-prof
%endif
# End cabal-rpm deps
%description
Persistent allows us to choose among existing databases that are highly tuned
for different data storage use cases, interoperate with other programming
languages, and to use a safe and productive query interface, while still
keeping the type safety of Haskell datatypes.
Persistent follows the guiding principles of type safety and concise,
declarative syntax. Other nice features are database-independence, convenient
data modeling, and automatic database migrations.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%global main_version %{version}
%if %{defined ghclibdir}
%ghc_lib_subpackage %{lifttype}
%endif
%global version %{main_version}
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver} -a1
cp -bp %{SOURCE2} %{pkg_name}.cabal
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_libs_build %{subpkgs}
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_libs_install %{subpkgs}
%ghc_lib_install
# End cabal-rpm install
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc ChangeLog.md README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.5.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.5.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jul 23 2023 Jens Petersen <petersen@redhat.com> - 2.14.5.1-7
- https://hackage.haskell.org/package/persistent-2.14.5.1/changelog
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.3.5-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sun Jan 22 2023 Jens Petersen <petersen@redhat.com> - 2.13.3.5-5
- https://hackage.haskell.org/package/persistent-2.13.3.5/changelog
- refresh to cabal-rpm-2.1.0 with SPDX migration
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.3.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Tue Jun 07 2022 Jens Petersen <petersen@redhat.com> - 2.13.3.0-3
- https://hackage.haskell.org/package/persistent-2.13.3.0/changelog
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 2.13.1.1-1
- update to 2.13.1.1
- subpackage lift-type
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 2.11.0.2-1
- update to 2.11.0.2
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.5.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.5.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.5.2-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.10.5.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jun 10 2020 Jens Petersen <petersen@redhat.com> - 2.10.5.2-1
- update to 2.10.5.2
* Thu Feb 20 2020 Jens Petersen <petersen@redhat.com> - 2.9.2-3
- refresh to cabal-rpm-2.0.2
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Jens Petersen <petersen@redhat.com> - 2.9.2-1
- update to 2.9.2
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 2.8.2-5
- refresh to cabal-rpm-0.13
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 28 2018 Jens Petersen <petersen@redhat.com> - 2.8.2-3
- revise .cabal
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Jul 09 2018 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.8.2-1
- update to 2.8.2
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Jens Petersen <petersen@redhat.com> - 2.7.1-3
- rebuild
* Tue Nov 07 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.7.1-2
- rebuilt
* Sat Nov 04 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.7.1-1
- Update to latest version.
* Mon Oct 23 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.7.0-4
- rebuilt
* Mon Sep 04 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 2.7.0-3
- Split docs into subpackage.
* Sun Sep 03 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 2.7.0-2
- Add a real description.
- Update to latest spec template.
* Fri Jul 21 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 2.7.0-1
- Update to latest version.
* Fri Jul 21 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> 2.2.4.1-6
- Bump for Fedora 26.
* Fri Dec 16 2016 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.2.4.1-5
- Bump to rebuild against new dependencies
* Thu Dec 15 2016 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.2.4.1-4
- Update release to be newer than previous builds
* Thu Dec 15 2016 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 2.2.4.1-1
- spec file generated by cabal-rpm-0.10.0