ghc-http-streams/ghc-http-streams.spec

170 lines
4.3 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name http-streams
%global pkgver %{pkg_name}-%{version}
# https://github.com/aesiniath/http-streams/issues/125
%ifnarch i686 armv7hl s390x
%bcond_without tests
%endif
Name: ghc-%{pkg_name}
Version: 0.8.9.8
Release: %autorelease
Summary: An HTTP client using io-streams
License: BSD-3-Clause
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-HsOpenSSL-devel
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-attoparsec-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-base64-bytestring-devel
BuildRequires: ghc-blaze-builder-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-case-insensitive-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-http-common-devel
BuildRequires: ghc-io-streams-devel
BuildRequires: ghc-mtl-devel
BuildRequires: ghc-network-devel
BuildRequires: ghc-network-uri-devel
BuildRequires: ghc-openssl-streams-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-unordered-containers-devel
%if %{with ghc_prof}
BuildRequires: ghc-HsOpenSSL-prof
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-attoparsec-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-base64-bytestring-prof
BuildRequires: ghc-blaze-builder-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-case-insensitive-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-http-common-prof
BuildRequires: ghc-io-streams-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-network-prof
BuildRequires: ghc-network-uri-prof
BuildRequires: ghc-openssl-streams-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-unordered-containers-prof
%endif
%if %{with tests}
BuildRequires: ghc-HUnit-devel
BuildRequires: ghc-aeson-pretty-devel
BuildRequires: ghc-hspec-devel
BuildRequires: ghc-hspec-expectations-devel
BuildRequires: ghc-lifted-base-devel
BuildRequires: ghc-snap-core-devel
BuildRequires: ghc-snap-server-devel
BuildRequires: ghc-system-fileio-devel
BuildRequires: ghc-system-filepath-devel
%endif
# End cabal-rpm deps
%description
An HTTP client, using the Snap Framework's 'io-streams' library to handle the
streaming IO. The API is optimized for ease of use for the rather common case
of code needing to query web services and deal with the result.
The library is exported in a single module; see "Network.Http.Client" for full
documentation.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc CHANGELOG.md README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
%autochangelog