ghc-hledger-lib/ghc-hledger-lib.spec

434 lines
14 KiB
RPMSpec

# generated by cabal-rpm-2.1.0 --subpackage
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name hledger-lib
%global pkgver %{pkg_name}-%{version}
%global cassavamegaparsec cassava-megaparsec-2.0.4
%global timeit timeit-2.0
%global breakpoint breakpoint-0.1.2.0
%global subpkgs %{cassavamegaparsec} %{timeit} %{breakpoint}
# doctest testsuite failing
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 1.27.1
# can only be reset when all subpkgs bumped
Release: 12%{?dist}
Summary: A reusable library providing the core functionality of hledger
License: GPL-3.0-or-later
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
Source1: https://hackage.haskell.org/package/%{cassavamegaparsec}/%{cassavamegaparsec}.tar.gz
Source2: https://hackage.haskell.org/package/%{timeit}/%{timeit}.tar.gz
Source3: https://hackage.haskell.org/package/%{breakpoint}/%{breakpoint}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros-extra
BuildRequires: ghc-Decimal-devel
BuildRequires: ghc-Glob-devel
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-aeson-pretty-devel
BuildRequires: ghc-ansi-terminal-devel
BuildRequires: ghc-array-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-blaze-markup-devel
#BuildRequires: ghc-breakpoint-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-call-stack-devel
BuildRequires: ghc-cassava-devel
#BuildRequires: ghc-cassava-megaparsec-devel
BuildRequires: ghc-cmdargs-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-data-default-devel
BuildRequires: ghc-deepseq-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-doclayout-devel
BuildRequires: ghc-extra-devel
BuildRequires: ghc-file-embed-devel
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-hashtables-devel
BuildRequires: ghc-megaparsec-devel
BuildRequires: ghc-microlens-devel
BuildRequires: ghc-microlens-th-devel
BuildRequires: ghc-mtl-devel
BuildRequires: ghc-parser-combinators-devel
BuildRequires: ghc-pretty-simple-devel
BuildRequires: ghc-regex-tdfa-devel
BuildRequires: ghc-safe-devel
BuildRequires: ghc-tabular-devel
BuildRequires: ghc-tasty-devel
BuildRequires: ghc-tasty-hunit-devel
BuildRequires: ghc-template-haskell-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-time-devel
#BuildRequires: ghc-timeit-devel
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-uglymemo-devel
BuildRequires: ghc-unordered-containers-devel
BuildRequires: ghc-utf8-string-devel
%if %{with ghc_prof}
BuildRequires: ghc-Decimal-prof
BuildRequires: ghc-Glob-prof
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-aeson-pretty-prof
BuildRequires: ghc-ansi-terminal-prof
BuildRequires: ghc-array-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-blaze-markup-prof
#BuildRequires: ghc-breakpoint-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-call-stack-prof
BuildRequires: ghc-cassava-prof
#BuildRequires: ghc-cassava-megaparsec-prof
BuildRequires: ghc-cmdargs-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-data-default-prof
BuildRequires: ghc-deepseq-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-doclayout-prof
BuildRequires: ghc-extra-prof
BuildRequires: ghc-file-embed-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-hashtables-prof
BuildRequires: ghc-megaparsec-prof
BuildRequires: ghc-microlens-prof
BuildRequires: ghc-microlens-th-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-parser-combinators-prof
BuildRequires: ghc-pretty-simple-prof
BuildRequires: ghc-regex-tdfa-prof
BuildRequires: ghc-safe-prof
BuildRequires: ghc-tabular-prof
BuildRequires: ghc-tasty-prof
BuildRequires: ghc-tasty-hunit-prof
BuildRequires: ghc-template-haskell-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-prof
#BuildRequires: ghc-timeit-prof
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-uglymemo-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-utf8-string-prof
%endif
# for missing dep 'cassava-megaparsec':
BuildRequires: ghc-vector-devel
%if %{with ghc_prof}
BuildRequires: ghc-vector-prof
%endif
# for missing dep 'breakpoint':
BuildRequires: ghc-ghc-devel
BuildRequires: ghc-haskeline-devel
%if %{with ghc_prof}
BuildRequires: ghc-ghc-prof
BuildRequires: ghc-haskeline-prof
%endif
# End cabal-rpm deps
%description
A reusable library containing hledger's core functionality. This is used by
most hledger* packages so that they support the same common file formats,
command line options, reports etc.
hledger is a robust, cross-platform set of tools for tracking money, time, or
any other commodity, using double-entry accounting and a simple, editable file
format, with command-line, terminal and web interfaces. It is a Haskell rewrite
of Ledger, and one of the leading implementations of Plain Text Accounting.
Read more at: <https://hledger.org>.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%global main_version %{version}
%if %{defined ghclibdir}
%ghc_lib_subpackage -l MIT %{cassavamegaparsec}
%ghc_lib_subpackage -l BSD-3-Clause %{timeit}
%ghc_lib_subpackage -l MIT %{breakpoint}
%endif
%global version %{main_version}
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver} -a1 -a2 -a3
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_libs_build %{subpkgs}
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_libs_install %{subpkgs}
%ghc_lib_install
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc CHANGES.md README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
* Sun Jan 22 2023 Jens Petersen <petersen@redhat.com> - 1.27.1-12
- https://hackage.haskell.org/package/hledger-lib-1.27.1/changelog
- new dependency: breakpoint
- refresh to cabal-rpm-2.1.0 with SPDX migration
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.21-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jun 17 2022 Jens Petersen <petersen@redhat.com> - 1.21-10
- rebuild
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.21-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 1.21-8
- update to 1.21
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 1.20.4-7
- update to 1.20.4
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 1.20.3-6
- update to 1.20.3
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Thu Jul 16 2020 Jens Petersen <petersen@redhat.com> - 1.18.1-3
- update to 1.18.1
* Fri Jun 19 2020 Jens Petersen <petersen@redhat.com> - 1.18-2
- update to 1.18
* Wed Jun 10 2020 Jens Petersen <petersen@redhat.com> - 1.16.2-1
- update to 1.16.2
- timeit replaces easyeasy
* Fri Feb 14 2020 Jens Petersen <petersen@redhat.com> - 1.14.1-3
- update to 1.14.1
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Jens Petersen <petersen@redhat.com> - 1.12-1
- update to 1.12
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Wed Apr 3 2019 Jens Petersen <petersen@redhat.com> - 1.10-2
- base-compat-batteries, megaparsec, and parser-combinators were packaged
* Thu Feb 21 2019 Jens Petersen <petersen@redhat.com> - 1.10-1
- update to 1.10
- subpackage base-compat-batteries
* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 1.5.1-6
- refresh to cabal-rpm-0.13
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sun Jul 22 2018 Jens Petersen <petersen@redhat.com> - 1.5.1-4
- update to 1.5.1
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Jan 24 2018 Jens Petersen <petersen@redhat.com> - 1.4-4
- update to 1.4
- update megaparsec to 6.3.0, which needs parser-combinators
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri May 26 2017 Jens Petersen <petersen@redhat.com> - 1.2-1
- update to 1.2
- megaparsec-5.2.0
* Mon Feb 20 2017 Jens Petersen <petersen@redhat.com> - 1.0.1-1
- update to 1.0.1
- subpackage megaparsec
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.27.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Sep 5 2016 Jens Petersen <petersen@redhat.com> - 0.27.1-1
- update to 0.27.1
- use pretty-show
* Tue May 24 2016 Ben Boeckel <mathstuf@gmail.com> - 0.24-5
- Rebuild for ghc-cmdargs, ghc-regexpr, ghc-split
- doc -> license macro
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.24-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Sat Aug 08 2015 Ben Boeckel <mathstuf@gmail.com> - 0.24-3
- rebuild for ghc-safe bump
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sun Mar 01 2015 Ben Boeckel <mathstuf@gmail.com> - 0.24-1
- update to 0.24
- cblrpm refresh
* Fri Aug 29 2014 Jens Petersen <petersen@redhat.com> - 0.23.2-1
- update to 0.23.2
- patch out pretty-show until available in Fedora
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.19.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.19.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.19.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Jun 12 2013 Jens Petersen <petersen@redhat.com> - 0.19.3-1
- update to 0.19.3
- update to new simplified Haskell Packaging Guidelines
* Fri Mar 22 2013 Jens Petersen <petersen@redhat.com> - 0.17-9
- rebuild
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Fri Nov 9 2012 Jens Petersen <petersen@redhat.com> - 0.17-7
- allow building with cmdargs 0.10 and split 0.2
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.17-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Mon Jul 16 2012 Jens Petersen <petersen@redhat.com> - 0.17-5
- change prof BRs to devel
* Fri Jun 22 2012 Jens Petersen <petersen@redhat.com> - 0.17-4
- rebuild
* Sat Jun 16 2012 Jens Petersen <petersen@redhat.com> - 0.17-3
- rebuild
* Thu Mar 22 2012 Jens Petersen <petersen@redhat.com> - 0.17-2
- add license to ghc_files
* Tue Feb 28 2012 Ben Boeckel <mathstuf@gmail.com> - 0.17-1
- Update to 0.17
* Wed Jan 4 2012 Jens Petersen <petersen@redhat.com> - 0.16.1-1
- update to 0.16.1 and cabal2spec-0.25.2
* Mon Oct 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.16-1.1
- rebuild with new gmp without compat lib
* Mon Oct 3 2011 Jens Petersen <petersen@redhat.com> - 0.16-1
- update to 0.16
- new dependency on ghc-cmdargs
* Mon Oct 3 2011 Jens Petersen <petersen@redhat.com> - 0.14-2
- BR ghc-*-prof not devel
* Sat Jul 09 2011 Ben Boeckel <mathstuf@gmail.com> - 0.14-1
- Update to 0.14 and cabal2spec-0.24
* Fri Dec 10 2010 Ben Boeckel <mathstuf@gmail.com> - 0.13-1
- Update to 0.13
* Fri Dec 03 2010 Ben Boeckel <mathstuf@gmail.com> - 0.12.98-1
- Update to snapshot (0.12.98)
* Sat Oct 30 2010 Ben Boeckel <mathstuf@gmail.com> - 0.12.1-1
- Update to 0.12.1
* Sun Sep 05 2010 Ben Boeckel <mathstuf@gmail.com> - 0.12-1
- Update to 0.12
* Fri Sep 03 2010 Ben Boeckel <mathstuf@gmail.com> - 0.11.1-1
- Initial package
* Fri Sep 3 2010 Fedora Haskell SIG <haskell-devel@lists.fedoraproject.org> - 0.11.1-0
- initial packaging for Fedora automatically generated by cabal2spec-0.22.2