ghc-cryptonite/ghc-cryptonite.spec

164 lines
4.0 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name cryptonite
%global pkgver %{pkg_name}-%{version}
# https://github.com/feuerbach/tasty/issues/266
# https://gitlab.haskell.org/ghc/ghc/issues/17744
# still hanging on Fedora
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 0.30
Release: %autorelease
Summary: Cryptography Primitives sink
# Main - Argon2 C code - Blake2 C code
License: BSD-3-Clause and (CC0-1.0 or Apache-2.0) and (CC0-1.0 or Apache-2.0 or OpenSSL)
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-base-devel
BuildRequires: ghc-basement-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-deepseq-devel
BuildRequires: ghc-memory-devel
%if %{with ghc_prof}
BuildRequires: ghc-base-prof
BuildRequires: ghc-basement-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-deepseq-prof
BuildRequires: ghc-memory-prof
%endif
BuildRequires: glibc-devel
%if %{with tests}
BuildRequires: ghc-tasty-devel
BuildRequires: ghc-tasty-hunit-devel
BuildRequires: ghc-tasty-kat-devel
BuildRequires: ghc-tasty-quickcheck-devel
%endif
# End cabal-rpm deps
%description
A repository of cryptographic primitives.
* Symmetric ciphers: AES, DES, 3DES, CAST5, Blowfish, Twofish, Camellia, RC4,
Salsa, XSalsa, ChaCha.
* Hash: SHA1, SHA2, SHA3, SHAKE, MD2, MD4, MD5, Keccak, Skein, Ripemd, Tiger,
Whirlpool, Blake2
* MAC: HMAC, KMAC, Poly1305
* Asymmetric crypto: DSA, RSA, DH, ECDH, ECDSA, ECC, Curve25519, Curve448,
Ed25519, Ed448
* Key Derivation Function: PBKDF2, Scrypt, HKDF, Argon2, BCrypt, BCryptPBKDF
* Cryptographic Random generation: System Entropy, Deterministic Random
Generator
* Data related: Anti-Forensic Information Splitter (AFIS)
If anything cryptographic related is missing from here, submit a pull request
to have it added. This package strives to be a cryptographic kitchen sink that
provides cryptography for everyone.
Evaluate the security related to your requirements before using.
Read "Crypto.Tutorial" for a quick start guide.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
# Begin cabal-rpm deps:
Requires: glibc-devel%{?_isa}
# End cabal-rpm deps
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
# docs are arch dependent
Requires: ghc-filesystem
Obsoletes: %{name}-devel-doc < %{version}-%{release}
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc CHANGELOG.md README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
%autochangelog