ghc-aws/ghc-aws.spec

187 lines
5.1 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name aws
%global pkgver %{pkg_name}-%{version}
# testsuite missing deps: quickcheck-instances
Name: ghc-%{pkg_name}
Version: 0.23
Release: %autorelease
Summary: Amazon Web Services (AWS) for Haskell
License: BSD-3-Clause
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-attoparsec-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-base16-bytestring-devel
BuildRequires: ghc-base64-bytestring-devel
BuildRequires: ghc-blaze-builder-devel
BuildRequires: ghc-byteable-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-case-insensitive-devel
BuildRequires: ghc-cereal-devel
BuildRequires: ghc-conduit-devel
BuildRequires: ghc-conduit-extra-devel
BuildRequires: ghc-containers-devel
BuildRequires: ghc-cryptonite-devel
BuildRequires: ghc-data-default-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-exceptions-devel
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-http-client-tls-devel
BuildRequires: ghc-http-conduit-devel
BuildRequires: ghc-http-types-devel
BuildRequires: ghc-lifted-base-devel
BuildRequires: ghc-memory-devel
BuildRequires: ghc-monad-control-devel
BuildRequires: ghc-mtl-devel
BuildRequires: ghc-network-devel
BuildRequires: ghc-network-bsd-devel
BuildRequires: ghc-old-locale-devel
BuildRequires: ghc-resourcet-devel
BuildRequires: ghc-safe-devel
BuildRequires: ghc-scientific-devel
BuildRequires: ghc-tagged-devel
BuildRequires: ghc-text-devel
BuildRequires: ghc-time-devel
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-unordered-containers-devel
BuildRequires: ghc-utf8-string-devel
BuildRequires: ghc-vector-devel
BuildRequires: ghc-xml-conduit-devel
%if %{with ghc_prof}
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-attoparsec-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-base16-bytestring-prof
BuildRequires: ghc-base64-bytestring-prof
BuildRequires: ghc-blaze-builder-prof
BuildRequires: ghc-byteable-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-case-insensitive-prof
BuildRequires: ghc-cereal-prof
BuildRequires: ghc-conduit-prof
BuildRequires: ghc-conduit-extra-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-cryptonite-prof
BuildRequires: ghc-data-default-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-exceptions-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-http-client-tls-prof
BuildRequires: ghc-http-conduit-prof
BuildRequires: ghc-http-types-prof
BuildRequires: ghc-lifted-base-prof
BuildRequires: ghc-memory-prof
BuildRequires: ghc-monad-control-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-network-prof
BuildRequires: ghc-network-bsd-prof
BuildRequires: ghc-old-locale-prof
BuildRequires: ghc-resourcet-prof
BuildRequires: ghc-safe-prof
BuildRequires: ghc-scientific-prof
BuildRequires: ghc-tagged-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-prof
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-unordered-containers-prof
BuildRequires: ghc-utf8-string-prof
BuildRequires: ghc-vector-prof
BuildRequires: ghc-xml-conduit-prof
%endif
# End cabal-rpm deps
%description
Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS
services. To see a high level overview of the library, see the README at
<https://github.com/aristidb/aws/blob/master/README.md>.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc CHANGELOG.md Examples README.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
%autochangelog