Update to 0.19.3-1

This commit is contained in:
Daiki Ueno 2014-10-16 18:59:38 +09:00
parent 32c7ad1986
commit d5e533acc8
6 changed files with 14 additions and 277 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@ gettext-0.18.1.1.tar.gz
/gettext-0.19.tar.gz
/gettext-0.19.1.tar.xz
/gettext-0.19.2.tar.xz
/gettext-0.19.3.tar.xz

View File

@ -1,82 +0,0 @@
commit d75090f27cf150267bd59a9e1be42ec51bfb7b0e
Author: Eric Blake <eblake@redhat.com>
Date: Fri Oct 10 07:31:46 2014 +0900
autopoint: Fix infinite recursion when tracing configure.ac
Reported by Andreas Henriksson at:
<https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=764580>
* autopoint.in (func_trace_autoconf): Temporarily redefine
built-in macros, instead of undefining.
* gettextize.in: Likewise.
Index: gettext-0.19.2/gettext-tools/misc/autopoint.in
===================================================================
--- gettext-0.19.2.orig/gettext-tools/misc/autopoint.in
+++ gettext-0.19.2/gettext-tools/misc/autopoint.in
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# Copyright (C) 2002-2013 Free Software Foundation, Inc.
+# Copyright (C) 2002-2014 Free Software Foundation, Inc.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -143,14 +143,14 @@ fi
func_trace_autoconf ()
{
echo '\
-dnl disable macros which may abort autom4te
-m4_undefine([m4_assert])
-m4_undefine([m4_fatal])
-m4_undefine([m4_warn])
-m4_undefine([m4_errprintn])
-m4_undefine([m4_exit])
-m4_undefine([m4_include])
-m4_undefine([m4_esyscmd])
+dnl replace macros which may abort autom4te with a no-op variant
+m4_pushdef([m4_assert])
+m4_pushdef([m4_fatal])
+m4_pushdef([m4_warn])
+m4_pushdef([m4_errprintn])
+m4_pushdef([m4_exit])
+m4_pushdef([m4_include])
+m4_pushdef([m4_esyscmd])
' \
| "$AUTOM4TE" --no-cache --language=Autoconf-without-aclocal-m4 \
--trace="$1":\$% - "$2" 2>/dev/null
Index: gettext-0.19.2/gettext-tools/misc/gettextize.in
===================================================================
--- gettext-0.19.2.orig/gettext-tools/misc/gettextize.in
+++ gettext-0.19.2/gettext-tools/misc/gettextize.in
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# Copyright (C) 1995-1998, 2000-2013 Free Software Foundation, Inc.
+# Copyright (C) 1995-1998, 2000-2014 Free Software Foundation, Inc.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -143,14 +143,14 @@ fi
func_trace_autoconf ()
{
echo '\
-dnl disable macros which may abort autom4te
-m4_undefine([m4_assert])
-m4_undefine([m4_fatal])
-m4_undefine([m4_warn])
-m4_undefine([m4_errprintn])
-m4_undefine([m4_exit])
-m4_undefine([m4_include])
-m4_undefine([m4_esyscmd])
+dnl replace macros which may abort autom4te with a no-op variant
+m4_pushdef([m4_assert])
+m4_pushdef([m4_fatal])
+m4_pushdef([m4_warn])
+m4_pushdef([m4_errprintn])
+m4_pushdef([m4_exit])
+m4_pushdef([m4_include])
+m4_pushdef([m4_esyscmd])
' \
| "$AUTOM4TE" --no-cache --language=Autoconf-without-aclocal-m4 \
--trace="$1":\$% - "$2" 2>/dev/null

View File

@ -1,14 +0,0 @@
diff --git a/gettext-tools/src/x-c.c b/gettext-tools/src/x-c.c
index 479b8e8..a5978c9 100644
--- a/gettext-tools/src/x-c.c
+++ b/gettext-tools/src/x-c.c
@@ -996,7 +996,8 @@ literalstring_parse (const char *string, lex_pos_ty *pos,
for (n = 0, j = 0; j < 3; ++j)
{
n = n * 8 + c - '0';
- switch (*++p)
+ c = *++p;
+ switch (c)
{
default:
break;

View File

@ -1,167 +0,0 @@
From a843584fc210219a62472305d924de44ebb0ab02 Mon Sep 17 00:00:00 2001
From: Daiki Ueno <ueno@gnu.org>
Date: Wed, 15 Oct 2014 12:37:45 +0900
Subject: [PATCH] tests: Support newer ncurses with italic caps in xterm
terminfo
* tests/test-term-ostream-xterm-basic-italic.out: New file.
* tests/test-term-ostream-xterm: Use it as possible test result.
* Makefile.am (EXTRA_DIST): Add new files.
Needed for ncurses >= 5.9-20140906 that defines sitm/ritm in the
xterm-basic terminfo definition.
---
gnulib-local/ChangeLog | 8 ++
gnulib-local/Makefile.am | 1 +
gnulib-local/tests/test-term-ostream-xterm | 1 +
.../tests/test-term-ostream-xterm-basic-italic.out | 131 +++++++++++++++++++++
4 files changed, 141 insertions(+)
create mode 100644 gnulib-local/tests/test-term-ostream-xterm-basic-italic.out
Index: gettext-0.19.2/gettext-tools/gnulib-tests/test-term-ostream-xterm-basic-italic.out
===================================================================
--- /dev/null
+++ gettext-0.19.2/gettext-tools/gnulib-tests/test-term-ostream-xterm-basic-italic.out
@@ -0,0 +1,131 @@
+Colors (foreground/background):
+ |black |blue |green |cyan |red |magenta|yellow |white |default
+black | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+blue | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+green | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+cyan | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+red | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+magenta| Words | Words | Words | Words | Words | Words | Words | Words | Words 
+yellow | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+white | Words | Words | Words | Words | Words | Words | Words | Words | Words 
+default| Words | Words | Words | Words | Words | Words | Words | Words | Words
+
+Colors (hue/saturation):
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+  
+
+Weights:
+normal, bold, (Bdefault
+
+Postures:
+normal, italic, default
+
+Text decorations:
+normal, underlined, default
+
Index: gettext-0.19.2/gettext-tools/gnulib-tests/test-term-ostream-xterm
===================================================================
--- gettext-0.19.2.orig/gettext-tools/gnulib-tests/test-term-ostream-xterm
+++ gettext-0.19.2/gettext-tools/gnulib-tests/test-term-ostream-xterm
@@ -22,6 +22,7 @@ LC_ALL=C tr -d '\r' < out1 > out
${DIFF} ${srcdir}/test-term-ostream-xterm-r6.out out > /dev/null \
|| ${DIFF} ${srcdir}/test-term-ostream-xterm-xf86-v32.out out > /dev/null \
|| ${DIFF} ${srcdir}/test-term-ostream-xterm-basic.out out > /dev/null \
+|| ${DIFF} ${srcdir}/test-term-ostream-xterm-basic-italic.out out > /dev/null \
|| ${DIFF} ${srcdir}/test-term-ostream-xterm-8bit.out out > /dev/null \
|| ${DIFF} ${srcdir}/test-term-ostream-xterm-linux-debian.out out > /dev/null \
|| ${DIFF} ${srcdir}/test-term-ostream-xterm-linux-mandriva.out out > /dev/null \

View File

@ -5,22 +5,19 @@
Summary: GNU libraries and utilities for producing multi-lingual messages
Name: gettext
Version: 0.19.2
Release: 5%{?dist}
Version: 0.19.3
Release: 1%{?dist}
License: GPLv3+ and LGPLv2+
Group: Development/Tools
URL: http://www.gnu.org/software/gettext/
Source: ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.xz
Source2: msghack.py
Source3: msghack.1
# backport from upstream
Patch0: gettext-fix-octal-char-escape.patch
Patch1: gettext-ncurses-italic.patch
Patch2: gettext-autopoint-infloop.patch
# removal of openmp.m4
BuildRequires: autoconf >= 2.62
BuildRequires: automake
BuildRequires: libtool, bison, gcc-c++
# for bootstrapping
# BuildRequires: autoconf >= 2.62
# BuildRequires: automake
# BuildRequires: libtool, bison
BuildRequires: gcc-c++
%if %{with java}
# libintl.jar requires gcj >= 4.3 to build
BuildRequires: gcc-java, libgcj
@ -138,9 +135,6 @@ Emacs.
%prep
%setup -q
%patch0 -p1 -b .fix-octal-char-escape.patch
%patch1 -p1 -b .ncurses-italic
%patch2 -p1 -b .autopoint-infloop
%build
@ -336,6 +330,11 @@ fi
%{_emacs_sitelispdir}/%{name}/*.el
%changelog
* Thu Oct 16 2014 Daiki Ueno <dueno@redhat.com> - 0.19.3-1
- update to 0.19.3 release
- remove patches included in 0.19.3
- remove autoconf/automake/libtool/bison from BR, as we don't do bootstrap
* Wed Oct 15 2014 Daiki Ueno <dueno@redhat.com> - 0.19.2-5
- apply patch to fix infloop in autopoint (Closes: #1151238)
- apply patch to support newer ncurses in F-22

View File

@ -1 +1 @@
1e6a827f5fbd98b3d40bd16b803acc44 gettext-0.19.2.tar.xz
092c3f460553ceb4a638ff81d36434c4 gettext-0.19.3.tar.xz