update to 0.21.1 release

This commit is contained in:
Sundeep Anand 2022-10-14 13:38:25 +05:30
parent e09fc9f993
commit 7aca11f7d4
4 changed files with 19 additions and 20 deletions

View File

@ -1,5 +1,5 @@
diff --git a/Makefile.am b/Makefile.am
index 764336c..daed715 100644
index 5a7184c..28267a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@
@ -11,14 +11,14 @@ index 764336c..daed715 100644
changelog_etc = \
gettext-runtime/ChangeLog.0 \
@@ -85,7 +85,6 @@ distcheck-hook:
cmp -s $(srcdir)/gettext-runtime/m4/xsize.m4 $(srcdir)/gettext-tools/gnulib-m4/xsize.m4
@@ -124,7 +124,6 @@ distcheck-hook:
test "`sed 1,16d $(srcdir)/gettext-runtime/intl/xsize.h | md5sum`" = "`sed 1,16d $(srcdir)/gettext-tools/gnulib-lib/xsize.h | md5sum`"
cmp -s $(srcdir)/gettext-runtime/man/help2man $(srcdir)/gettext-tools/man/help2man
cmp -s $(srcdir)/gettext-runtime/man/x-to-1.in $(srcdir)/gettext-tools/man/x-to-1.in
- cmp -s $(srcdir)/libtextstyle/m4/libtextstyle.m4 $(srcdir)/gettext-tools/gnulib-m4/libtextstyle.m4
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.java $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.java
cmp -s $(srcdir)/gettext-tools/examples/hello-java-awt/m4/TestAWT.class $(srcdir)/gettext-tools/examples/hello-java-swing/m4/TestAWT.class
# Verify that all files have appropriate copyright headers.
test "`sed 1,15d $(srcdir)/gnulib-local/lib/alloca.in.h | md5sum`" = "`sed 1,15d $(srcdir)/gettext-runtime/libasprintf/alloca.in.h | md5sum`"
diff --git a/configure.ac b/configure.ac
index f4e54ea..ff850ae 100644
--- a/configure.ac
@ -42,20 +42,20 @@ index f4e54ea..ff850ae 100644
AC_CONFIG_FILES([Makefile])
diff --git a/gettext-tools/Makefile.am b/gettext-tools/Makefile.am
index 90f5548..cdf2834 100644
index 449a797..bce4ad8 100644
--- a/gettext-tools/Makefile.am
+++ b/gettext-tools/Makefile.am
@@ -19,7 +19,7 @@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
-SUBDIRS = gnulib-lib libgrep src libgettextpo po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
+SUBDIRS = gnulib-lib libgrep libgettextpo src po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
-SUBDIRS = intl gnulib-lib libgrep src libgettextpo po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
+SUBDIRS = intl gnulib-lib libgrep libgettextpo src po its projects styles emacs misc man m4 tests system-tests gnulib-tests examples doc
EXTRA_DIST = misc/DISCLAIM
MOSTLYCLEANFILES = core *.stackdump
diff --git a/gettext-tools/libgettextpo/textstyle.in.h b/gettext-tools/libgettextpo/textstyle.in.h
index 60015bd..ae5f5fb 100644
index 05ce0cf..936331c 100644
--- a/gettext-tools/libgettextpo/textstyle.in.h
+++ b/gettext-tools/libgettextpo/textstyle.in.h
@@ -239,7 +239,8 @@ typedef ostream_t file_ostream_t;
@ -100,10 +100,10 @@ index 60015bd..ae5f5fb 100644
#define color_test_mode false
diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
index f5e52ea..a9c9fac 100644
index 510ab2a..72791ba 100644
--- a/gettext-tools/src/Makefile.am
+++ b/gettext-tools/src/Makefile.am
@@ -300,19 +300,9 @@ cldr_plurals_SOURCES = cldr-plural.y cldr-plural-exp.c cldr-plurals.c
@@ -291,19 +291,9 @@ cldr_plurals_SOURCES = cldr-plural.y cldr-plural-exp.c cldr-plurals.c
cldr_plurals_CFLAGS = $(AM_CFLAGS) $(INCXML)
cldr_plurals_LDADD = libgettextsrc.la $(LDADD)

View File

@ -1,11 +1,10 @@
%bcond_with jar
%bcond_with java
%global snapshot 20220203
Summary: GNU tools and libraries for localized translated messages
Name: gettext
Version: 0.21
Release: 20.0.%{snapshot}%{?dist}
Version: 0.21.1
Release: 1%{?dist}
# The following are licensed under LGPLv2+:
# - libintl and its headers
@ -22,15 +21,13 @@ Release: 20.0.%{snapshot}%{?dist}
# Everything else is GPLv3+
License: GPLv3+ and LGPLv2+ and GFDL
URL: https://www.gnu.org/software/gettext/
# Snapshot tarball has been generated by following upstream release steps.
# https://git.savannah.gnu.org/gitweb/?p=gettext.git;a=blob;f=Admin/release-steps
Source: %{name}-%{version}-%{snapshot}.tar.gz
Source: https://ftp.gnu.org/pub/gnu/%{name}/%{name}-%{version}.tar.gz
Source2: msghack.py
Source3: msghack.1
Patch1: %{name}-%{version}-disable-libtextstyle.patch
Patch2: %{name}-%{version}-covscan.patch
Patch3: gettext-java17-2062407.patch
Patch3: %{name}-java17-2062407.patch
# for bootstrapping
# BuildRequires: autoconf >= 2.62
@ -210,7 +207,7 @@ export CFLAGS="$RPM_OPT_FLAGS -D__SUPPORT_SNAN__"
export CPPFLAGS="-I%{_includedir}/libxml2"
# Side effect of unbundling libxml2 from libtextstyle.
export LIBS="-lxml2"
%configure --without-included-gettext --enable-nls --disable-static \
%configure --enable-nls --disable-static \
--enable-shared --disable-csharp --disable-rpath \
%if %{with java}
--enable-java \
@ -238,7 +235,6 @@ sed -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
install -pm 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_bindir}/msghack
install -pm 644 %SOURCE3 ${RPM_BUILD_ROOT}%{_mandir}/man1/msghack.1
# make preloadable_libintl.so executable
chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/preloadable_libintl.so
@ -420,6 +416,9 @@ make check LIBUNISTRING=-lunistring
%{_mandir}/man1/msghack.1*
%changelog
* Fri Oct 14 2022 Sundeep Anand <suanand@redhat.com> - 0.21.1-1
- update to 0.21.1 release
* Thu Oct 13 2022 Sundeep Anand <suanand@redhat.com> - 0.21-20.0.20220203
- Include doc and man pages for envsubst subpackage.
Move _libdir and _datadir from gettext-runtime to gettext package.

View File

@ -1 +1 @@
SHA512 (gettext-0.21-20220203.tar.gz) = ffa90ef2fe7894504a35ee1cee8e45e4e500dd22a10e70e888a95e4aa80002fad063e9ecc5610b4617908ddef05b50e780115b1c26864bce16fea9d02a44665b
SHA512 (gettext-0.21.1.tar.gz) = ccd43a43fab3c90ed99b3e27628c9aeb7186398153b137a4997f8c7ddfd9729b0ba9d15348567e5206af50ac027673d2b8a3415bb3fc65f87ad778f85dc03a05