Initial import into devel.
Modified Files: import.log devel/.cvsignore devel/sources Added Files: devel/gengetopt-2.19.1-from-debian.patch devel/gengetopt-2.19.1-man.patch devel/gengetopt.spec
This commit is contained in:
parent
6327f2e5f7
commit
b441d24d5c
@ -0,0 +1 @@
|
||||
gengetopt-2.19.1.tar.gz
|
16
gengetopt-2.19.1-from-debian.patch
Normal file
16
gengetopt-2.19.1-from-debian.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -urNp gengetopt-2.19.1.orig/doc/README.example gengetopt-2.19.1/doc/README.example
|
||||
--- gengetopt-2.19.1.orig/doc/README.example 1970-01-01 05:30:00.000000000 +0530
|
||||
+++ gengetopt-2.19.1/doc/README.example 2007-06-10 16:57:03.000000000 +0530
|
||||
@@ -0,0 +1,12 @@
|
||||
+#!/bin/sh -v
|
||||
+
|
||||
+# commands to try the C++ example:
|
||||
+
|
||||
+gengetopt -isample1.ggo -Fcmdline1 --long-help -u c++ -o main1 main1.cc cmdline1.c
|
||||
+./main1 --help
|
||||
+
|
||||
+# commands to try the C example:
|
||||
+
|
||||
+gengetopt --input=sample2.ggo --func-name=my_cmdline_parser --file-name=cmdline2 --unamed-opts
|
||||
+gcc -o main2 main2.c cmdline2.c
|
||||
+./main2 -h
|
19
gengetopt-2.19.1-man.patch
Normal file
19
gengetopt-2.19.1-man.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -urNp gengetopt-2.19.1.orig/doc/gengetopt.1 gengetopt-2.19.1/doc/gengetopt.1
|
||||
--- gengetopt-2.19.1.orig/doc/gengetopt.1 2006-12-11 13:39:44.000000000 +0530
|
||||
+++ gengetopt-2.19.1/doc/gengetopt.1 2007-06-10 17:04:20.000000000 +0530
|
||||
@@ -1,12 +1,12 @@
|
||||
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.36.
|
||||
-.TH GENGETOPT "1" "December 2006" "gengetopt 2.19rc" "User Commands"
|
||||
+.TH GENGETOPT "1" "January 2007" "gengetopt 2.19.1" "User Commands"
|
||||
.SH NAME
|
||||
-gengetopt \- manual page for gengetopt 2.19rc
|
||||
+gengetopt \- manual page for gengetopt 2.19.1
|
||||
.SH SYNOPSIS
|
||||
.B gengetopt
|
||||
[\fIOPTIONS\fR]...
|
||||
.SH DESCRIPTION
|
||||
-GNU gengetopt 2.19rc
|
||||
+GNU gengetopt 2.19.1
|
||||
.PP
|
||||
This program generates a C function that uses getopt_long function
|
||||
to parse the command line options, validate them and fill a struct.
|
96
gengetopt.spec
Normal file
96
gengetopt.spec
Normal file
@ -0,0 +1,96 @@
|
||||
Summary: Tool to write command line option parsing code for C programs
|
||||
Name: gengetopt
|
||||
Version: 2.19.1
|
||||
Release: 3%{dist}
|
||||
License: GPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/gengetopt/
|
||||
Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: %{name}-%{version}-from-debian.patch
|
||||
Patch1: %{name}-%{version}-man.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
BuildRequires: help2man
|
||||
BuildRequires: source-highlight
|
||||
BuildRequires: valgrind
|
||||
|
||||
%description
|
||||
Gengetopt is a tool to generate C code to parse the command line arguments
|
||||
argc and argv that are part of every C or C++ program. The generated code uses
|
||||
the C library function getopt_long to perform the actual command line parsing.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
# Disabling parallel make to prevent failure with -j2.
|
||||
make
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
|
||||
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
# Move /usr/share/doc/gengetopt/examples to RPM_BUILD_DIR.
|
||||
# To be later listed against %doc.
|
||||
mv $RPM_BUILD_ROOT%{_docdir}/%{name}/examples .
|
||||
rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
|
||||
|
||||
# README.example
|
||||
mv ./doc/README.example ./examples
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS ChangeLog COPYING LICENSE NEWS README THANKS TODO doc/gengetopt.html doc/index.html examples
|
||||
%{_bindir}/%{name}
|
||||
%{_infodir}/%{name}.info.gz
|
||||
%{_mandir}/man1/%{name}.1.gz
|
||||
|
||||
%dir %{_datadir}/%{name}
|
||||
%{_datadir}/%{name}/getopt.c
|
||||
%{_datadir}/%{name}/getopt1.c
|
||||
%{_datadir}/%{name}/gnugetopt.h
|
||||
|
||||
%changelog
|
||||
* Mon Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-3
|
||||
- Added 'BuildRequires: ...' for check stanza.
|
||||
- Added a check stanza.
|
||||
- Removed -devel package.
|
||||
|
||||
* Mon Jun 11 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-2
|
||||
- Used variables name and version in Source0.
|
||||
- Mentioned /sbin/install-info as a requirement for post and preun.
|
||||
- Used _datadir instead of defining sharedir.
|
||||
- Disabled parallel make to prevent failure with -j2.
|
||||
- Removing /usr/share/info/dir in the install stanza.
|
||||
- Replaced '$RPM_BUILD_DIR' with '.' in the install stanza.
|
||||
|
||||
* Sun Jun 10 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-1
|
||||
- Initial build.
|
||||
- Added README.example from Debian.
|
||||
- Changed version and date in online manual page to 2.19.1 from 2.19rc.
|
Loading…
Reference in New Issue
Block a user