Updated to 2.21-1 in devel.
Modified Files: .cvsignore gengetopt.spec sources Removed Files: gengetopt-2.19.1-from-debian.patch gengetopt-2.19.1-man.patch gengetopt-2.20-from-debian.patch
This commit is contained in:
parent
1393a55cb4
commit
8572303ea3
@ -1 +1 @@
|
||||
gengetopt-2.20.tar.gz
|
||||
gengetopt-2.21.tar.gz
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -urNp gengetopt-2.19.1.orig/doc/README.example gengetopt-2.19.1/doc/README.example
|
||||
--- gengetopt-2.19.1.orig/doc/README.example 1970-01-01 05:30:00.000000000 +0530
|
||||
+++ gengetopt-2.19.1/doc/README.example 2007-06-10 16:57:03.000000000 +0530
|
||||
@@ -0,0 +1,12 @@
|
||||
+#!/bin/sh -v
|
||||
+
|
||||
+# commands to try the C++ example:
|
||||
+
|
||||
+gengetopt -isample1.ggo -Fcmdline1 --long-help -u c++ -o main1 main1.cc cmdline1.c
|
||||
+./main1 --help
|
||||
+
|
||||
+# commands to try the C example:
|
||||
+
|
||||
+gengetopt --input=sample2.ggo --func-name=my_cmdline_parser --file-name=cmdline2 --unamed-opts
|
||||
+gcc -o main2 main2.c cmdline2.c
|
||||
+./main2 -h
|
@ -1,19 +0,0 @@
|
||||
diff -urNp gengetopt-2.19.1.orig/doc/gengetopt.1 gengetopt-2.19.1/doc/gengetopt.1
|
||||
--- gengetopt-2.19.1.orig/doc/gengetopt.1 2006-12-11 13:39:44.000000000 +0530
|
||||
+++ gengetopt-2.19.1/doc/gengetopt.1 2007-06-10 17:04:20.000000000 +0530
|
||||
@@ -1,12 +1,12 @@
|
||||
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.36.
|
||||
-.TH GENGETOPT "1" "December 2006" "gengetopt 2.19rc" "User Commands"
|
||||
+.TH GENGETOPT "1" "January 2007" "gengetopt 2.19.1" "User Commands"
|
||||
.SH NAME
|
||||
-gengetopt \- manual page for gengetopt 2.19rc
|
||||
+gengetopt \- manual page for gengetopt 2.19.1
|
||||
.SH SYNOPSIS
|
||||
.B gengetopt
|
||||
[\fIOPTIONS\fR]...
|
||||
.SH DESCRIPTION
|
||||
-GNU gengetopt 2.19rc
|
||||
+GNU gengetopt 2.19.1
|
||||
.PP
|
||||
This program generates a C function that uses getopt_long function
|
||||
to parse the command line options, validate them and fill a struct.
|
@ -1,16 +0,0 @@
|
||||
diff -urNp gengetopt-2.19.1.orig/doc/README.example gengetopt-2.19.1/doc/README.example
|
||||
--- gengetopt-2.19.1.orig/doc/README.example 1970-01-01 05:30:00.000000000 +0530
|
||||
+++ gengetopt-2.19.1/doc/README.example 2007-06-10 16:57:03.000000000 +0530
|
||||
@@ -0,0 +1,12 @@
|
||||
+#!/bin/sh -v
|
||||
+
|
||||
+# commands to try the C++ example:
|
||||
+
|
||||
+gengetopt -isample1.ggo -Fcmdline1 --long-help -u c++ -o main1 main1.cc cmdline1.c
|
||||
+./main1 --help
|
||||
+
|
||||
+# commands to try the C example:
|
||||
+
|
||||
+gengetopt --input=sample2.ggo --func-name=my_cmdline_parser --file-name=cmdline2 --unamed-opts
|
||||
+gcc -o main2 main2.c cmdline2.c
|
||||
+./main2 -h
|
@ -1,14 +1,12 @@
|
||||
Summary: Tool to write command line option parsing code for C programs
|
||||
Name: gengetopt
|
||||
Version: 2.20
|
||||
Version: 2.21
|
||||
Release: 1%{dist}
|
||||
License: GPL
|
||||
License: GPLv3+
|
||||
Group: Development/Tools
|
||||
URL: http://www.gnu.org/software/gengetopt/
|
||||
Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: %{name}-%{version}-from-debian.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
@ -25,13 +23,10 @@ the C library function getopt_long to perform the actual command line parsing.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
# Disabling parallel make to prevent failure with -j2.
|
||||
make
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%check
|
||||
make check
|
||||
@ -40,7 +35,7 @@ make check
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
# To retain timestamps on files installed without any modification.
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
|
||||
make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
@ -49,9 +44,6 @@ rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
mv $RPM_BUILD_ROOT%{_docdir}/%{name}/examples .
|
||||
rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
|
||||
|
||||
# README.example
|
||||
mv ./doc/README.example ./examples
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -60,7 +52,8 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info.gz \
|
||||
%{_infodir}/dir >/dev/null 2>&1 || :
|
||||
fi
|
||||
|
||||
%files
|
||||
@ -76,6 +69,12 @@ fi
|
||||
%{_datadir}/%{name}/gnugetopt.h
|
||||
|
||||
%changelog
|
||||
* Sat Aug 04 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.21-1
|
||||
- Version bump to 2.21. Closes Red Hat Bugzilla bug #250817.
|
||||
- License changed to GPLv3 or later.
|
||||
- Parallel build problems fixed by upstream.
|
||||
- README.example added by upstream.
|
||||
|
||||
* Mon Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.20-1
|
||||
- Version bump to 2.20.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user