Updated to 2.20-1 in devel.

Modified Files: gengetopt.spec Added Files:
    gengetopt-2.20-from-debian.patch
This commit is contained in:
Debarshi Ray 2007-07-06 21:54:38 +00:00
parent b441d24d5c
commit 28f3692099
2 changed files with 23 additions and 5 deletions

View File

@ -0,0 +1,16 @@
diff -urNp gengetopt-2.19.1.orig/doc/README.example gengetopt-2.19.1/doc/README.example
--- gengetopt-2.19.1.orig/doc/README.example 1970-01-01 05:30:00.000000000 +0530
+++ gengetopt-2.19.1/doc/README.example 2007-06-10 16:57:03.000000000 +0530
@@ -0,0 +1,12 @@
+#!/bin/sh -v
+
+# commands to try the C++ example:
+
+gengetopt -isample1.ggo -Fcmdline1 --long-help -u c++ -o main1 main1.cc cmdline1.c
+./main1 --help
+
+# commands to try the C example:
+
+gengetopt --input=sample2.ggo --func-name=my_cmdline_parser --file-name=cmdline2 --unamed-opts
+gcc -o main2 main2.c cmdline2.c
+./main2 -h

View File

@ -1,14 +1,13 @@
Summary: Tool to write command line option parsing code for C programs
Name: gengetopt
Version: 2.19.1
Release: 3%{dist}
Version: 2.20
Release: 1%{dist}
License: GPL
Group: Development/Tools
URL: http://www.gnu.org/software/gengetopt/
Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
Patch0: %{name}-%{version}-from-debian.patch
Patch1: %{name}-%{version}-man.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
@ -27,7 +26,6 @@ the C library function getopt_long to perform the actual command line parsing.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%build
%configure
@ -40,9 +38,10 @@ make check
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
# To retain timestamps on files installed without any modification.
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
# Move /usr/share/doc/gengetopt/examples to RPM_BUILD_DIR.
@ -77,6 +76,9 @@ fi
%{_datadir}/%{name}/gnugetopt.h
%changelog
* Mon Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.20-1
- Version bump to 2.20.
* Mon Jun 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 2.19.1-3
- Added 'BuildRequires: ...' for check stanza.
- Added a check stanza.