Update to 0.4.18

- Switch to meson build system
This commit is contained in:
Kalev Lember 2019-11-04 14:36:44 +01:00
parent 5f74a64699
commit f7fb9271e4
4 changed files with 74 additions and 12 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/gegl-0.4.12.tar.bz2
/gegl-0.4.14.tar.bz2
/gegl-0.4.16.tar.bz2
/gegl-0.4.18.tar.xz

View File

@ -0,0 +1,51 @@
From 6bcf95fd0f32cf5e8b1ddbe17b14d9ad049bded8 Mon Sep 17 00:00:00 2001
From: Christoph Reiter <reiter.christoph@gmail.com>
Date: Sun, 27 Oct 2019 14:10:08 +0100
Subject: [PATCH] meson: fix cpu detection
Use host_machine.cpu_family() instead of cpu(). Only the former
provides a stable/defined set of values.
Also don't error out on some arches for no good reason.
This fixes the build on 32bit Windows.
---
meson.build | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/meson.build b/meson.build
index af133a0f1..540498921 100644
--- a/meson.build
+++ b/meson.build
@@ -73,23 +73,21 @@ if os_osx and cc.get_id() != 'clang'
endif
-host_cpu = host_machine.cpu()
-if host_cpu.startswith('i') and host_cpu.endswith('86')
+host_cpu_family = host_machine.cpu_family()
+if host_cpu_family == 'x86'
have_x86 = true
config.set10('ARCH_X86', true)
-elif host_cpu == 'x86_64'
+elif host_cpu_family == 'x86_64'
have_x86 = true
config.set10('ARCH_X86', true)
config.set10('ARCH_X86_64', true)
-elif host_cpu == 'ppc' or host_cpu == 'powerpc'
+elif host_cpu_family == 'ppc'
have_ppc = true
config.set10('ARCH_PPC', true)
-elif host_cpu == 'ppc64' or host_cpu == 'powerpc64'
+elif host_cpu_family == 'ppc64'
have_ppc = true
config.set10('ARCH_PPC', true)
config.set10('ARCH_PPC64', true)
-else
- error('Unknown host architecture')
endif
################################################################################
--
2.23.0

View File

@ -1,29 +1,34 @@
%global apiver 0.4
Name: gegl04
Version: 0.4.16
Release: 4%{?dist}
Version: 0.4.18
Release: 1%{?dist}
Summary: Graph based image processing framework
# The binary is under the GPL, while the libs are under LGPL.
# The main package only installs the libs, which makes the license:
License: LGPLv3+
URL: http://www.gegl.org/
Source0: http://download.gimp.org/pub/gegl/%{apiver}/gegl-%{version}.tar.bz2
Source0: http://download.gimp.org/pub/gegl/%{apiver}/gegl-%{version}.tar.xz
# Backported from upstream
Patch01: 0001-meson-fix-cpu-detection.patch
BuildRequires: chrpath
BuildRequires: enscript
BuildRequires: gcc-c++
BuildRequires: gettext-devel >= 0.19.8
BuildRequires: gobject-introspection-devel >= 1.32.0
BuildRequires: gtk-doc
BuildRequires: libspiro-devel
BuildRequires: meson
BuildRequires: perl-interpreter
BuildRequires: ruby
BuildRequires: SDL-devel >= 1.2.0
BuildRequires: suitesparse-devel
BuildRequires: vala
BuildRequires: pkgconfig(babl) >= 0.1.58
BuildRequires: pkgconfig(babl) >= 0.1.72
BuildRequires: pkgconfig(cairo) >= 1.12.2
BuildRequires: pkgconfig(exiv2) >= 0.25
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.32.0
@ -106,25 +111,22 @@ GEGL library.
%prep
%setup -q -n gegl-%{version}
%autosetup -p1 -n gegl-%{version}
%build
%configure --disable-static
make %{?_smp_mflags}
%meson --auto-features=auto -Ddocs=true
%meson_build
%install
%make_install
%meson_install
# Remove rpaths
chrpath --delete %{buildroot}%{_bindir}/*
chrpath --delete %{buildroot}%{_libdir}/*.so*
chrpath --delete %{buildroot}%{_libdir}/gegl-%{apiver}/*.so
# Remove .la files
find %{buildroot} -name '*.la' -delete
%find_lang gegl-%{apiver}
@ -138,6 +140,10 @@ find %{buildroot} -name '*.la' -delete
%{_libdir}/libgegl-npd-%{apiver}.so
%{_libdir}/libgegl-sc-%{apiver}.so
%{_libdir}/girepository-1.0/Gegl-%{apiver}.typelib
%ifarch %{arm} %{ix86} x86_64
%dir %{_datadir}/gegl-%{apiver}/
%{_datadir}/gegl-%{apiver}/lua/
%endif
%files devel
%{_includedir}/gegl-%{apiver}/
@ -160,6 +166,10 @@ find %{buildroot} -name '*.la' -delete
%changelog
* Mon Nov 04 2019 Kalev Lember <klember@redhat.com> - 0.4.18-1
- Update to 0.4.18
- Switch to meson build system
* Thu Sep 12 2019 Josef Ridky <jridky@redhat.com> -0.4.16-4
- Obsoletes gegl03 (#1751416)

View File

@ -1 +1 @@
SHA512 (gegl-0.4.16.tar.bz2) = 38eacbd53d9993ca99d061bf6f80553a86ff06bf42d1710403ac5f15629ccc9b1f4395ee7700a04cebc954ed7fe8745c5bef85453c9c56d89681dd53a1552b27
SHA512 (gegl-0.4.18.tar.xz) = e79874cd50e9f0c27c7dc9d9b952545c31d0a48e2b158aa54b92c3e933267877222f86ede7256f2528f18985dc85d6eadbcd809f7a3563efc4449ec7634f15fd