Update to 0.4.22

This commit is contained in:
Josef Řídký 2020-02-19 10:55:47 +01:00
parent 79339ce575
commit c71553214d
4 changed files with 8 additions and 58 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/gegl-0.4.14.tar.bz2
/gegl-0.4.16.tar.bz2
/gegl-0.4.18.tar.xz
/gegl-0.4.22.tar.xz

View File

@ -1,51 +0,0 @@
From 6bcf95fd0f32cf5e8b1ddbe17b14d9ad049bded8 Mon Sep 17 00:00:00 2001
From: Christoph Reiter <reiter.christoph@gmail.com>
Date: Sun, 27 Oct 2019 14:10:08 +0100
Subject: [PATCH] meson: fix cpu detection
Use host_machine.cpu_family() instead of cpu(). Only the former
provides a stable/defined set of values.
Also don't error out on some arches for no good reason.
This fixes the build on 32bit Windows.
---
meson.build | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/meson.build b/meson.build
index af133a0f1..540498921 100644
--- a/meson.build
+++ b/meson.build
@@ -73,23 +73,21 @@ if os_osx and cc.get_id() != 'clang'
endif
-host_cpu = host_machine.cpu()
-if host_cpu.startswith('i') and host_cpu.endswith('86')
+host_cpu_family = host_machine.cpu_family()
+if host_cpu_family == 'x86'
have_x86 = true
config.set10('ARCH_X86', true)
-elif host_cpu == 'x86_64'
+elif host_cpu_family == 'x86_64'
have_x86 = true
config.set10('ARCH_X86', true)
config.set10('ARCH_X86_64', true)
-elif host_cpu == 'ppc' or host_cpu == 'powerpc'
+elif host_cpu_family == 'ppc'
have_ppc = true
config.set10('ARCH_PPC', true)
-elif host_cpu == 'ppc64' or host_cpu == 'powerpc64'
+elif host_cpu_family == 'ppc64'
have_ppc = true
config.set10('ARCH_PPC', true)
config.set10('ARCH_PPC64', true)
-else
- error('Unknown host architecture')
endif
################################################################################
--
2.23.0

View File

@ -1,8 +1,8 @@
%global apiver 0.4
Name: gegl04
Version: 0.4.18
Release: 2%{?dist}
Version: 0.4.22
Release: 1%{?dist}
Summary: Graph based image processing framework
# The binary is under the GPL, while the libs are under LGPL.
@ -11,9 +11,6 @@ License: LGPLv3+
URL: http://www.gegl.org/
Source0: http://download.gimp.org/pub/gegl/%{apiver}/gegl-%{version}.tar.xz
# Backported from upstream
Patch01: 0001-meson-fix-cpu-detection.patch
BuildRequires: chrpath
BuildRequires: enscript
BuildRequires: gcc-c++
@ -27,7 +24,7 @@ BuildRequires: ruby
BuildRequires: suitesparse-devel
BuildRequires: vala
BuildRequires: pkgconfig(babl) >= 0.1.72
BuildRequires: pkgconfig(babl) >= 0.1.74
BuildRequires: pkgconfig(cairo) >= 1.12.2
BuildRequires: pkgconfig(exiv2) >= 0.25
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.32.0
@ -167,6 +164,9 @@ chrpath --delete %{buildroot}%{_libdir}/gegl-%{apiver}/*.so
%changelog
* Wed Feb 19 2020 Josef Ridky <jridky@redhat.com> - 0.4.22-1
- Update to 0.4.22
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gegl-0.4.18.tar.xz) = e79874cd50e9f0c27c7dc9d9b952545c31d0a48e2b158aa54b92c3e933267877222f86ede7256f2528f18985dc85d6eadbcd809f7a3563efc4449ec7634f15fd
SHA512 (gegl-0.4.22.tar.xz) = 3118fb17532bcd5893a77739eaf936f5d1e2020178abc497098d227c25f726679621503ac83e7d14a9883d259247d97b92016174e76a2e6e950be7e26ce251ab