gdl/gdl-0.9-antlr-cmake.patch
2013-02-25 16:58:20 -07:00

23 lines
888 B
Diff

diff -up gdl-0.9.3/src/CMakeLists.txt.antlr gdl-0.9.3/src/CMakeLists.txt
--- gdl-0.9.3/src/CMakeLists.txt.antlr 2012-12-27 09:22:44.000000000 -0700
+++ gdl-0.9.3/src/CMakeLists.txt 2013-02-25 16:57:37.808871375 -0700
@@ -237,9 +237,7 @@ gtdhelper.hpp
)
endif(WIN32 AND NOT CYGWIN)
-add_subdirectory(antlr)
-
-include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src/antlr ${CMAKE_BINARY_DIR})
+include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_BINARY_DIR})
link_directories(${LINK_DIRECTORIES})
if(PYTHON_MODULE) #libgdl
@@ -250,7 +248,6 @@ else(PYTHON_MODULE) #gdl
add_executable(gdl ${SOURCES})
endif(PYTHON_MODULE)
-add_dependencies(gdl antlr) # be sure that antlr is built before gdl
target_link_libraries(gdl antlr) # link antlr against gdl
target_link_libraries(gdl ${LIBRARIES})
add_definitions(-DHAVE_CONFIG_H)