4be62182e6
Drop EL7 support due to plplot 5.11 requirement
23 lines
880 B
Diff
23 lines
880 B
Diff
diff -up gdl-1.0.0/src/CMakeLists.txt.antlr gdl-1.0.0/src/CMakeLists.txt
|
|
--- gdl-1.0.0/src/CMakeLists.txt.antlr 2021-08-19 20:04:43.096095029 -0600
|
|
+++ gdl-1.0.0/src/CMakeLists.txt 2021-08-19 20:05:26.844467193 -0600
|
|
@@ -193,9 +193,7 @@ ${WX_RC}
|
|
)
|
|
endif(HAVE_LIBWXWIDGETS AND WIN32)
|
|
|
|
-add_subdirectory(antlr)
|
|
-
|
|
-include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src/antlr ${CMAKE_BINARY_DIR})
|
|
+include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_BINARY_DIR})
|
|
link_directories(${LINK_DIRECTORIES})
|
|
|
|
if(PYTHON_MODULE) #GDL.so
|
|
@@ -213,7 +211,6 @@ if(USE_OPENMP)
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
|
|
endif(USE_OPENMP)
|
|
|
|
-add_dependencies(gdl antlr) # be sure that antlr is built before gdl
|
|
target_link_libraries(gdl antlr) # link antlr against gdl
|
|
if (MINGW)
|
|
target_link_libraries(gdl ws2_32)
|