gdl/gdl-antlr.patch
2017-02-01 10:05:47 -07:00

23 lines
891 B
Diff

diff -up gdl-0.9.7rc1-20161104/src/CMakeLists.txt.antlr gdl-0.9.7rc1-20161104/src/CMakeLists.txt
--- gdl-0.9.7rc1-20161104/src/CMakeLists.txt.antlr 2016-10-19 15:14:13.000000000 -0600
+++ gdl-0.9.7rc1-20161104/src/CMakeLists.txt 2016-11-04 16:03:32.618417108 -0600
@@ -266,9 +266,7 @@ widget.cpp
widget.hpp
)
-add_subdirectory(antlr)
-
-include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src/antlr ${CMAKE_BINARY_DIR})
+include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/src ${CMAKE_BINARY_DIR})
link_directories(${LINK_DIRECTORIES})
if(PYTHON_MODULE) #GDL.so
@@ -282,7 +280,6 @@ else(PYTHON_MODULE) #GDL.so
add_executable(gdl ${SOURCES})
endif(PYTHON_MODULE)
-add_dependencies(gdl antlr) # be sure that antlr is built before gdl
target_link_libraries(gdl antlr) # link antlr against gdl
if (MINGW)
target_link_libraries(gdl ws2_32)