Update to latest git
This commit is contained in:
parent
4d1679fa0d
commit
e56e9b4751
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ gdl-0.9rc4.tar.gz
|
||||
/gdl-0.9.8-git-f3b6e01.tar.gz
|
||||
/gdl-0.9.8-git-d892ee5.tar.gz
|
||||
/gdl-0.9.9.tar.gz
|
||||
/gdl-0.9.9-git-2870075.tar.gz
|
||||
|
@ -1,112 +0,0 @@
|
||||
diff --git a/src/gdlc.i.g b/src/gdlc.i.g
|
||||
index e66902d..1c648c8 100644
|
||||
--- a/src/gdlc.i.g
|
||||
+++ b/src/gdlc.i.g
|
||||
@@ -170,7 +170,7 @@ public:
|
||||
static bool SearchCompilePro(const std::string& pro, bool searchForPro);
|
||||
static int GetFunIx( ProgNodeP);
|
||||
static int GetFunIx( const std::string& subName);
|
||||
- static int GetProIx( ProgNodeP);//const std::string& subName);
|
||||
+ static int GetProIx( ProgNodeP, bool throwImmediately=false);//const std::string& subName);
|
||||
static int GetProIx( const std::string& subName);
|
||||
DStructGDL* ObjectStruct( DObjGDL* self, ProgNodeP mp);
|
||||
void SetRootR( ProgNodeP tt, DotAccessDescT* aD, BaseGDL* r, ArrayIndexListT* aL);
|
||||
@@ -184,7 +184,7 @@ public:
|
||||
|
||||
private:
|
||||
|
||||
- static void SetProIx( ProgNodeP f); // triggers read/compile
|
||||
+ static void SetProIx( ProgNodeP f, bool throwImmediately=false); // triggers read/compile
|
||||
static void AdjustTypes( BaseGDL*&, BaseGDL*&);
|
||||
|
||||
|
||||
@@ -979,18 +979,6 @@ interactive returns[ RetCode retCode]
|
||||
)+
|
||||
;
|
||||
|
||||
-// execute statement
|
||||
-execute returns[ RetCode retCode]
|
||||
-{
|
||||
-// RetCode retCode;
|
||||
- ValueGuard<bool> guard( interruptEnable);
|
||||
- interruptEnable = false;
|
||||
-
|
||||
- return statement_list(_t);
|
||||
-}
|
||||
- : retCode=statement_list
|
||||
- ;
|
||||
-
|
||||
// used to call functions
|
||||
// same as statement list, but different behaviour for returncodes
|
||||
call_fun returns[ BaseGDL* res]
|
||||
@@ -1083,24 +1071,7 @@ call_pro
|
||||
;
|
||||
|
||||
|
||||
-// used on many occasions
|
||||
-statement_list returns[ RetCode retCode]
|
||||
-{
|
||||
- for (; _t != NULL;) {
|
||||
-
|
||||
- retCode=statement(_t);
|
||||
- _t = _retTree;
|
||||
-
|
||||
- if( retCode != RC_OK) break; // break out if non-regular
|
||||
- }
|
||||
- _retTree = _t;
|
||||
- return retCode;
|
||||
-}
|
||||
- : (retCode=statement
|
||||
- )+
|
||||
- ;
|
||||
-
|
||||
-statement returns[ RetCode retCode]
|
||||
+statement [bool throwImmediately=false] returns[ RetCode retCode]
|
||||
{
|
||||
// ProgNodeP& actPos = statement_AST_in;
|
||||
assert( _t != NULL);
|
||||
@@ -1121,7 +1092,7 @@ statement returns[ RetCode retCode]
|
||||
// track actual line number
|
||||
callStack.back()->SetLineNumber( last->getLine());
|
||||
|
||||
- retCode = last->Run(); // Run() sets _retTree
|
||||
+ retCode = last->Run(throwImmediately); // Run() sets _retTree
|
||||
|
||||
}
|
||||
while(
|
||||
@@ -1456,6 +1427,35 @@ statement returns[ RetCode retCode]
|
||||
} // catch [ GDLException& e]
|
||||
|
||||
|
||||
+// used on many occasions
|
||||
+statement_list [bool throwImmediately=false] returns[ RetCode retCode]
|
||||
+{
|
||||
+ for (; _t != NULL;) {
|
||||
+
|
||||
+ retCode=statement(_t, throwImmediately);
|
||||
+ _t = _retTree;
|
||||
+
|
||||
+ if( retCode != RC_OK) break; // break out if non-regular
|
||||
+ }
|
||||
+ _retTree = _t;
|
||||
+ return retCode;
|
||||
+}
|
||||
+ : (retCode=statement[throwImmediately]
|
||||
+ )+
|
||||
+ ;
|
||||
+
|
||||
+// execute statement
|
||||
+execute [bool throwImmediately=false] returns[ RetCode retCode]
|
||||
+{
|
||||
+// RetCode retCode;
|
||||
+ ValueGuard<bool> guard( interruptEnable);
|
||||
+ interruptEnable = false;
|
||||
+
|
||||
+// return statement_list(_t, throwImmediately);
|
||||
+}
|
||||
+ : retCode=statement_list[throwImmediately]
|
||||
+ ;
|
||||
+
|
||||
|
||||
|
||||
|
@ -1,9 +1,9 @@
|
||||
diff -up gdl-0.9.7rc1-20161104/src/CMakeLists.txt.antlr gdl-0.9.7rc1-20161104/src/CMakeLists.txt
|
||||
--- gdl-0.9.7rc1-20161104/src/CMakeLists.txt.antlr 2016-10-19 15:14:13.000000000 -0600
|
||||
+++ gdl-0.9.7rc1-20161104/src/CMakeLists.txt 2016-11-04 16:03:32.618417108 -0600
|
||||
@@ -266,9 +266,7 @@ widget.cpp
|
||||
widget.hpp
|
||||
diff -up gdl-287007567ba3998b4b70119025c3def86bdef649/src/CMakeLists.txt.antlr gdl-287007567ba3998b4b70119025c3def86bdef649/src/CMakeLists.txt
|
||||
--- gdl-287007567ba3998b4b70119025c3def86bdef649/src/CMakeLists.txt.antlr 2019-09-16 03:51:53.000000000 -0600
|
||||
+++ gdl-287007567ba3998b4b70119025c3def86bdef649/src/CMakeLists.txt 2019-09-16 21:13:52.240535555 -0600
|
||||
@@ -291,9 +291,7 @@ sax.cpp
|
||||
)
|
||||
endif(USE_EXPAT)
|
||||
|
||||
-add_subdirectory(antlr)
|
||||
-
|
||||
@ -12,7 +12,7 @@ diff -up gdl-0.9.7rc1-20161104/src/CMakeLists.txt.antlr gdl-0.9.7rc1-20161104/sr
|
||||
link_directories(${LINK_DIRECTORIES})
|
||||
|
||||
if(PYTHON_MODULE) #GDL.so
|
||||
@@ -282,7 +280,6 @@ else(PYTHON_MODULE) #GDL.so
|
||||
@@ -308,7 +306,6 @@ else(PYTHON_MODULE) #GDL.so
|
||||
add_executable(gdl ${SOURCES})
|
||||
endif(PYTHON_MODULE)
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up gdl-0.9.9/src/dSFMT/dSFMT-common.h.std gdl-0.9.9/src/dSFMT/dSFMT-common.h
|
||||
--- gdl-0.9.9/src/dSFMT/dSFMT-common.h.std 2018-12-01 07:19:52.000000000 -0700
|
||||
+++ gdl-0.9.9/src/dSFMT/dSFMT-common.h 2019-02-12 21:32:20.568719598 -0700
|
||||
diff -up gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT-common.h.std gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT-common.h
|
||||
--- gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT-common.h.std 2019-09-16 03:51:53.000000000 -0600
|
||||
+++ gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT-common.h 2019-09-16 21:15:07.887885236 -0600
|
||||
@@ -44,25 +44,25 @@ static const union X128I_T sse2_param_ma
|
||||
#if defined(HAVE_ALTIVEC)
|
||||
inline static void do_recursion(w128_t *r, w128_t *a, w128_t * b,
|
||||
@ -39,9 +39,9 @@ diff -up gdl-0.9.9/src/dSFMT/dSFMT-common.h.std gdl-0.9.9/src/dSFMT/dSFMT-common
|
||||
x = vec_srl(x, sr1);
|
||||
x = vec_and(x, sr1_msk);
|
||||
y = vec_and(w, msk1);
|
||||
diff -up gdl-0.9.9/src/dSFMT/dSFMT.h.std gdl-0.9.9/src/dSFMT/dSFMT.h
|
||||
--- gdl-0.9.9/src/dSFMT/dSFMT.h.std 2018-12-01 07:19:52.000000000 -0700
|
||||
+++ gdl-0.9.9/src/dSFMT/dSFMT.h 2019-02-12 21:31:11.001860961 -0700
|
||||
diff -up gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT.h.std gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT.h
|
||||
--- gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT.h.std 2019-09-16 03:51:53.000000000 -0600
|
||||
+++ gdl-287007567ba3998b4b70119025c3def86bdef649/src/dSFMT/dSFMT.h 2019-09-16 21:15:07.887885236 -0600
|
||||
@@ -143,7 +143,7 @@ extern "C" {
|
||||
|
||||
/** 128-bit data structure */
|
||||
@ -51,14 +51,3 @@ diff -up gdl-0.9.9/src/dSFMT/dSFMT.h.std gdl-0.9.9/src/dSFMT/dSFMT.h
|
||||
uint64_t u[2];
|
||||
uint32_t u32[4];
|
||||
double d[2];
|
||||
diff -up gdl-0.9.9/src/randomgenerators.cpp.std gdl-0.9.9/src/randomgenerators.cpp
|
||||
--- gdl-0.9.9/src/randomgenerators.cpp.std 2018-12-01 07:19:52.000000000 -0700
|
||||
+++ gdl-0.9.9/src/randomgenerators.cpp 2019-02-12 21:31:11.002860973 -0700
|
||||
@@ -35,7 +35,6 @@
|
||||
|
||||
namespace lib {
|
||||
|
||||
- using namespace std;
|
||||
#ifdef USE_EIGEN
|
||||
/* following are some modified codes taken from the GNU Scientific Library.
|
||||
*
|
||||
|
18
gdl.spec
18
gdl.spec
@ -1,15 +1,15 @@
|
||||
%global commit d892ee54b710c645ec0bc75d4a0cb3118813daa6
|
||||
%global commit 287007567ba3998b4b70119025c3def86bdef649
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
|
||||
Name: gdl
|
||||
Version: 0.9.9
|
||||
Release: 10%{?dist}
|
||||
Release: 11.20190915git%{shortcommit}%{?dist}
|
||||
Summary: GNU Data Language
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://gnudatalanguage.sourceforge.net/
|
||||
Source0: https://github.com/gnudatalanguage/gdl/archive/v%{version}/gdl-%{version}.tar.gz
|
||||
#Source0: https://github.com/gnudatalanguage/gdl/archive/%{commit}/gdl-%{version}-git-%{shortcommit}.tar.gz
|
||||
#Source0: https://github.com/gnudatalanguage/gdl/archive/v%{version}/gdl-%{version}.tar.gz
|
||||
Source0: https://github.com/gnudatalanguage/gdl/archive/%{commit}/gdl-%{version}-git-%{shortcommit}.tar.gz
|
||||
Source1: gdl.csh
|
||||
Source2: gdl.sh
|
||||
Source4: xorg.conf
|
||||
@ -19,9 +19,6 @@ Patch1: gdl-antlr.patch
|
||||
# Support python3
|
||||
# https://github.com/gnudatalanguage/gdl/pull/468
|
||||
Patch2: gdl-python3.patch
|
||||
# Update ANTLR .g file to match upstream changes
|
||||
# https://github.com/gnudatalanguage/gdl/pull/529
|
||||
Patch3: gdl-antlr-grammar.patch
|
||||
# Fix conflict with std::vector and ALTIVEC vector
|
||||
# https://github.com/gnudatalanguage/gdl/pull/535
|
||||
Patch4: gdl-std.patch
|
||||
@ -50,6 +47,7 @@ BuildRequires: python%{python3_pkgversion}-devel, python%{python3_pkgversion}-n
|
||||
%else
|
||||
BuildRequires: python2-devel, python2-numpy, python2-matplotlib
|
||||
%endif
|
||||
BuildRequires: shapelib-devel
|
||||
BuildRequires: fftw-devel, hdf-static
|
||||
%if 0%{?fedora}
|
||||
# eccodes not available on these arches
|
||||
@ -141,11 +139,10 @@ Provides: %{name}-runtime = %{version}-%{release}
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{name}-%{commit}
|
||||
rm -rf src/antlr
|
||||
%patch1 -p1 -b .antlr
|
||||
%patch2 -p1 -b .python3
|
||||
%patch3 -p1 -b .antlr-grammar
|
||||
%patch4 -p1 -b .std
|
||||
|
||||
pushd src
|
||||
@ -305,6 +302,9 @@ cat xorg.log
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 17 2019 Orion Poplawski <orion@nwra.com> - 0.9.9-11.20190915git2870075
|
||||
- Update to latest git
|
||||
|
||||
* Tue Aug 20 2019 Susi Lehtola <jussilehtola@fedoraproject.org> - 0.9.9-10
|
||||
- Rebuilt for GSL 2.6.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gdl-0.9.9.tar.gz) = 41709c4951bbf71f7494eb339b6760756301b89b591020cb5a30c47d3b6f6228671a7d75b817e77f3ff6f1380505d27949e2900eb2577167de995f4941f288ee
|
||||
SHA512 (gdl-0.9.9-git-2870075.tar.gz) = f23519a1981d9d8b876220cc2d2d4568edada963242d8a6c94f543f83e35af1b36dadf75ddbae772b62bc0d8714fcdb144e562777867091702aaff8dd476d1d5
|
||||
|
Loading…
Reference in New Issue
Block a user