- Don't build included copy of antlr, use system version
This commit is contained in:
parent
5de4b0f5d2
commit
d065280dde
65
gdl-0.9rc2-20090224-antlr.patch
Normal file
65
gdl-0.9rc2-20090224-antlr.patch
Normal file
@ -0,0 +1,65 @@
|
||||
--- gdl-0.9rc2-20090224/configure.antlr 2009-02-24 09:46:08.000000000 -0700
|
||||
+++ gdl-0.9rc2-20090224/configure 2009-02-24 09:47:32.000000000 -0700
|
||||
@@ -22313,7 +22313,7 @@
|
||||
|
||||
|
||||
|
||||
-ac_config_files="$ac_config_files Makefile src/Makefile src/antlr/Makefile"
|
||||
+ac_config_files="$ac_config_files Makefile src/Makefile"
|
||||
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
@@ -22950,7 +22950,6 @@
|
||||
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
|
||||
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
|
||||
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
|
||||
- "src/antlr/Makefile") CONFIG_FILES="$CONFIG_FILES src/antlr/Makefile" ;;
|
||||
|
||||
*) { { $as_echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
|
||||
$as_echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
|
||||
--- gdl-0.9rc2-20090224/src/Makefile.in.antlr 2009-02-23 11:24:00.000000000 -0700
|
||||
+++ gdl-0.9rc2-20090224/src/Makefile.in 2009-02-24 09:53:18.000000000 -0700
|
||||
@@ -55,7 +55,7 @@
|
||||
libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
@BUILDASLIBRARY_TRUE@libgdl_la_DEPENDENCIES = \
|
||||
-@BUILDASLIBRARY_TRUE@ $(top_builddir)/src/antlr/libantlr.la
|
||||
+@BUILDASLIBRARY_TRUE@ -lantlr
|
||||
am__libgdl_la_SOURCES_DIST = accessdesc.hpp arrayindex.hpp \
|
||||
assocdata.cpp assocdata.hpp basegdl.hpp basic_fun_cl.cpp \
|
||||
basic_fun_cl.hpp basic_fun.cpp basic_fun.hpp basic_fun_jmg.cpp \
|
||||
@@ -233,7 +233,7 @@
|
||||
@BUILDASLIBRARY_FALSE@ gdl-gdl.$(OBJEXT)
|
||||
gdl_OBJECTS = $(am_gdl_OBJECTS)
|
||||
@BUILDASLIBRARY_FALSE@gdl_DEPENDENCIES = \
|
||||
-@BUILDASLIBRARY_FALSE@ $(top_builddir)/src/antlr/libantlr.a
|
||||
+@BUILDASLIBRARY_FALSE@ -lantlr
|
||||
gdl_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
||||
--mode=link $(CXXLD) $(gdl_CXXFLAGS) $(CXXFLAGS) \
|
||||
$(gdl_LDFLAGS) $(LDFLAGS) -o $@
|
||||
@@ -391,7 +391,6 @@
|
||||
|
||||
# set the include path found by configure
|
||||
INCLUDES = $(EXT_INCLUDES) $(all_includes)
|
||||
-SUBDIRS = antlr
|
||||
noinst_HEADERS = gdlwidget.hpp prognode.hpp prognodeexpr.hpp
|
||||
cpp_hpp_files = accessdesc.hpp arrayindex.hpp assocdata.cpp assocdata.hpp \
|
||||
basegdl.hpp basic_fun_cl.cpp basic_fun_cl.hpp basic_fun.cpp basic_fun.hpp \
|
||||
@@ -438,7 +437,7 @@
|
||||
@BUILDASLIBRARY_FALSE@gdl_CXXFLAGS = $(AM_CXXFLAGS)
|
||||
# the library search path.
|
||||
@BUILDASLIBRARY_FALSE@gdl_LDFLAGS = $(all_libraries)
|
||||
-@BUILDASLIBRARY_FALSE@gdl_LDADD = $(top_builddir)/src/antlr/libantlr.a -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
|
||||
+@BUILDASLIBRARY_FALSE@gdl_LDADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
|
||||
|
||||
# build as library (for python module)
|
||||
@BUILDASLIBRARY_TRUE@lib_LTLIBRARIES = libgdl.la
|
||||
@@ -448,7 +447,7 @@
|
||||
# netCDF and HDF define some same symbols
|
||||
# hence -z muldefs has to be passed to the linker
|
||||
@BUILDASLIBRARY_TRUE@@DARWIN_TRUE@libgdl_la_LDFLAGS = $(all_libraries) -Wl,-m
|
||||
-@BUILDASLIBRARY_TRUE@libgdl_la_LIBADD = $(top_builddir)/src/antlr/libantlr.la -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
|
||||
+@BUILDASLIBRARY_TRUE@libgdl_la_LIBADD = -lantlr -L/usr/X11R6/lib64 -L/usr/X11R6/lib -lX11
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
5
gdl.spec
5
gdl.spec
@ -14,8 +14,10 @@ Source1: gdl.csh
|
||||
Source2: gdl.sh
|
||||
Patch1: gdl-0.9pre5-ppc64.patch
|
||||
Patch2: gdl-0.9rc1-gcc43.patch
|
||||
Patch3: gdl-0.9rc2-20090224-antlr.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: antlr
|
||||
BuildRequires: readline-devel, ncurses-devel
|
||||
BuildRequires: gsl-devel, plplot-devel, ImageMagick-c++-devel
|
||||
BuildRequires: netcdf-devel, hdf5-devel, libjpeg-devel
|
||||
@ -35,6 +37,8 @@ Systems Inc.
|
||||
%setup -q -n %{name}-%{version}rc2-20090224
|
||||
%patch1 -p1 -b .ppc64
|
||||
%patch2 -p1 -b .gcc43
|
||||
%patch3 -p1 -b .antlr
|
||||
rm -rf src/antlr
|
||||
|
||||
|
||||
%build
|
||||
@ -77,6 +81,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Update to 0.9rc2 cvs 20090224
|
||||
- Fix release tag
|
||||
- Drop ImageMagick patch fixed upstream
|
||||
- Don't build included copy of antlr, use system version
|
||||
|
||||
* Fri Jan 23 2009 - Orion Poplawski <orion@cora.nwra.com> - 0.9-0.rc2.1
|
||||
- Update to 0.9rc2 based cvs
|
||||
|
Loading…
Reference in New Issue
Block a user