Add patch to build with gcc 6
This commit is contained in:
parent
55c43b53d8
commit
a5ec0c8dfb
31
gdl-gcc6.patch
Normal file
31
gdl-gcc6.patch
Normal file
@ -0,0 +1,31 @@
|
||||
diff -up gdl-0.9.6/src/specializations.hpp.gcc6 gdl-0.9.6/src/specializations.hpp
|
||||
--- gdl-0.9.6/src/specializations.hpp.gcc6 2015-08-24 15:26:47.000000000 -0600
|
||||
+++ gdl-0.9.6/src/specializations.hpp 2016-03-03 16:30:46.694379312 -0700
|
||||
@@ -534,16 +534,6 @@ void Data_<SpDString>::MinMax( DLong* mi
|
||||
|
||||
// default_io.cpp
|
||||
template<>
|
||||
-std::istream& operator>>(std::istream& i, Data_<SpDFloat>& data_);
|
||||
-template<>
|
||||
-std::istream& operator>>(std::istream& i, Data_<SpDDouble>& data_);
|
||||
-template<>
|
||||
-std::istream& operator>>(std::istream& i, Data_<SpDComplex>& data_);
|
||||
-template<>
|
||||
-std::istream& operator>>(std::istream& i, Data_<SpDComplexDbl>& data_);
|
||||
-template<>
|
||||
-std::istream& operator>>(std::istream& is, Data_<SpDString>& data_);
|
||||
-template<>
|
||||
std::ostream& Data_<SpDLong>::ToStream(std::ostream& o, SizeT w, SizeT* actPosPtr);
|
||||
template<>
|
||||
std::ostream& Data_<SpDULong>::ToStream(std::ostream& o, SizeT w, SizeT* actPosPtr);
|
||||
--- gdl-0.9.6/src/typedefs.hpp.gcc6 2014/08/09 15:33:29 1.76
|
||||
+++ gdl-0.9.6/src/typedefs.hpp 2016/02/04 22:48:46 1.77
|
||||
@@ -235,7 +235,7 @@
|
||||
|
||||
Guard& operator=( Guard& r)
|
||||
{
|
||||
- if( &r == this) return;
|
||||
+ if( &r == this) return *this;
|
||||
delete guarded;
|
||||
guarded = r.guarded;
|
||||
r.guarded = NULL;
|
10
gdl.spec
10
gdl.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: gdl
|
||||
Version: 0.9.6
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: GNU Data Language
|
||||
|
||||
Group: Applications/Engineering
|
||||
@ -21,6 +21,10 @@ Patch2: gdl-file_move.patch
|
||||
# Fix test_formats
|
||||
# https://sourceforge.net/p/gnudatalanguage/bugs/684/
|
||||
Patch3: gdl-formats.patch
|
||||
# Fix build with gcc 6
|
||||
# https://sourceforge.net/p/gnudatalanguage/bugs/686/
|
||||
# https://sourceforge.net/p/gnudatalanguage/bugs/688/
|
||||
Patch4: gdl-gcc6.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -104,6 +108,7 @@ rm -rf src/antlr
|
||||
%patch1 -p1 -b .antlr
|
||||
%patch2 -p1 -b .file_move
|
||||
%patch3 -p1 -b .formats
|
||||
%patch4 -p1 -b .gcc6
|
||||
|
||||
pushd src
|
||||
for f in *.g
|
||||
@ -201,6 +206,9 @@ xvfb-run ./xrun.sh
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 3 2016 Orion Poplawski <orion@cora.nwra.com> - 0.9.6-5
|
||||
- Add patch to build with gcc 6
|
||||
|
||||
* Mon Feb 22 2016 Orion Poplawski <orion@cora.nwra.com> - 0.9.6-4
|
||||
- Rebuild for gsl 2.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user