Get the friend patch right
This commit is contained in:
parent
d065280dde
commit
706295c1d6
11
gdl-0.9rc2-20090224-friend.patch
Normal file
11
gdl-0.9rc2-20090224-friend.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gdl-0.9rc2-20090224/src/envt.hpp.friend 2008-06-10 14:43:43.000000000 -0600
|
||||
+++ gdl-0.9rc2-20090224/src/envt.hpp 2009-02-25 11:38:48.000000000 -0700
|
||||
@@ -162,6 +162,8 @@
|
||||
if( ix >= env.size()) return false;
|
||||
return ( env.Env( ix) != NULL);
|
||||
}
|
||||
+
|
||||
+ friend class DInterpreter;
|
||||
};
|
||||
|
||||
// for UD subroutines (written in GDL) ********************************
|
5
gdl.spec
5
gdl.spec
@ -15,6 +15,9 @@ Source2: gdl.sh
|
||||
Patch1: gdl-0.9pre5-ppc64.patch
|
||||
Patch2: gdl-0.9rc1-gcc43.patch
|
||||
Patch3: gdl-0.9rc2-20090224-antlr.patch
|
||||
# gcc 4.4.0 catches more class issues - add needed friend
|
||||
# https://sourceforge.net/tracker/index.php?func=detail&aid=2634356&group_id=97659&atid=618683
|
||||
Patch4: gdl-0.9rc2-20090224-friend.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: antlr
|
||||
@ -38,6 +41,7 @@ Systems Inc.
|
||||
%patch1 -p1 -b .ppc64
|
||||
%patch2 -p1 -b .gcc43
|
||||
%patch3 -p1 -b .antlr
|
||||
%patch4 -p1 -b .friend
|
||||
rm -rf src/antlr
|
||||
|
||||
|
||||
@ -81,6 +85,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Update to 0.9rc2 cvs 20090224
|
||||
- Fix release tag
|
||||
- Drop ImageMagick patch fixed upstream
|
||||
- Add patch to compile with gcc 4.4.0 - needs new friend statement
|
||||
- Don't build included copy of antlr, use system version
|
||||
|
||||
* Fri Jan 23 2009 - Orion Poplawski <orion@cora.nwra.com> - 0.9-0.rc2.1
|
||||
|
Loading…
Reference in New Issue
Block a user