Add patch for specialization error caught by gcc 4.1.1
This commit is contained in:
parent
572c0441de
commit
4aa7c7185f
15
gdl-0.9pre2-specialization.patch
Normal file
15
gdl-0.9pre2-specialization.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- gdl-0.9pre2/src/specializations.hpp.orig 2006-06-12 23:24:09.000000000 -0600
|
||||
+++ gdl-0.9pre2/src/specializations.hpp 2006-09-19 10:23:58.000000000 -0600
|
||||
@@ -237,6 +237,12 @@
|
||||
Data_<SpDByte>* Data_<SpDComplexDbl>::LogNeg();
|
||||
|
||||
// datatypes.cpp
|
||||
+template<>
|
||||
+Data_<SpDString>::Data_(const dimension& dim_, BaseGDL::InitType iT);
|
||||
+template<>
|
||||
+Data_<SpDPtr>::Data_(const dimension& dim_, BaseGDL::InitType iT);
|
||||
+template<>
|
||||
+Data_<SpDObj>::Data_(const dimension& dim_, BaseGDL::InitType iT);
|
||||
template<> SizeT Data_<SpDString>::NBytes() const;
|
||||
// template<> SizeT Data_<SpDObj>::NBytes() const;
|
||||
// template<> SizeT Data_<SpDPtr>::NBytes() const;
|
3
gdl.spec
3
gdl.spec
@ -7,6 +7,7 @@ Group: Applications/Engineering
|
||||
License: GPL
|
||||
URL: http://gnudatalanguage.sourceforge.net/
|
||||
Source0: http://dl.sf.net/gnudata/%{name}-%{version}pre2.tar.gz
|
||||
Patch0: gdl-0.9pre2-specialization.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: readline-devel, ncurses-devel
|
||||
@ -24,6 +25,7 @@ Systems Inc.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}pre2
|
||||
%patch -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -51,6 +53,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%changelog
|
||||
* Mon Sep 19 2006 - Orion Poplawski <orion@cora.nwra.com> - 0.9-0.pre3
|
||||
- Rebuild for FC6
|
||||
- Add patch for specialization error caught by gcc 4.1.1
|
||||
|
||||
* Thu Jun 29 2006 - Orion Poplawski <orion@cora.nwra.com> - 0.9-0.pre2
|
||||
- Update to 0.9pre2
|
||||
|
Loading…
Reference in New Issue
Block a user