Update to 0.9.4

- Update build patch - drop automake components
- New python patch to fix python build
This commit is contained in:
Orion Poplawski 2013-09-30 10:42:28 -06:00
parent f0478aac52
commit 41bcadafb4
6 changed files with 25 additions and 76800 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ gdl-0.9rc4.tar.gz
/gdl-0.9.1.tar.gz
/gdl-0.9.2.tar.gz
/gdl-0.9.3.tar.gz
/gdl-0.9.4.tar.gz

View File

@ -1,15 +1,3 @@
diff -up gdl-0.9.2/testsuite/Makefile.am.build gdl-0.9.2/testsuite/Makefile.am
--- gdl-0.9.2/testsuite/Makefile.am.build 2012-05-10 15:11:37.730137963 -0600
+++ gdl-0.9.2/testsuite/Makefile.am 2012-05-10 16:15:25.312948418 -0600
@@ -2,7 +2,7 @@ check_LTLIBRARIES = libtest_ce.la
libtest_ce_la_SOURCES = libtest_ce.cpp
libtest_ce_la_LDFLAGS = -rpath $(abs_srcdir)/testsuite/.libs
-TESTS_ENVIRONMENT = $(top_srcdir)/testsuite/try $(top_srcdir)
+TESTS_ENVIRONMENT = $(top_srcdir)/testsuite/try $(top_srcdir) $(top_builddir)
TESTS = \
test_angles.pro \
test_base64.pro \
diff -up gdl-0.9.2/testsuite/try.build gdl-0.9.2/testsuite/try
--- gdl-0.9.2/testsuite/try.build 2011-05-02 05:00:47.000000000 -0600
+++ gdl-0.9.2/testsuite/try 2012-05-10 16:16:14.218180027 -0600

File diff suppressed because it is too large Load Diff

12
gdl-python.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up gdl-0.9.4/src/pythongdl.cpp.python gdl-0.9.4/src/pythongdl.cpp
--- gdl-0.9.4/src/pythongdl.cpp.python 2013-07-26 03:30:32.000000000 -0600
+++ gdl-0.9.4/src/pythongdl.cpp 2013-09-30 10:24:27.092666180 -0600
@@ -373,7 +373,7 @@ PyObject *GDLSub( PyObject *self, PyObje
if( libCall)
e = new EnvT( NULL, sub);
else
- e = new EnvUDT( NULL, sub);
+ e = new EnvUDT( NULL, static_cast<DSubUD*>(sub));
Guard< EnvBaseT> e_guard( e);

View File

@ -1,8 +1,8 @@
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: gdl
Version: 0.9.3
Release: 10.cvs20130731%{?dist}
Version: 0.9.4
Release: 1%{?dist}
Summary: GNU Data Language
Group: Applications/Engineering
@ -12,7 +12,6 @@ Source0: http://downloads.sourceforge.net/gnudatalanguage/%{name}-%{versi
Source1: gdl.csh
Source2: gdl.sh
Source3: makecvstarball
Patch0: gdl-cvs.patch
# Build with system antlr library. Request for upstream change here:
# https://sourceforge.net/tracker/index.php?func=detail&aid=2685215&group_id=97659&atid=618686
Patch1: gdl-antlr-auto.patch
@ -23,6 +22,9 @@ Patch3: gdl-build.patch
# Patch to support plplot's new width() function
# https://sourceforge.net/p/gnudatalanguage/patches/70/
Patch4: gdl-plwidth.patch
# Fix python build
# https://sourceforge.net/p/gnudatalanguage/bugs/552/
Patch5: gdl-python.patch
Patch13: gdl-0.9-antlr-cmake.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -98,7 +100,6 @@ Provides: %{name}-runtime = %{version}-%{release}
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .cvs
rm -rf src/antlr
%patch13 -p1 -b .antlr
pushd src
@ -110,8 +111,7 @@ popd
%patch2 -p1 -b .shared
%patch3 -p1 -b .build
%patch4 -p1 -b .plwidth
rm ltmain.sh
rm -r CMakeFiles
%patch5 -p1 -b .python
%global cmake_opts \\\
-DWXWIDGETS=ON \\\
@ -196,6 +196,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Sep 30 2013 Orion Poplawski <orion@cora.nwra.com> - 0.9.4-1
- Update to 0.9.4
- Update build patch - drop automake components
- New python patch to fix python build
* Tue Aug 27 2013 Orion Poplawski <orion@cora.nwra.com> - 0.9.3-10.cvs20130804
- Add patch to support new width() method in plplot

View File

@ -1 +1 @@
f4a8f64e90dec5de1c89a2aca42d9e75 gdl-0.9.3.tar.gz
5d8d5783a387cca264fe8edb09e04f10 gdl-0.9.4.tar.gz