Update to current cvs
Drop env patch fixed upstream
This commit is contained in:
parent
f58a69b9e3
commit
26f44ab2d2
File diff suppressed because it is too large
Load Diff
@ -1,21 +0,0 @@
|
||||
diff -up gdl-0.9.2/src/pythongdl.cpp.env gdl-0.9.2/src/pythongdl.cpp
|
||||
--- gdl-0.9.2/src/pythongdl.cpp.env 2011-09-20 05:33:52.000000000 -0600
|
||||
+++ gdl-0.9.2/src/pythongdl.cpp 2012-07-16 21:19:57.386741436 -0600
|
||||
@@ -224,7 +224,7 @@ bool CopyArgFromPython( vector<BaseGDL*>
|
||||
}
|
||||
}
|
||||
|
||||
- e.Extra(); // expand _EXTRA
|
||||
+ e.ResolveExtra(); // expand _EXTRA
|
||||
|
||||
return true;
|
||||
}
|
||||
@@ -383,7 +383,7 @@ PyObject *GDLSub( PyObject *self, PyObje
|
||||
|
||||
// make the call
|
||||
StackSizeGuard<EnvStackT> guard( GDLInterpreter::CallStack());
|
||||
- GDLInterpreter::CallStack().push_back( e);
|
||||
+ // GDLInterpreter::CallStack().push_back( e);
|
||||
|
||||
BaseGDL* retValGDL = NULL;
|
||||
auto_ptr<BaseGDL> retValGDL_guard;
|
9
gdl.spec
9
gdl.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: gdl
|
||||
Version: 0.9.2
|
||||
Release: 7.cvs20120716%{?dist}
|
||||
Release: 8.cvs20120717%{?dist}
|
||||
Summary: GNU Data Language
|
||||
|
||||
Group: Applications/Engineering
|
||||
@ -20,8 +20,6 @@ Patch1: gdl-antlr-auto.patch
|
||||
Patch2: gdl-shared.patch
|
||||
# Patch to allow make check to work for out of tree builds
|
||||
Patch3: gdl-build.patch
|
||||
# Patch to comment out env push_pack in pythongdl.c as elsewhere
|
||||
Patch4: gdl-0.9.2-env.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
#RHEL doesn't have the needed antlr version/headers, has old plplot
|
||||
@ -97,7 +95,6 @@ popd
|
||||
%endif
|
||||
%patch2 -p1 -b .shared
|
||||
%patch3 -p1 -b .build
|
||||
%patch4 -p1 -b .env
|
||||
rm ltmain.sh
|
||||
autoreconf --install
|
||||
|
||||
@ -180,6 +177,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 17 2012 Orion Poplawski <orion@cora.nwra.com> - 0.9.2-8.cvs20120717
|
||||
- Update to current cvs
|
||||
- Drop env patch fixed upstream
|
||||
|
||||
* Mon Jul 16 2012 Orion Poplawski <orion@cora.nwra.com> - 0.9.2-7.cvs20120716
|
||||
- Update to current cvs
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user