Add patch for test debugging
This commit is contained in:
parent
90d9e9f6d5
commit
2356278c4e
50
gdl-test.patch
Normal file
50
gdl-test.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -up gdl-0.9.4/testsuite/test_matrix_multiply.pro.test gdl-0.9.4/testsuite/test_matrix_multiply.pro
|
||||
--- gdl-0.9.4/testsuite/test_matrix_multiply.pro.test 2013-04-11 10:00:30.000000000 -0600
|
||||
+++ gdl-0.9.4/testsuite/test_matrix_multiply.pro 2013-10-01 10:10:48.507995487 -0600
|
||||
@@ -54,14 +54,38 @@ test4=trans_matrice#matrice-identity
|
||||
;
|
||||
errors=0
|
||||
tolerance=1e-5
|
||||
-if ABS(MIN(test1)) GT tolerance then errors++
|
||||
-if ABS(MAX(test1)) GT tolerance then errors++
|
||||
-if ABS(MIN(test2)) GT tolerance then errors++
|
||||
-if ABS(MAX(test2)) GT tolerance then errors++
|
||||
-if ABS(MIN(test3)) GT tolerance then errors++
|
||||
-if ABS(MAX(test3)) GT tolerance then errors++
|
||||
-if ABS(MIN(test4)) GT tolerance then errors++
|
||||
-if ABS(MAX(test4)) GT tolerance then errors++
|
||||
+if ABS(MIN(test1)) GT tolerance then begin
|
||||
+ print, 'ABS(MIN(test1))=',ABS(MIN(test1)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MAX(test1)) GT tolerance then begin
|
||||
+ print, 'ABS(MAX(test1))=',ABS(MAX(test1)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MIN(test2)) GT tolerance then begin
|
||||
+ print, 'ABS(MIN(test2))=',ABS(MIN(test2)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MAX(test2)) GT tolerance then begin
|
||||
+ print, 'ABS(MAX(test2))=',ABS(MAX(test2)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MIN(test3)) GT tolerance then begin
|
||||
+ print, 'ABS(MIN(test3))=',ABS(MIN(test3)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MAX(test3)) GT tolerance then begin
|
||||
+ print, 'ABS(MAX(test3))=',ABS(MAX(test3)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MIN(test4)) GT tolerance then begin
|
||||
+ print, 'ABS(MIN(test4))=',ABS(MIN(test4)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
+if ABS(MAX(test4)) GT tolerance then begin
|
||||
+ print, 'ABS(MAX(test4))=',ABS(MAX(test4)),' GT ',tolerance
|
||||
+ errors++
|
||||
+endif
|
||||
;
|
||||
if (errors GT 0) then begin
|
||||
print, 'size of matrix : ', nbp
|
5
gdl.spec
5
gdl.spec
@ -28,6 +28,9 @@ Patch5: gdl-python.patch
|
||||
# Fix datatype for use with gsl's permutation type
|
||||
# https://sourceforge.net/p/gnudatalanguage/bugs/570/
|
||||
Patch6: gdl-gsl.patch
|
||||
# test_matrix_multiply fails - try to debug
|
||||
# https://sourceforge.net/p/gnudatalanguage/bugs/556/
|
||||
Patch7: gdl-test.patch
|
||||
Patch13: gdl-0.9-antlr-cmake.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -116,6 +119,7 @@ popd
|
||||
%patch4 -p1 -b .plwidth
|
||||
%patch5 -p1 -b .python
|
||||
%patch6 -p1 -b .gsl
|
||||
%patch7 -p1 -b .gsl
|
||||
|
||||
%global cmake_opts \\\
|
||||
-DWXWIDGETS=ON \\\
|
||||
@ -198,6 +202,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Update build patch - drop automake components
|
||||
- New python patch to fix python build
|
||||
- Add patch to fix gsl usage
|
||||
- Add patch for test debugging
|
||||
|
||||
* Tue Aug 27 2013 Orion Poplawski <orion@cora.nwra.com> - 0.9.3-10.cvs20130804
|
||||
- Add patch to support new width() method in plplot
|
||||
|
Loading…
Reference in New Issue
Block a user