- Update to 0.9rc3

- Drop ppc64, friend patches fixed upstream
- Add source for makecvstarball
- Rebase antlr patch, add automake source version
- Add conditionals for EPEL builds
- Add %check section
This commit is contained in:
Orion Poplawski 2009-10-15 18:00:52 +00:00
parent aacbbe1a05
commit 0bb8fc3ed7
7 changed files with 50 additions and 59 deletions

View File

@ -1 +1 @@
gdl-0.9rc2-20090312.tar.bz2
gdl-0.9rc3.tar.gz

View File

@ -1,11 +0,0 @@
--- gdl-0.9pre5/configure.ppc64 2007-08-21 22:25:25.000000000 -0600
+++ gdl-0.9pre5/configure 2007-08-21 22:25:37.000000000 -0600
@@ -21152,7 +21152,7 @@
DARWIN="yes"
;;
- powerpc-*-linux* )
+ powerpc*-*-linux* )
LDFLAGS="$LDFLAGS -rdynamic"
;;

View File

@ -1,11 +0,0 @@
--- gdl-0.9pre6/src/plot3d_nr.cpp.plplot 2007-10-29 17:10:47.000000000 -0600
+++ gdl-0.9pre6/src/plot3d_nr.cpp 2008-02-27 09:39:56.000000000 -0700
@@ -217,7 +217,7 @@
zmin = (zmax_in > zmin_in) ? zmin_in: zmax_in;
zmax = (zmax_in > zmin_in) ? zmax_in: zmin_in;
- pldtik(zmin, zmax, &tick, &nsub);
+ pldtik(zmin, zmax, &tick, &nsub, FALSE);
tp = tick * floor(zmin / tick) + tick;
pl3upv = 0;

View File

@ -1,11 +0,0 @@
--- gdl-0.9rc2-20090224/src/envt.hpp.friend 2008-06-10 14:43:43.000000000 -0600
+++ gdl-0.9rc2-20090224/src/envt.hpp 2009-02-25 11:38:48.000000000 -0700
@@ -162,6 +162,8 @@
if( ix >= env.size()) return false;
return ( env.Env( ix) != NULL);
}
+
+ friend class DInterpreter;
};
// for UD subroutines (written in GDL) ********************************

View File

@ -1,6 +1,6 @@
--- gdl-0.9rc2-20090312/configure.antlr 2009-03-12 08:41:10.000000000 -0600
+++ gdl-0.9rc2-20090312/configure 2009-03-12 08:42:04.000000000 -0600
@@ -22102,7 +22102,7 @@
--- gdl-0.9rc3/configure.antlr 2009-09-11 10:04:09.000000000 -0600
+++ gdl-0.9rc3/configure 2009-10-15 11:11:06.707875846 -0600
@@ -23525,7 +23525,7 @@
@ -9,7 +9,7 @@
cat >confcache <<\_ACEOF
@@ -22707,7 +22707,6 @@
@@ -24130,7 +24130,6 @@
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
@ -17,8 +17,8 @@
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
echo "$as_me: error: invalid argument: $ac_config_target" >&2;}
--- gdl-0.9rc2-20090312/src/Makefile.in.antlr 2009-02-23 11:24:00.000000000 -0700
+++ gdl-0.9rc2-20090312/src/Makefile.in 2009-02-26 09:00:54.000000000 -0700
--- gdl-0.9rc3/src/Makefile.in.antlr 2009-09-11 10:04:09.000000000 -0600
+++ gdl-0.9rc3/src/Makefile.in 2009-10-15 11:10:12.689817337 -0600
@@ -55,7 +55,7 @@
libLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(lib_LTLIBRARIES)
@ -28,7 +28,7 @@
am__libgdl_la_SOURCES_DIST = accessdesc.hpp arrayindex.hpp \
assocdata.cpp assocdata.hpp basegdl.hpp basic_fun_cl.cpp \
basic_fun_cl.hpp basic_fun.cpp basic_fun.hpp basic_fun_jmg.cpp \
@@ -233,7 +233,7 @@
@@ -236,7 +236,7 @@
@BUILDASLIBRARY_FALSE@ gdl-gdl.$(OBJEXT)
gdl_OBJECTS = $(am_gdl_OBJECTS)
@BUILDASLIBRARY_FALSE@gdl_DEPENDENCIES = \
@ -37,7 +37,7 @@
gdl_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXXLD) $(gdl_CXXFLAGS) $(CXXFLAGS) \
$(gdl_LDFLAGS) $(LDFLAGS) -o $@
@@ -391,7 +391,6 @@
@@ -395,7 +395,6 @@
# set the include path found by configure
INCLUDES = $(EXT_INCLUDES) $(all_includes)
@ -45,7 +45,7 @@
noinst_HEADERS = gdlwidget.hpp prognode.hpp prognodeexpr.hpp
cpp_hpp_files = accessdesc.hpp arrayindex.hpp assocdata.cpp assocdata.hpp \
basegdl.hpp basic_fun_cl.cpp basic_fun_cl.hpp basic_fun.cpp basic_fun.hpp \
@@ -438,7 +437,7 @@
@@ -442,7 +441,7 @@
@BUILDASLIBRARY_FALSE@gdl_CXXFLAGS = $(AM_CXXFLAGS)
# the library search path.
@BUILDASLIBRARY_FALSE@gdl_LDFLAGS = $(all_libraries)
@ -54,7 +54,7 @@
# build as library (for python module)
@BUILDASLIBRARY_TRUE@lib_LTLIBRARIES = libgdl.la
@@ -448,7 +447,7 @@
@@ -452,7 +451,7 @@
# netCDF and HDF define some same symbols
# hence -z muldefs has to be passed to the linker
@BUILDASLIBRARY_TRUE@@DARWIN_TRUE@libgdl_la_LDFLAGS = $(all_libraries) -Wl,-m

View File

@ -2,34 +2,38 @@
Name: gdl
Version: 0.9
Release: 0.6.rc2.20090312%{?dist}
Release: 0.7.rc3%{?dist}
Summary: GNU Data Language
Group: Applications/Engineering
License: GPLv2+
URL: http://gnudatalanguage.sourceforge.net/
#Source0: http://downloads.sourceforge.net/gnudatalanguage/%{name}-%{version}rc2.tar.bz2
# cvs -z3 -d :pserver:anonymous@gnudatalanguage.cvs.sourceforge.net:/cvsroot/gnudatalanguage export -D 20090312 -d gdl-0.9rc2-20090312 gdl
# tar cjf gdl-0.9rc2-20090312.tar.bz2 gdl-0.9rc2-20090312
Source0: http://downloads.sourceforge.net/gnudatalanguage/%{name}-%{version}rc2-20090312.tar.bz2
Source0: http://downloads.sourceforge.net/gnudatalanguage/%{name}-%{version}rc3.tar.gz
# Made with makecvstarball
#Source0: http://downloads.sourceforge.net/gnudatalanguage/%{name}-%{version}rc2-20090603.tar.bz2
Source1: gdl.csh
Source2: gdl.sh
Patch1: gdl-0.9pre5-ppc64.patch
Source3: makecvstarball
Patch2: gdl-0.9rc1-gcc43.patch
# Build with system antlr library. Request for upstream change here:
# https://sourceforge.net/tracker/index.php?func=detail&aid=2685215&group_id=97659&atid=618686
Patch3: gdl-0.9rc2-20090312-antlr.patch
# gcc 4.4.0 catches more class issues - add needed friend
# https://sourceforge.net/tracker/index.php?func=detail&aid=2634356&group_id=97659&atid=618683
Patch4: gdl-0.9rc2-20090224-friend.patch
Patch3: gdl-0.9rc3-antlr.patch
Patch4: gdl-0.9rc2-20090504-antlr-auto.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
#RHEL doesn't have the needed antlr version/headers, old plplot
%if !0%{?rhel}
BuildRequires: antlr
%define plplot_config %{nil}
%else
%define plplot_config --enable-oldplplot
%endif
BuildRequires: readline-devel, ncurses-devel
BuildRequires: gsl-devel, plplot-devel, ImageMagick-c++-devel
BuildRequires: netcdf-devel, hdf5-devel, libjpeg-devel
BuildRequires: python-devel, python-numarray, python-matplotlib
BuildRequires: fftw-devel, hdf-devel, proj-devel
BuildRequires: autoconf, automake, libtool
# Needed to pull in drivers
Requires: plplot
Requires: %{name}-common = %{version}-%{release}
@ -46,25 +50,32 @@ Systems Inc.
Summary: Common files for GDL
Group: Applications/Engineering
Requires: %{name}-runtime = %{version}-%{release}
%if !0%{?rhel}
BuildArch: noarch
%endif
%description common
Common files for GDL
%prep
%setup -q -n %{name}-%{version}rc2-20090312
%patch1 -p1 -b .ppc64
%setup -q -n %{name}-%{version}rc3
%patch2 -p1 -b .gcc43
%if !0%{?rhel}
%patch3 -p1 -b .antlr
%patch4 -p1 -b .friend
%patch4 -p1 -b .antlr-auto
%endif
%if !0%{?rhel}
rm -rf src/antlr
%endif
rm ltmain.sh
autoreconf --install
%build
export CPPFLAGS="-DH5_USE_16_API"
%global _configure ../configure
%configure --disable-dependency-tracking --disable-static --with-fftw \
%{plplot_config} \
INCLUDES="-I/usr/include/netcdf -I/usr/include/hdf" \
LIBS="-L%{_libdir}/hdf"
make %{?_smp_mflags}
@ -85,6 +96,11 @@ install -m 0644 %SOURCE1 $RPM_BUILD_ROOT/%{_sysconfdir}/profile.d
install -m 0644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/profile.d
%check
cd testsuite
echo ".r test_suite" | ../src/gdl
%clean
rm -rf $RPM_BUILD_ROOT
@ -101,6 +117,14 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Oct 15 2009 - Orion Poplawski <orion@cora.nwra.com> - 0.9-0.7.rc3
- Update to 0.9rc3
- Drop ppc64, friend patches fixed upstream
- Add source for makecvstarball
- Rebase antlr patch, add automake source version
- Add conditionals for EPEL builds
- Add %%check section
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-0.6.rc2.20090312
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

View File

@ -1 +1 @@
a3f361a43164617934134300cbe51207 gdl-0.9rc2-20090312.tar.bz2
94a29e13ec5d71e664659b32e421b02e gdl-0.9rc3.tar.gz