fix build

This commit is contained in:
David Tardon 2018-02-14 16:04:15 +01:00
parent 0084b47d85
commit a59d91296e
3 changed files with 27 additions and 0 deletions

View File

@ -0,0 +1,11 @@
diff -up ./Utilities/doxygen/CMakeLists.txt.backup ./Utilities/doxygen/CMakeLists.txt
--- ./Utilities/doxygen/CMakeLists.txt.backup 2017-11-09 09:09:58.000000000 +0100
+++ ./Utilities/doxygen/CMakeLists.txt 2018-02-14 15:17:12.223249372 +0100
@@ -253,6 +253,7 @@ if(LIBXSLT_XSLTPROC_EXECUTABLE)
set(XSLT_PROCESSOR ${LIBXSLT_XSLTPROC_EXECUTABLE})
# http://docbook.sourceforge.net/release/xsl/current/doc/manpages/man.output.quietly.html
set(XSLT_PROCESSOR_ARG --param man.output.quietly 1)
+ set(XSLT_PROCESSOR_ARG --maxdepth 5000)
# User can change the behavior at cmake time:
if(NOT DEFINED GDCM_MANPAGES_USE_NONET)
set(GDCM_MANPAGES_USE_NONET FALSE)

View File

@ -0,0 +1,12 @@
diff -up ./CMakeLists.txt.dt ./CMakeLists.txt
--- ./CMakeLists.txt.dt 2018-02-14 15:33:46.376657320 +0100
+++ ./CMakeLists.txt 2018-02-14 15:33:51.173615948 +0100
@@ -15,7 +15,7 @@ if( POLICY CMP0063 )
cmake_policy(SET CMP0063 NEW)
endif()
project(GDCM)
-set(CMAKE_CXX_STANDARD 98)
+set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_EXTENSIONS OFF)
mark_as_advanced(CMAKE_BACKWARDS_COMPATIBILITY CMAKE_BUILD_TYPE CMAKE_INSTALL_PREFIX)
set(GDCM_CMAKE_DIR "${GDCM_SOURCE_DIR}/CMake" CACHE INTERNAL "")

View File

@ -14,6 +14,8 @@ Patch3: gdcm-2.4.0-no-versioned-dir.patch
#Patch4: gdcm-0005-support-vtk6.patch
Patch5: gdcm-2.4.0-find-python27.patch
Patch6: gdcm-2.6-fix-cmake-config-paths.patch
Patch7: gdcm-2.8.4-fix-manpage-gen.patch
Patch8: gdcm-2.8.4-fix-poppler.patch
BuildRequires: CharLS-devel >= 1.0
BuildRequires: cmake
@ -113,6 +115,8 @@ used this library with python
%patch2 -p 1
%patch3 -p 1
%patch6 -p 1
%patch7 -p 1
%patch8 -p 1
# Fix cmake command
sed -i.backup 's/add_dependency/add_dependencies/' Utilities/doxygen/CMakeLists.txt