Fix patch2 , disable docs
This commit is contained in:
parent
501710ed64
commit
953cfafe94
@ -1,18 +1,6 @@
|
||||
From 84da37121e7814cf1e5c423cc0779d6df6b1c660 Mon Sep 17 00:00:00 2001
|
||||
From: "Ankur Sinha (Ankur Sinha Gmail)" <sanjay.ankur@gmail.com>
|
||||
Date: Sun, 17 Feb 2019 21:23:45 +0000
|
||||
Subject: [PATCH 6/7] Update for new poppler
|
||||
|
||||
---
|
||||
Applications/Cxx/gdcminfo.cxx | 34 +++++++++++++++++-----------------
|
||||
Applications/Cxx/gdcmpdf.cxx | 12 ++++++------
|
||||
2 files changed, 23 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/Applications/Cxx/gdcminfo.cxx b/Applications/Cxx/gdcminfo.cxx
|
||||
index 2c510d7df..d9506be4e 100644
|
||||
--- a/Applications/Cxx/gdcminfo.cxx
|
||||
+++ b/Applications/Cxx/gdcminfo.cxx
|
||||
@@ -105,22 +105,22 @@ static int checkdeflated(const char *name)
|
||||
--- ./Applications/Cxx/gdcminfo.cxx.orig 2019-02-27 17:20:57.000000000 +0000
|
||||
+++ ./Applications/Cxx/gdcminfo.cxx 2019-09-17 07:33:31.966220556 +0100
|
||||
@@ -105,22 +105,22 @@ static int checkdeflated(const char *nam
|
||||
return 1;
|
||||
}
|
||||
in = fopen(name, "r");
|
||||
@ -39,7 +27,7 @@ index 2c510d7df..d9506be4e 100644
|
||||
fprintf( stderr, "source is NULL\n" );
|
||||
return 1;
|
||||
}
|
||||
@@ -172,7 +172,7 @@ static int checkdeflated(const char *name)
|
||||
@@ -172,7 +172,7 @@ static int checkdeflated(const char *nam
|
||||
printf( "deflate stream has proper length: %lu\n", len );
|
||||
}
|
||||
|
||||
@ -48,7 +36,7 @@ index 2c510d7df..d9506be4e 100644
|
||||
|
||||
if (ret)
|
||||
fprintf(stdout,"puff() failed with return code %d\n", ret);
|
||||
@@ -202,7 +202,7 @@ static std::string getInfoDate(Dict *infoDict, const char *key)
|
||||
@@ -202,7 +202,7 @@ static std::string getInfoDate(Dict *inf
|
||||
#endif
|
||||
{
|
||||
const GooString* gs = obj.getString();
|
||||
@ -57,31 +45,7 @@ index 2c510d7df..d9506be4e 100644
|
||||
if (s[0] == 'D' && s[1] == ':')
|
||||
{
|
||||
s += 2;
|
||||
@@ -258,7 +258,7 @@ static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uM
|
||||
{
|
||||
Object obj;
|
||||
const GooString *s1;
|
||||
- GBool isUnicode;
|
||||
+ bool isUnicode;
|
||||
Unicode u;
|
||||
char buf[8];
|
||||
int i, n;
|
||||
@@ -274,12 +274,12 @@ static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uM
|
||||
if ((s1->getChar(0) & 0xff) == 0xfe &&
|
||||
(s1->getChar(1) & 0xff) == 0xff)
|
||||
{
|
||||
- isUnicode = gTrue;
|
||||
+ isUnicode = true;
|
||||
i = 2;
|
||||
}
|
||||
else
|
||||
{
|
||||
- isUnicode = gFalse;
|
||||
+ isUnicode = false;
|
||||
i = 0;
|
||||
}
|
||||
while (i < obj.getString()->getLength())
|
||||
@@ -400,7 +400,7 @@ static int ProcessOneFile( std::string const & filename, gdcm::Defs const & defs
|
||||
@@ -400,7 +400,7 @@ static int ProcessOneFile( std::string c
|
||||
return 1;
|
||||
}
|
||||
gdcm::SplitMosaicFilter filter;
|
||||
@ -90,21 +54,6 @@ index 2c510d7df..d9506be4e 100644
|
||||
const gdcm::Image &image = reader.GetImage();
|
||||
if( mosaic )
|
||||
{
|
||||
@@ -539,10 +539,10 @@ static int ProcessOneFile( std::string const & filename, gdcm::Defs const & defs
|
||||
int pages = doc->getNumPages();
|
||||
const char *encrypted = doc->isEncrypted() ? "yes" : "no";
|
||||
// printf("yes (print:%s copy:%s change:%s addNotes:%s)\n",
|
||||
- // doc->okToPrint(gTrue) ? "yes" : "no",
|
||||
- // doc->okToCopy(gTrue) ? "yes" : "no",
|
||||
- // doc->okToChange(gTrue) ? "yes" : "no",
|
||||
- // doc->okToAddNotes(gTrue) ? "yes" : "no");
|
||||
+ // doc->okToPrint(true) ? "yes" : "no",
|
||||
+ // doc->okToCopy(true) ? "yes" : "no",
|
||||
+ // doc->okToChange(true) ? "yes" : "no",
|
||||
+ // doc->okToAddNotes(true) ? "yes" : "no");
|
||||
|
||||
// print linearization info
|
||||
const char *optimized = doc->isLinearized() ? "yes" : "no";
|
||||
@@ -608,10 +608,10 @@ int main(int argc, char *argv[])
|
||||
int version = 0;
|
||||
int debug = 0;
|
||||
@ -127,11 +76,9 @@ index 2c510d7df..d9506be4e 100644
|
||||
};
|
||||
static const char short_options[] = "i:rdVWDEhv";
|
||||
c = getopt_long (argc, argv, short_options,
|
||||
diff --git a/Applications/Cxx/gdcmpdf.cxx b/Applications/Cxx/gdcmpdf.cxx
|
||||
index b3f22b520..15220a34b 100644
|
||||
--- a/Applications/Cxx/gdcmpdf.cxx
|
||||
+++ b/Applications/Cxx/gdcmpdf.cxx
|
||||
@@ -50,7 +50,7 @@ static std::string getInfoDate(Dict *infoDict, const char *key)
|
||||
--- ./Applications/Cxx/gdcmpdf.cxx.orig 2019-02-27 17:20:57.000000000 +0000
|
||||
+++ ./Applications/Cxx/gdcmpdf.cxx 2019-09-17 07:33:31.967220575 +0100
|
||||
@@ -50,7 +50,7 @@ static std::string getInfoDate(Dict *inf
|
||||
#endif
|
||||
{
|
||||
const GooString* gs = obj.getString();
|
||||
@ -140,44 +87,3 @@ index b3f22b520..15220a34b 100644
|
||||
if (s[0] == 'D' && s[1] == ':')
|
||||
{
|
||||
s += 2;
|
||||
@@ -102,11 +102,11 @@ static std::string getInfoDate(Dict *infoDict, const char *key)
|
||||
return out;
|
||||
}
|
||||
|
||||
-static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap, GBool & unicode)
|
||||
+static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uMap, bool & unicode)
|
||||
{
|
||||
Object obj;
|
||||
const GooString *s1;
|
||||
- GBool isUnicode = gFalse;
|
||||
+ bool isUnicode = false;
|
||||
Unicode u;
|
||||
char buf[8];
|
||||
int i, n;
|
||||
@@ -122,12 +122,12 @@ static std::string getInfoString(Dict *infoDict, const char *key, UnicodeMap *uM
|
||||
if ((s1->getChar(0) & 0xff) == 0xfe &&
|
||||
(s1->getChar(1) & 0xff) == 0xff)
|
||||
{
|
||||
- isUnicode = gTrue;
|
||||
+ isUnicode = true;
|
||||
i = 2;
|
||||
}
|
||||
else
|
||||
{
|
||||
- isUnicode = gFalse;
|
||||
+ isUnicode = false;
|
||||
i = 0;
|
||||
}
|
||||
while (i < obj.getString()->getLength())
|
||||
@@ -398,7 +398,7 @@ http://msdn.microsoft.com/en-us/library/078sfkak(VS.80).aspx
|
||||
std::string creationdate;
|
||||
std::string moddate;
|
||||
|
||||
- GBool isUnicode = gFalse;
|
||||
+ bool isUnicode = false;
|
||||
if (doc->isOk())
|
||||
{
|
||||
#ifdef LIBPOPPLER_NEW_OBJECT_API
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
@ -13,29 +13,29 @@
|
||||
std::cout << s2 << " -> " << s2.size() << std::endl;
|
||||
|
||||
- gdcm::String<EOF,64,0> s3 = "coucou";
|
||||
+ gdcm::String<'\\',64,0> s3 = "coucou";
|
||||
+ gdcm::String<'\0',64,0> s3 = "coucou";
|
||||
std::cout << s3.c_str() << " -> " << s3.size() << std::endl;
|
||||
|
||||
- gdcm::String<EOF,64,0> s4 = "coucou!";
|
||||
+ gdcm::String<'\\',64,0> s4 = "coucou!";
|
||||
+ gdcm::String<'\0',64,0> s4 = "coucou!";
|
||||
std::cout << s4.c_str() << " -> " << s4.size() << std::endl;
|
||||
|
||||
const char *s = "coucou!";
|
||||
- gdcm::String<EOF,64,0> s5( s, strlen(s) );
|
||||
+ gdcm::String<'\\',64,0> s5( s, strlen(s) );
|
||||
+ gdcm::String<'\0',64,0> s5( s, strlen(s) );
|
||||
std::cout << s5.c_str() << " -> " << s5.size() << std::endl;
|
||||
|
||||
std::string ss = "coucou!";
|
||||
- gdcm::String<EOF,64,0> s6( ss );
|
||||
+ gdcm::String<'\\',64,0> s6( ss );
|
||||
+ gdcm::String<'\0',64,0> s6( ss );
|
||||
std::cout << s6.c_str() << " -> " << s6.size() << std::endl;
|
||||
|
||||
- gdcm::String<EOF,64,0> s7( ss, 1, 5 );
|
||||
+ gdcm::String<'\\',64,0> s7( ss, 1, 5 );
|
||||
+ gdcm::String<'\0',64,0> s7( ss, 1, 5 );
|
||||
std::cout << s7.c_str() << " -> " << s7.size() << std::endl;
|
||||
|
||||
- gdcm::String<EOF,64,0> s8( ss, 1, 6 );
|
||||
+ gdcm::String<'\\',64,0> s8( ss, 1, 6 );
|
||||
+ gdcm::String<'\0',64,0> s8( ss, 1, 6 );
|
||||
std::cout << s8.c_str() << " -> " << s8.size() << std::endl;
|
||||
|
||||
return 0;
|
||||
|
30
gdcm.spec
30
gdcm.spec
@ -12,9 +12,6 @@ Source0: https://github.com/malaterre/%{name}/archive/v%{version}/%{name}-%{v
|
||||
Source1: http://downloads.sourceforge.net/project/gdcm/gdcmData/gdcmData/gdcmData.tar.gz
|
||||
|
||||
Patch1: 0001-Use-copyright.patch
|
||||
# Increase maxdepth to permit generation of man pages
|
||||
# https://sourceforge.net/p/gdcm/bugs/449/
|
||||
Patch2: 0002-Increase-xslt-maxdepth.patch
|
||||
# Use add_subdirectories since subdirs may not pass variables properly
|
||||
# https://stackoverflow.com/a/30894329/375067
|
||||
# https://cmake.org/pipermail/cmake/2007-August/015928.html
|
||||
@ -121,7 +118,7 @@ used this library with python
|
||||
%autosetup -n GDCM-%{version} -S git -N
|
||||
# Data source
|
||||
%setup -n GDCM-%{version} -q -T -D -a 1
|
||||
%patch -p1 -P 1 2 3 4 5 7 8
|
||||
%patch -p1 -P 1 3 4 5 7 8
|
||||
%if 0%{?fedora} > 29
|
||||
%patch6 -p1 -b .poppler.0.73.0
|
||||
%endif
|
||||
@ -164,7 +161,7 @@ pushd %{_target_platform}
|
||||
-DGDCM_BUILD_TESTING:BOOL=ON \
|
||||
-DGDCM_DATA_ROOT=../gdcmData/ \
|
||||
-DGDCM_BUILD_EXAMPLES:BOOL=ON \
|
||||
-DGDCM_DOCUMENTATION:BOOL=ON \
|
||||
-DGDCM_DOCUMENTATION:BOOL=OFF \
|
||||
-DGDCM_WRAP_PYTHON:BOOL=ON \
|
||||
-DPYTHON_EXECUTABLE=%{__python3} \
|
||||
-DGDCM_INSTALL_PYTHONMODULE_DIR=%{python3_sitearch} \
|
||||
@ -215,25 +212,25 @@ make test -C %{_target_platform} || exit 0
|
||||
%doc AUTHORS README.txt
|
||||
%license Copyright.txt README.Copyright.txt
|
||||
%{_libdir}/libgdcmCommon.so.2.8
|
||||
%{_libdir}/libgdcmCommon.so.2.8.8
|
||||
%{_libdir}/libgdcmCommon.so.2.8.9
|
||||
%{_libdir}/libgdcmDICT.so.2.8
|
||||
%{_libdir}/libgdcmDICT.so.2.8.8
|
||||
%{_libdir}/libgdcmDICT.so.2.8.9
|
||||
%{_libdir}/libgdcmDSED.so.2.8
|
||||
%{_libdir}/libgdcmDSED.so.2.8.8
|
||||
%{_libdir}/libgdcmDSED.so.2.8.9
|
||||
%{_libdir}/libgdcmIOD.so.2.8
|
||||
%{_libdir}/libgdcmIOD.so.2.8.8
|
||||
%{_libdir}/libgdcmIOD.so.2.8.9
|
||||
%{_libdir}/libgdcmMEXD.so.2.8
|
||||
%{_libdir}/libgdcmMEXD.so.2.8.8
|
||||
%{_libdir}/libgdcmMEXD.so.2.8.9
|
||||
%{_libdir}/libgdcmMSFF.so.2.8
|
||||
%{_libdir}/libgdcmMSFF.so.2.8.8
|
||||
%{_libdir}/libgdcmMSFF.so.2.8.9
|
||||
%{_libdir}/libgdcmjpeg12.so.2.8
|
||||
%{_libdir}/libgdcmjpeg12.so.2.8.8
|
||||
%{_libdir}/libgdcmjpeg12.so.2.8.9
|
||||
%{_libdir}/libgdcmjpeg16.so.2.8
|
||||
%{_libdir}/libgdcmjpeg16.so.2.8.8
|
||||
%{_libdir}/libgdcmjpeg16.so.2.8.9
|
||||
%{_libdir}/libgdcmjpeg8.so.2.8
|
||||
%{_libdir}/libgdcmjpeg8.so.2.8.8
|
||||
%{_libdir}/libgdcmjpeg8.so.2.8.9
|
||||
%{_libdir}/libgdcmmd5.so.2.8
|
||||
%{_libdir}/libgdcmmd5.so.2.8.8
|
||||
%{_libdir}/libgdcmmd5.so.2.8.9
|
||||
%{_libdir}/libsocketxx.so.1.2
|
||||
%{_libdir}/libsocketxx.so.1.2.0
|
||||
%dir %{_datadir}/%{name}
|
||||
@ -241,7 +238,7 @@ make test -C %{_target_platform} || exit 0
|
||||
%exclude %{_docdir}/%{name}/html/
|
||||
|
||||
%files doc
|
||||
%doc %{_docdir}/%{name}/html/
|
||||
#doc %{_docdir}/%{name}/html/
|
||||
|
||||
%files applications
|
||||
%{_bindir}/gdcmanon
|
||||
@ -286,6 +283,7 @@ make test -C %{_target_platform} || exit 0
|
||||
%changelog
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
- Fix patch2 , disable docs
|
||||
|
||||
* Thu Apr 11 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 2.8.9-1
|
||||
- Update to 2.8.9
|
||||
|
Loading…
Reference in New Issue
Block a user