Update patch to allow inplace build
- Remove gdcm-as.patch which has been applied upstream
This commit is contained in:
parent
ac659928db
commit
862d2ce942
@ -1,16 +0,0 @@
|
|||||||
--- gdcm-2.4.0.orig/CMakeLists.txt 2013-10-16 10:28:54.000000000 +0200
|
|
||||||
+++ gdcm-2.4.0/CMakeLists.txt 2013-10-20 20:49:44.857086416 +0200
|
|
||||||
@@ -27,13 +27,6 @@
|
|
||||||
|
|
||||||
#-----------------------------------------------------------------------------
|
|
||||||
# Disallow insource build since I never test that
|
|
||||||
-string(COMPARE EQUAL "${GDCM_SOURCE_DIR}" "${GDCM_BINARY_DIR}" INSOURCE)
|
|
||||||
-get_filename_component(PARENTDIR ${GDCM_BINARY_DIR} PATH)
|
|
||||||
-string(COMPARE EQUAL "${GDCM_SOURCE_DIR}" "${PARENTDIR}" INSOURCESUBDIR)
|
|
||||||
-if(INSOURCE OR INSOURCESUBDIR)
|
|
||||||
- message(FATAL_ERROR "GDCM requires an out of source Build. "
|
|
||||||
- "Please create a separate binary directory and run CMake there.")
|
|
||||||
-endif()
|
|
||||||
|
|
||||||
#----------------------------------------------------------------------------
|
|
||||||
set(GDCM_MAJOR_VERSION 2)
|
|
20
gdcm-2.4.5-inplace-build.patch
Normal file
20
gdcm-2.4.5-inplace-build.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- gdcm-2.4.5.orig/CMakeLists.txt 2015-08-22 16:09:50.000000000 +0200
|
||||||
|
+++ gdcm-2.4.5/CMakeLists.txt 2015-08-29 15:19:12.908123494 +0200
|
||||||
|
@@ -30,17 +30,6 @@
|
||||||
|
# VTK source tree for "DELAYLOAD"
|
||||||
|
|
||||||
|
#-----------------------------------------------------------------------------
|
||||||
|
-if(NOT DEFINED GDCM_ALLOW_INSOURCE_BUILD)
|
||||||
|
- # Disallow insource build since I never test that
|
||||||
|
- string(COMPARE EQUAL "${GDCM_SOURCE_DIR}" "${GDCM_BINARY_DIR}" INSOURCE)
|
||||||
|
- get_filename_component(PARENTDIR ${GDCM_BINARY_DIR} PATH)
|
||||||
|
- string(COMPARE EQUAL "${GDCM_SOURCE_DIR}" "${PARENTDIR}" INSOURCESUBDIR)
|
||||||
|
- if(INSOURCE OR INSOURCESUBDIR)
|
||||||
|
- message(FATAL_ERROR "GDCM requires an out of source Build. "
|
||||||
|
- "Please create a separate binary directory and run CMake there. "
|
||||||
|
- "Or explicitly define GDCM_ALLOW_INSOURCE_BUILD")
|
||||||
|
- endif()
|
||||||
|
-endif()
|
||||||
|
#----------------------------------------------------------------------------
|
||||||
|
set(GDCM_MAJOR_VERSION 2)
|
||||||
|
set(GDCM_MINOR_VERSION 4)
|
@ -1,64 +0,0 @@
|
|||||||
commit c333154ef31f15c66e748077475220c04fa1e651
|
|
||||||
Author: Mathieu Malaterre <mathieu.malaterre@gmail.com>
|
|
||||||
Date: Tue Feb 24 21:49:44 2015 +0100
|
|
||||||
|
|
||||||
Do not use `as` since it is a reserved python keyword
|
|
||||||
|
|
||||||
diff --git a/Source/MessageExchangeDefinition/gdcmAAssociateRQPDU.h b/Source/MessageExchangeDefinition/gdcmAAssociateRQPDU.h
|
|
||||||
index 852a684..08309d5 100644
|
|
||||||
--- a/Source/MessageExchangeDefinition/gdcmAAssociateRQPDU.h
|
|
||||||
+++ b/Source/MessageExchangeDefinition/gdcmAAssociateRQPDU.h
|
|
||||||
@@ -80,7 +80,7 @@ public:
|
|
||||||
PresentationContextArrayType const &GetPresentationContexts() { return PresContext; }
|
|
||||||
|
|
||||||
const PresentationContextRQ *GetPresentationContextByID(uint8_t i) const;
|
|
||||||
- const PresentationContextRQ *GetPresentationContextByAbstractSyntax(AbstractSyntax const & as ) const;
|
|
||||||
+ const PresentationContextRQ *GetPresentationContextByAbstractSyntax(AbstractSyntax const & absyn ) const;
|
|
||||||
bool IsLastFragment() const { return true; }
|
|
||||||
|
|
||||||
const UserInformation & GetUserInformation() const { return UserInfo; }
|
|
||||||
diff --git a/Source/MessageExchangeDefinition/gdcmPresentationContextRQ.h b/Source/MessageExchangeDefinition/gdcmPresentationContextRQ.h
|
|
||||||
index db06a9f..6de57dc 100644
|
|
||||||
--- a/Source/MessageExchangeDefinition/gdcmPresentationContextRQ.h
|
|
||||||
+++ b/Source/MessageExchangeDefinition/gdcmPresentationContextRQ.h
|
|
||||||
@@ -46,7 +46,7 @@ public:
|
|
||||||
const std::ostream &Write(std::ostream &os) const;
|
|
||||||
size_t Size() const;
|
|
||||||
|
|
||||||
- void SetAbstractSyntax( AbstractSyntax const & as );
|
|
||||||
+ void SetAbstractSyntax( AbstractSyntax const & absyn );
|
|
||||||
AbstractSyntax const &GetAbstractSyntax() const { return SubItems; }
|
|
||||||
AbstractSyntax &GetAbstractSyntax() { return SubItems; }
|
|
||||||
|
|
||||||
commit 36e44b330085ae80b4ecc2d519f43db2a65cd61e
|
|
||||||
Author: Mathieu Malaterre <mathieu.malaterre@gmail.com>
|
|
||||||
Date: Wed Feb 25 07:39:22 2015 +0100
|
|
||||||
|
|
||||||
Another round of fixes for bug #345
|
|
||||||
|
|
||||||
diff --git a/Source/MessageExchangeDefinition/gdcmPresentationContext.h b/Source/MessageExchangeDefinition/gdcmPresentationContext.h
|
|
||||||
index 324f0fa..c4fba12 100644
|
|
||||||
--- a/Source/MessageExchangeDefinition/gdcmPresentationContext.h
|
|
||||||
+++ b/Source/MessageExchangeDefinition/gdcmPresentationContext.h
|
|
||||||
@@ -37,7 +37,7 @@ public:
|
|
||||||
PresentationContext( UIDs::TSName asname,
|
|
||||||
UIDs::TSName tsname = UIDs::ImplicitVRLittleEndianDefaultTransferSyntaxforDICOM );
|
|
||||||
|
|
||||||
- void SetAbstractSyntax( const char *as ) { AbstractSyntax = as; }
|
|
||||||
+ void SetAbstractSyntax( const char *absyn ) { AbstractSyntax = absyn; }
|
|
||||||
const char *GetAbstractSyntax() const { return AbstractSyntax.c_str(); }
|
|
||||||
|
|
||||||
void AddTransferSyntax( const char *tsstr );
|
|
||||||
diff --git a/Source/MessageExchangeDefinition/gdcmPresentationContextGenerator.h b/Source/MessageExchangeDefinition/gdcmPresentationContextGenerator.h
|
|
||||||
index 9bb8e43..46b7102 100644
|
|
||||||
--- a/Source/MessageExchangeDefinition/gdcmPresentationContextGenerator.h
|
|
||||||
+++ b/Source/MessageExchangeDefinition/gdcmPresentationContextGenerator.h
|
|
||||||
@@ -80,7 +80,7 @@ public:
|
|
||||||
/// Not implemented for now. GDCM internally uses Implicit Little Endian
|
|
||||||
void SetDefaultTransferSyntax( const TransferSyntax &ts );
|
|
||||||
protected:
|
|
||||||
- bool AddPresentationContext( const char *as, const char *ts );
|
|
||||||
+ bool AddPresentationContext( const char *absyn, const char *ts );
|
|
||||||
const char *GetDefaultTransferSyntax() const;
|
|
||||||
|
|
||||||
private:
|
|
@ -14,16 +14,13 @@ URL: http://gdcm.sourceforge.net/wiki/index.php/Main_Page
|
|||||||
Source0: http://sourceforge.net/projects/gdcm/files/gdcm%202.x/GDCM%20%{version}/%{name}-%{version}.tar.bz2
|
Source0: http://sourceforge.net/projects/gdcm/files/gdcm%202.x/GDCM%20%{version}/%{name}-%{version}.tar.bz2
|
||||||
Source1: http://downloads.sourceforge.net/project/gdcm/gdcmData/gdcmData/gdcmData.tar.gz
|
Source1: http://downloads.sourceforge.net/project/gdcm/gdcmData/gdcmData/gdcmData.tar.gz
|
||||||
|
|
||||||
Patch1: gdcm-2.4.0-inplace-build.patch
|
Patch1: gdcm-2.4.5-inplace-build.patch
|
||||||
Patch2: gdcm-2.4.0-usecopyright.patch
|
Patch2: gdcm-2.4.0-usecopyright.patch
|
||||||
Patch3: gdcm-2.4.0-install2libarch.patch
|
Patch3: gdcm-2.4.0-install2libarch.patch
|
||||||
Patch4: gdcm-2.4.0-no-versioned-dir.patch
|
Patch4: gdcm-2.4.0-no-versioned-dir.patch
|
||||||
# From http://public.kitware.com/pipermail/vtkusers/2013-February/127377.html
|
# From http://public.kitware.com/pipermail/vtkusers/2013-February/127377.html
|
||||||
Patch5: gdcm-0005-support-vtk6.patch
|
Patch5: gdcm-0005-support-vtk6.patch
|
||||||
Patch6: gdcm-2.4.0-find-python27.patch
|
Patch6: gdcm-2.4.0-find-python27.patch
|
||||||
# Fix FTBS - https://bugzilla.redhat.com/show_bug.cgi?id=1195879
|
|
||||||
# https://sourceforge.net/p/gdcm/bugs/345/
|
|
||||||
Patch7: gdcm-as.patch
|
|
||||||
|
|
||||||
BuildRequires: CharLS-devel >= 1.0
|
BuildRequires: CharLS-devel >= 1.0
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -112,7 +109,6 @@ used this library with python
|
|||||||
%patch3 -p 1
|
%patch3 -p 1
|
||||||
%patch4 -p 1
|
%patch4 -p 1
|
||||||
%patch5 -p 1
|
%patch5 -p 1
|
||||||
%patch7 -p 1 -b.as
|
|
||||||
|
|
||||||
# Remove bundled utilities (we use Fedora's ones)
|
# Remove bundled utilities (we use Fedora's ones)
|
||||||
|
|
||||||
@ -270,6 +266,8 @@ make test -C %{_target_platform} || exit 0
|
|||||||
%changelog
|
%changelog
|
||||||
* Sat Aug 29 2015 Sebastian Pölsterl <sebp@k-d-w.org> - 2.4.5-1
|
* Sat Aug 29 2015 Sebastian Pölsterl <sebp@k-d-w.org> - 2.4.5-1
|
||||||
- Update to 2.4.5
|
- Update to 2.4.5
|
||||||
|
- Update patch to allow inplace build
|
||||||
|
- Remove gdcm-as.patch which has been applied upstream
|
||||||
|
|
||||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.4-6
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.4-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user