6c805458b5
These changes, originally added to Fedora GDB by Keith Seitz, and described in the Nov 30 2022 Changelog eentry, were inadvertently lost during the GDB 13.1 rebase. Only downstream/local changes were lost - the remainder of the changes were in the upstream GDB 13.1 sources.
72 lines
2.6 KiB
Diff
72 lines
2.6 KiB
Diff
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
|
From: Fedora GDB patches <invalid@email.com>
|
|
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
|
Subject: gdb-fedora-libncursesw.patch
|
|
|
|
;; Force libncursesw over libncurses to match the includes (RH BZ 1270534).
|
|
;;=push+jan
|
|
|
|
Fedora: Force libncursesw over libncurses to match the includes.
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1270534
|
|
|
|
diff --git a/gdb/configure b/gdb/configure
|
|
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -20916,6 +20916,7 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing waddstr" >&5
|
|
$as_echo_n "checking for library containing waddstr... " >&6; }
|
|
if ${ac_cv_search_waddstr+:} false; then :
|
|
@@ -20940,7 +20941,7 @@ return waddstr ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' ncursesw ncurses cursesX curses; do
|
|
+for ac_lib in '' ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
@@ -21014,6 +21015,7 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing tgetent" >&5
|
|
$as_echo_n "checking for library containing tgetent... " >&6; }
|
|
if ${ac_cv_search_tgetent+:} false; then :
|
|
@@ -21038,7 +21040,7 @@ return tgetent ();
|
|
return 0;
|
|
}
|
|
_ACEOF
|
|
-for ac_lib in '' termcap tinfow tinfo curses ncursesw ncurses; do
|
|
+for ac_lib in '' ncursesw; do
|
|
if test -z "$ac_lib"; then
|
|
ac_res="none required"
|
|
else
|
|
diff --git a/gdb/configure.ac b/gdb/configure.ac
|
|
--- a/gdb/configure.ac
|
|
+++ b/gdb/configure.ac
|
|
@@ -705,7 +705,8 @@ if test x"$prefer_curses" = xyes; then
|
|
# search /usr/local/include, if ncurses is installed in /usr/local. A
|
|
# default installation of ncurses on alpha*-dec-osf* will lead to such
|
|
# a situation.
|
|
- AC_SEARCH_LIBS(waddstr, [ncursesw ncurses cursesX curses])
|
|
+ # Fedora: Force libncursesw over libncurses to match the includes.
|
|
+ AC_SEARCH_LIBS(waddstr, [ncursesw])
|
|
|
|
if test "$ac_cv_search_waddstr" != no; then
|
|
curses_found=yes
|
|
@@ -747,7 +748,8 @@ case $host_os in
|
|
esac
|
|
|
|
# These are the libraries checked by Readline.
|
|
-AC_SEARCH_LIBS(tgetent, [termcap tinfow tinfo curses ncursesw ncurses])
|
|
+# Fedora: Force libncursesw over libncurses to match the includes.
|
|
+AC_SEARCH_LIBS(tgetent, [ncursesw])
|
|
|
|
if test "$ac_cv_search_tgetent" = no; then
|
|
CONFIG_OBS="$CONFIG_OBS stub-termcap.o"
|