e36d664785
- Fix /usr/bin/gdb-add-index missing -nx for gdb. - New option --with profile (disabled by default - missing workload, BZ 615603).
123 lines
3.9 KiB
Diff
123 lines
3.9 KiB
Diff
http://sourceware.org/ml/gdb-patches/2010-07/msg00184.html
|
|
Subject: Re: [0/4] RFC: add DWARF index support
|
|
|
|
Jan Kratochvil: Fixed $d -> $dir.
|
|
Jan Kratochvil: Remove /dev/null redirection.
|
|
|
|
>>>>> "Tom" == Tom Tromey <tromey@redhat.com> writes:
|
|
|
|
Tom> This patch series adds support for a DWARF index to gdb.
|
|
|
|
Roland suggested we wrap up the index-creation code into a helper
|
|
script.
|
|
|
|
I'm not sure if this is something people would want in gdb proper, but I
|
|
figured I would send it here just in case.
|
|
|
|
Tom
|
|
|
|
2010-07-09 Tom Tromey <tromey@redhat.com>
|
|
|
|
* Makefile.in (install-only): Install gdb-add-index.
|
|
* gdb-add-index: New file.
|
|
|
|
2010-07-09 Tom Tromey <tromey@redhat.com>
|
|
|
|
* gdb.texinfo (Index Files): Mention gdb-add-index.
|
|
|
|
>From 30714fe719e61baea03d0dc5793eb0d564faebb7 Mon Sep 17 00:00:00 2001
|
|
From: Tom Tromey <tromey@redhat.com>
|
|
Date: Fri, 9 Jul 2010 11:17:54 -0600
|
|
Subject: [PATCH 4/4] add gdb-add-index
|
|
Subject: [PATCH 4/4] add gdb-add-index
|
|
|
|
---
|
|
gdb/ChangeLog | 5 +++++
|
|
gdb/Makefile.in | 11 ++++++++++-
|
|
gdb/doc/ChangeLog | 4 ++++
|
|
gdb/doc/gdb.texinfo | 8 ++++++++
|
|
gdb/gdb-add-index | 30 ++++++++++++++++++++++++++++++
|
|
5 files changed, 57 insertions(+), 1 deletions(-)
|
|
create mode 100755 gdb/gdb-add-index
|
|
|
|
diff --git a/gdb/Makefile.in b/gdb/Makefile.in
|
|
index 6dbb284..8210a2c 100644
|
|
--- a/gdb/Makefile.in
|
|
+++ b/gdb/Makefile.in
|
|
@@ -1018,7 +1018,16 @@ install-only: $(CONFIG_INSTALL) xml-syscall-install
|
|
$(SHELL) $(srcdir)/../mkinstalldirs \
|
|
$(DESTDIR)$(man1dir) ; \
|
|
$(INSTALL_DATA) $(srcdir)/gdb.1 \
|
|
- $(DESTDIR)$(man1dir)/$$transformed_name.1
|
|
+ $(DESTDIR)$(man1dir)/$$transformed_name.1; \
|
|
+ transformed_name=`t='$(program_transform_name)'; \
|
|
+ echo gdb-add-index | sed -e "$$t"` ; \
|
|
+ if test "x$$transformed_name" = x; then \
|
|
+ transformed_name=gdb-add-index ; \
|
|
+ else \
|
|
+ true ; \
|
|
+ fi ; \
|
|
+ $(INSTALL_PROGRAM) $(srcdir)/gdb-add-index \
|
|
+ $(DESTDIR)$(bindir)/$$transformed_name$(EXEEXT)
|
|
@$(MAKE) DO=install "DODIRS=$(SUBDIRS)" $(FLAGS_TO_PASS) subdir_do
|
|
.PHONY: install-tui
|
|
install-tui:
|
|
diff --git a/gdb/doc/gdb.texinfo b/gdb/doc/gdb.texinfo
|
|
index 69141e3..457e6b4 100644
|
|
--- a/gdb/doc/gdb.texinfo
|
|
+++ b/gdb/doc/gdb.texinfo
|
|
@@ -15045,6 +15045,14 @@ There are currently some limitation on indices. They only work when
|
|
for DWARF debugging information, not stabs. And, they do not
|
|
currently work for programs using Ada.
|
|
|
|
+@value{GDBN} comes with a program, @command{gdb-add-index}, which can
|
|
+be used to add the index to a symbol file. It takes the symbol file
|
|
+as its only argument:
|
|
+
|
|
+@smallexample
|
|
+$ gdb-add-index symfile
|
|
+@end smallexample
|
|
+
|
|
|
|
@node Symbol Errors
|
|
@section Errors Reading Symbol Files
|
|
diff --git a/gdb/gdb-add-index b/gdb/gdb-add-index
|
|
new file mode 100755
|
|
index 0000000..c9a03b0
|
|
--- /dev/null
|
|
+++ b/gdb/gdb-add-index
|
|
@@ -0,0 +1,30 @@
|
|
+#! /bin/sh
|
|
+
|
|
+# Add a .gdb_index section to a file.
|
|
+
|
|
+# Copyright (C) 2010 Free Software Foundation, Inc.
|
|
+# This program is free software; you can redistribute it and/or modify
|
|
+# it under the terms of the GNU General Public License as published by
|
|
+# the Free Software Foundation; either version 3 of the License, or
|
|
+# (at your option) any later version.
|
|
+#
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+# GNU General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU General Public License
|
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
+
|
|
+file="$1"
|
|
+dir="${file%/*}"
|
|
+
|
|
+# We don't care if gdb gives an error.
|
|
+gdb -nx --batch-silent -ex "file $file" -ex "save gdb-index $dir"
|
|
+
|
|
+if test -f "${file}.gdb-index"; then
|
|
+ objcopy --add-section .gdb_index="${file}.gdb-index" --set-section-flags .gdb_index=readonly "$file" "$file"
|
|
+ rm -f "${file}.gdb-index"
|
|
+fi
|
|
+
|
|
+exit 0
|
|
--
|
|
1.6.2.5
|
|
|