2f7f533ae7
- Fix jit-reader.h for multi-lib.
41 lines
1.5 KiB
Diff
41 lines
1.5 KiB
Diff
diff --git a/gdb/configure b/gdb/configure
|
|
index 7ff74ba..00a5b5b 100755
|
|
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -7382,10 +7382,12 @@ _ACEOF
|
|
|
|
|
|
|
|
-if test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
- TARGET_PTR="unsigned long"
|
|
-elif test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
+# Try to keep TARGET_PTR the same across archs so that jit-reader.h file
|
|
+# content is the same for multilib distributions.
|
|
+if test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
TARGET_PTR="unsigned long long"
|
|
+elif test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
+ TARGET_PTR="unsigned long"
|
|
elif test "x${ac_cv_sizeof_unsigned___int128}" = "x16"; then
|
|
TARGET_PTR="unsigned __int128"
|
|
else
|
|
diff --git a/gdb/configure.ac b/gdb/configure.ac
|
|
index ec776d7..c02ace9 100644
|
|
--- a/gdb/configure.ac
|
|
+++ b/gdb/configure.ac
|
|
@@ -648,10 +648,12 @@ AC_CHECK_SIZEOF(unsigned long long)
|
|
AC_CHECK_SIZEOF(unsigned long)
|
|
AC_CHECK_SIZEOF(unsigned __int128)
|
|
|
|
-if test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
- TARGET_PTR="unsigned long"
|
|
-elif test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
+# Try to keep TARGET_PTR the same across archs so that jit-reader.h file
|
|
+# content is the same for multilib distributions.
|
|
+if test "x${ac_cv_sizeof_unsigned_long_long}" = "x8"; then
|
|
TARGET_PTR="unsigned long long"
|
|
+elif test "x${ac_cv_sizeof_unsigned_long}" = "x8"; then
|
|
+ TARGET_PTR="unsigned long"
|
|
elif test "x${ac_cv_sizeof_unsigned___int128}" = "x16"; then
|
|
TARGET_PTR="unsigned __int128"
|
|
else
|